aboutsummaryrefslogtreecommitdiff
path: root/textproc/rubygem-nokogiri18
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-03-02 17:44:46 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-03-02 17:44:46 +0000
commitdfc1d0e67442fb952fd26555a3c89f3cc64b54aa (patch)
tree27f0ff7bc2d9fd1e05610bcdaaf0e24caf69dca8 /textproc/rubygem-nokogiri18
parent9405a509cd7b4902c2e6793893bc0067db8cabfc (diff)
downloadports-dfc1d0e67442fb952fd26555a3c89f3cc64b54aa.tar.gz
ports-dfc1d0e67442fb952fd26555a3c89f3cc64b54aa.zip
Add rubygem-nokogiri18 1.8.5 (copied from rubygem-nokogiri)
- Add PORTSCOUT
Notes
Notes: svn path=/head/; revision=494421
Diffstat (limited to 'textproc/rubygem-nokogiri18')
-rw-r--r--textproc/rubygem-nokogiri18/Makefile32
-rw-r--r--textproc/rubygem-nokogiri18/distinfo3
-rw-r--r--textproc/rubygem-nokogiri18/files/patch-ext_nokogiri_extconf.rb46
-rw-r--r--textproc/rubygem-nokogiri18/files/patch-gemspec10
-rw-r--r--textproc/rubygem-nokogiri18/pkg-descr9
5 files changed, 100 insertions, 0 deletions
diff --git a/textproc/rubygem-nokogiri18/Makefile b/textproc/rubygem-nokogiri18/Makefile
new file mode 100644
index 000000000000..d7a711e94278
--- /dev/null
+++ b/textproc/rubygem-nokogiri18/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= nokogiri
+PORTVERSION= 1.8.5
+CATEGORIES= textproc rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 18
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= HTML, XML, SAX, and Reader parser
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+BUILD_DEPENDS= ${RUN_DEPENDS}
+LIB_DEPENDS= libgcrypt.so:security/libgcrypt
+RUN_DEPENDS= rubygem-pkg-config>=1.1.7:devel/rubygem-pkg-config
+
+USES= gem gnome pkgconfig
+USE_GNOME= libxml2 libxslt
+USE_RUBY= yes
+
+CONFIGURE_ARGS= --use-system-libraries
+
+PORTSCOUT= limit:^1\.8\.
+
+post-install:
+ ${FIND} ${STAGEDIR}${PREFIX}/${GEMS_BASE_DIR} -name '*.o' -o -name '*.so' | ${XARGS} ${STRIP_CMD}
+ ${RM} ${STAGEDIR}${PREFIX}/bin/nokogiri
+ ${RMDIR} ${STAGEDIR}${PREFIX}/${GEM_LIB_DIR}/ports/
+
+.include <bsd.port.mk>
diff --git a/textproc/rubygem-nokogiri18/distinfo b/textproc/rubygem-nokogiri18/distinfo
new file mode 100644
index 000000000000..fb5a5625d4b3
--- /dev/null
+++ b/textproc/rubygem-nokogiri18/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1540022382
+SHA256 (rubygem/nokogiri-1.8.5.gem) = 1f93a829257b621d40c4cbfce3acdcd688b0b3d70497ceae4fa2baf955eede2f
+SIZE (rubygem/nokogiri-1.8.5.gem) = 9279488
diff --git a/textproc/rubygem-nokogiri18/files/patch-ext_nokogiri_extconf.rb b/textproc/rubygem-nokogiri18/files/patch-ext_nokogiri_extconf.rb
new file mode 100644
index 000000000000..c5fa64d2780a
--- /dev/null
+++ b/textproc/rubygem-nokogiri18/files/patch-ext_nokogiri_extconf.rb
@@ -0,0 +1,46 @@
+--- ext/nokogiri/extconf.rb.orig 2017-09-20 14:58:44 UTC
++++ ext/nokogiri/extconf.rb
+@@ -658,6 +658,43 @@ have_func('xmlRelaxNGSetValidStructuredE
+ have_func('xmlSchemaSetValidStructuredErrors')
+ have_func('xmlSchemaSetParserStructuredErrors')
+
++$INSTALLFILES = [
++ ['html_document.h', '$(archdir)'],
++ ['html_element_description.h', '$(archdir)'],
++ ['html_entity_lookup.h', '$(archdir)'],
++ ['html_sax_parser_context.h', '$(archdir)'],
++ ['html_sax_push_parser.h', '$(archdir)'],
++ ['nokogiri.h', '$(archdir)'],
++ ['xml_attr.h', '$(archdir)'],
++ ['xml_attribute_decl.h', '$(archdir)'],
++ ['xml_cdata.h', '$(archdir)'],
++ ['xml_comment.h', '$(archdir)'],
++ ['xml_document.h', '$(archdir)'],
++ ['xml_document_fragment.h', '$(archdir)'],
++ ['xml_dtd.h', '$(archdir)'],
++ ['xml_element_content.h', '$(archdir)'],
++ ['xml_element_decl.h', '$(archdir)'],
++ ['xml_encoding_handler.h', '$(archdir)'],
++ ['xml_entity_decl.h', '$(archdir)'],
++ ['xml_entity_reference.h', '$(archdir)'],
++ ['xml_io.h', '$(archdir)'],
++ ['xml_libxml2_hacks.h', '$(archdir)'],
++ ['xml_namespace.h', '$(archdir)'],
++ ['xml_node.h', '$(archdir)'],
++ ['xml_node_set.h', '$(archdir)'],
++ ['xml_processing_instruction.h', '$(archdir)'],
++ ['xml_reader.h', '$(archdir)'],
++ ['xml_relax_ng.h', '$(archdir)'],
++ ['xml_sax_parser.h', '$(archdir)'],
++ ['xml_sax_parser_context.h', '$(archdir)'],
++ ['xml_sax_push_parser.h', '$(archdir)'],
++ ['xml_schema.h', '$(archdir)'],
++ ['xml_syntax_error.h', '$(archdir)'],
++ ['xml_text.h', '$(archdir)'],
++ ['xml_xpath_context.h', '$(archdir)'],
++ ['xslt_stylesheet.h', '$(archdir)'],
++]
++
+ create_makefile('nokogiri/nokogiri')
+
+ if enable_config('clean', true)
diff --git a/textproc/rubygem-nokogiri18/files/patch-gemspec b/textproc/rubygem-nokogiri18/files/patch-gemspec
new file mode 100644
index 000000000000..1339c204fbd0
--- /dev/null
+++ b/textproc/rubygem-nokogiri18/files/patch-gemspec
@@ -0,0 +1,10 @@
+--- nokogiri.gemspec.orig 2017-09-20 14:58:45 UTC
++++ nokogiri.gemspec
+@@ -27,7 +27,6 @@ Gem::Specification.new do |s|
+ s.specification_version = 4
+
+ if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
+- s.add_runtime_dependency(%q<mini_portile2>.freeze, ["~> 2.3.0"])
+ s.add_development_dependency(%q<hoe-bundler>.freeze, ["~> 1.2"])
+ s.add_development_dependency(%q<hoe-debugging>.freeze, ["~> 1.4"])
+ s.add_development_dependency(%q<hoe-gemspec>.freeze, ["~> 1.0"])
diff --git a/textproc/rubygem-nokogiri18/pkg-descr b/textproc/rubygem-nokogiri18/pkg-descr
new file mode 100644
index 000000000000..98806cf7d856
--- /dev/null
+++ b/textproc/rubygem-nokogiri18/pkg-descr
@@ -0,0 +1,9 @@
+* XPath support for document searching
+* CSS3 selector support for document searching
+* XML/HTML builder
+* Drop in replacement for Hpricot (though not bug for bug)
+
+Nokogiri parses and searches XML/HTML very quickly, and also has
+correctly implemented CSS3 selector support as well as XPath support.
+
+WWW: https://www.nokogiri.org/