aboutsummaryrefslogtreecommitdiff
path: root/textproc/rubygem-puppet-strings
diff options
context:
space:
mode:
authorRomain Tartière <romain@FreeBSD.org>2020-12-05 20:52:56 +0000
committerRomain Tartière <romain@FreeBSD.org>2020-12-05 20:52:56 +0000
commitdbe271208afd40b3c54e6256dbd9f8322c7d4093 (patch)
treeaad5e8d57d2bf3ffa7b6e899533ea4deb08ccd46 /textproc/rubygem-puppet-strings
parent29742375c8cd5afe927bc36e0a807697a326569e (diff)
downloadports-dbe271208afd40b3c54e6256dbd9f8322c7d4093.tar.gz
ports-dbe271208afd40b3c54e6256dbd9f8322c7d4093.zip
Make it possible to choose which version of Puppet to depend on
Since we do not change the default, no need to rebuild packages so no PORTREVISION bump. With hat: puppet
Notes
Notes: svn path=/head/; revision=557086
Diffstat (limited to 'textproc/rubygem-puppet-strings')
-rw-r--r--textproc/rubygem-puppet-strings/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/textproc/rubygem-puppet-strings/Makefile b/textproc/rubygem-puppet-strings/Makefile
index dee387cd17ae..ff54369d3adf 100644
--- a/textproc/rubygem-puppet-strings/Makefile
+++ b/textproc/rubygem-puppet-strings/Makefile
@@ -11,11 +11,22 @@ COMMENT= Puppet documentation extraction and presentation tool
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= puppet:sysutils/puppet6 \
- rubygem-rgen>=0:devel/rubygem-rgen \
+RUN_DEPENDS= rubygem-rgen>=0:devel/rubygem-rgen \
rubygem-yard>=0:textproc/rubygem-yard
USES= gem
USE_RUBY= yes
+OPTIONS_SINGLE= PUPPET
+OPTIONS_SINGLE_PUPPET=PUPPET5 PUPPET6 PUPPET7
+OPTIONS_DEFAULT=PUPPET6
+
+PUPPET5_DESC= Depend on sysutils/puppet5
+PUPPET6_DESC= Depend on sysutils/puppet6
+PUPPET7_DESC= Depend on sysutils/puppet7
+
+PUPPET5_RUN_DEPENDS=puppet:sysutils/puppet5
+PUPPET6_RUN_DEPENDS=puppet:sysutils/puppet6
+PUPPET7_RUN_DEPENDS=puppet:sysutils/puppet7
+
.include <bsd.port.mk>