aboutsummaryrefslogtreecommitdiff
path: root/textproc/saxon-he
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2004-11-09 16:03:39 +0000
committerHerve Quiroz <hq@FreeBSD.org>2004-11-09 16:03:39 +0000
commit3b359db6cceb43e3f2614e0e0b0dc8433445d286 (patch)
tree5ada1fd75558a702b940f8aaf8e7ae168d6bfa75 /textproc/saxon-he
parenta9db29ea5edf14352d86191e38ac80440152a25d (diff)
downloadports-3b359db6cceb43e3f2614e0e0b0dc8433445d286.tar.gz
ports-3b359db6cceb43e3f2614e0e0b0dc8433445d286.zip
Notes
Diffstat (limited to 'textproc/saxon-he')
-rw-r--r--textproc/saxon-he/Makefile6
-rw-r--r--textproc/saxon-he/files/saxon.sh10
2 files changed, 11 insertions, 5 deletions
diff --git a/textproc/saxon-he/Makefile b/textproc/saxon-he/Makefile
index 215907972a6b..3804c8c4bb46 100644
--- a/textproc/saxon-he/Makefile
+++ b/textproc/saxon-he/Makefile
@@ -16,8 +16,7 @@ DISTNAME= ${PORTNAME}b${PORTVERSION:S,.,-,g}
MAINTAINER= hq@FreeBSD.org
COMMENT= An XSLT 2.0 / XPath 2.0 / XQuery 1.0 processor for Java
-RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper \
- ${JAVALIBDIR}/xml-apis.jar:${PORTSDIR}/textproc/xerces-j
+RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper
USE_ZIP= yes
USE_JAVA= yes
@@ -34,7 +33,8 @@ PORTDOCS= background documentation img javadoc
.endif
do-configure:
- @${SED} 's|%%LOCALBASE%%|${LOCALBASE}|g ; s|%%JAVAVM%%|${JAVA}|g' \
+ @${SED} -e 's|%%LOCALBASE%%|${LOCALBASE}|g ; s|%%JAVAVM%%|${JAVA}|g ; \
+ s|%%SAXON_JARS%%|${JARFILES:S,^,${JAVAJARDIR}/,}|' \
${FILESDIR}/saxon.sh >${WRKSRC}/saxon
do-install:
diff --git a/textproc/saxon-he/files/saxon.sh b/textproc/saxon-he/files/saxon.sh
index 7b7e03dbdb28..2f8fa270f061 100644
--- a/textproc/saxon-he/files/saxon.sh
+++ b/textproc/saxon-he/files/saxon.sh
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# $FreeBSD: /tmp/pcvs/ports/textproc/saxon-he/files/Attic/saxon.sh,v 1.3 2004-10-27 16:50:43 hq Exp $
+# $FreeBSD: /tmp/pcvs/ports/textproc/saxon-he/files/Attic/saxon.sh,v 1.4 2004-11-09 16:03:39 hq Exp $
IAM=`basename "$0"`
@@ -11,4 +11,10 @@ else
LAUNCHER_CLASS="net.sf.saxon.Transform"
fi
-JAVAVM=%%JAVAVM%% %%LOCALBASE%%/bin/javavm -classpath "`%%LOCALBASE%%/bin/classpath`" ${LAUNCHER_CLASS} $@
+SAXON_CLASSPATH=""
+for jarfile in %%SAXON_JARS%%
+do
+ SAXON_CLASSPATH="${SAXON_CLASSPATH}:${jarfile}"
+done
+
+JAVAVM="%%JAVAVM%%" "%%LOCALBASE%%/bin/javavm" -classpath "${SAXON_CLASSPATH}" "${LAUNCHER_CLASS}" "$@"