aboutsummaryrefslogtreecommitdiff
path: root/textproc/scdoc
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-01-06 13:28:24 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-01-06 13:28:24 +0000
commit71c50e1481cad3a5996d992b75752ec83387f8e1 (patch)
treebc88550ca6f3d51d1578cf565b9425e9ae8afdcf /textproc/scdoc
parent8520857832864d87abc9da65a9efb4903860943e (diff)
downloadports-71c50e1481cad3a5996d992b75752ec83387f8e1.tar.gz
ports-71c50e1481cad3a5996d992b75752ec83387f8e1.zip
x11-wm/sway: add new port
Sway is a tiling Wayland compositor and a drop-in replacement for the i3 window manager for X11. It works with your existing i3 configuration and supports most of i3's features, plus a few extras. https://swaywm.org/
Notes
Notes: svn path=/head/; revision=489493
Diffstat (limited to 'textproc/scdoc')
-rw-r--r--textproc/scdoc/Makefile30
-rw-r--r--textproc/scdoc/distinfo3
-rw-r--r--textproc/scdoc/pkg-descr3
3 files changed, 36 insertions, 0 deletions
diff --git a/textproc/scdoc/Makefile b/textproc/scdoc/Makefile
new file mode 100644
index 000000000000..ceeb3eaf4472
--- /dev/null
+++ b/textproc/scdoc/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= scdoc
+DISTVERSION= 1.6.0
+CATEGORIES= textproc
+MASTER_SITES= https://git.sr.ht/~sircmpwn/${PORTNAME}/archive/
+DISTFILES= ${DISTVERSIONFULL}${EXTRACT_SUFX}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Simple man page generator for POSIX systems written in C99
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= gmake
+TEST_TARGET= check
+PLIST_FILES= bin/scdoc \
+ man/man1/scdoc.1.gz \
+ man/man5/scdoc.5.gz
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,share/man,man,' \
+ -e '/BIN/s,install -Dm755,${INSTALL_PROGRAM},' \
+ -e '/MAN/s,install -Dm644,${INSTALL_MAN},' \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -i '' 's,--date=,-f "%F %T %z" ,' \
+ ${WRKSRC}/test/preamble
+
+.include <bsd.port.mk>
diff --git a/textproc/scdoc/distinfo b/textproc/scdoc/distinfo
new file mode 100644
index 000000000000..dd95f928762b
--- /dev/null
+++ b/textproc/scdoc/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1542554764
+SHA256 (scdoc/1.6.0.tar.gz) = a396bc070c8734d7cafe3a3481c8cffacd83b3effdeb28de43e2cdac889643b1
+SIZE (scdoc/1.6.0.tar.gz) = 10937
diff --git a/textproc/scdoc/pkg-descr b/textproc/scdoc/pkg-descr
new file mode 100644
index 000000000000..a7f6cd99365c
--- /dev/null
+++ b/textproc/scdoc/pkg-descr
@@ -0,0 +1,3 @@
+scdoc is a simple man page generator for POSIX systems written in C99.
+
+WWW: https://git.sr.ht/~sircmpwn/scdoc/