aboutsummaryrefslogtreecommitdiff
path: root/textproc/scim-openvanilla/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-05-27 08:55:56 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-05-27 08:55:56 +0000
commitd907fad14d62ab041398d5503715645e1def8e4e (patch)
tree9e86444deae73d97252e5e9c4665cf663b841306 /textproc/scim-openvanilla/Makefile
parent1f81a11d9c419719920349c5c6bb2b843fc7a285 (diff)
Notes
Diffstat (limited to 'textproc/scim-openvanilla/Makefile')
-rw-r--r--textproc/scim-openvanilla/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/textproc/scim-openvanilla/Makefile b/textproc/scim-openvanilla/Makefile
index f028004294f5..a238b7206934 100644
--- a/textproc/scim-openvanilla/Makefile
+++ b/textproc/scim-openvanilla/Makefile
@@ -6,29 +6,32 @@
#
PORTNAME= scim-openvanilla
-PORTVERSION= 0.7.2.b20060214
-PORTREVISION= 4
+PORTVERSION= 0.7.2.20070514
CATEGORIES= textproc
-MASTER_SITES= http://www.csie.org/~llwang/ \
- http://www.infor.org/~llwang/
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= rafan
DISTNAME= openvanilla-${PORTVERSION}
MAINTAINER= llwang@infor.org
COMMENT= SCIM OpenVanilla input method (IM)/output filter (OF) framework
BUILD_DEPENDS= scim:${PORTSDIR}/textproc/scim \
- ${X11BASE}/include/OpenVanilla/OpenVanilla.h:${PORTSDIR}/textproc/openvanilla-framework
+ ${LOCALBASE}/include/OpenVanilla/OpenVanilla.h:${PORTSDIR}/textproc/openvanilla-framework
RUN_DEPENDS= scim:${PORTSDIR}/textproc/scim
+LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
USE_AUTOTOOLS= libltdl:15
WRKSRC= ${WRKDIR}/${DISTNAME}/Loaders/SCIM
USE_GMAKE= yes
USE_GNOME= pkgconfig
+USE_GETTEXT= yes
+USE_ICONV= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CPPFLAGS=-I${X11BASE}/include \
+CONFIGURE_ENV+= CPPFLAGS=-I${LOCALBASE}/include \
OV_MODULEDIR=${PREFIX}/lib/openvanilla/
-post-patch:
- @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure
+PLIST_FILES= lib/scim-1.0/1.4.0/IMEngine/OVLoader-SCIM.a \
+ lib/scim-1.0/1.4.0/IMEngine/OVLoader-SCIM.la \
+ lib/scim-1.0/1.4.0/IMEngine/OVLoader-SCIM.so
.include <bsd.port.mk>