aboutsummaryrefslogtreecommitdiff
path: root/textproc/sift
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-11-24 22:28:25 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-11-24 22:28:25 +0000
commit8a6ceda059bc6ada419950cf2a5af6b3d00fdf35 (patch)
tree53392f852501f31a0ef69d630e58fc2927b2f6b9 /textproc/sift
parent8c4b022298092c9cd48d2077c143b80a57997a7c (diff)
downloadports-8a6ceda059bc6ada419950cf2a5af6b3d00fdf35.tar.gz
ports-8a6ceda059bc6ada419950cf2a5af6b3d00fdf35.zip
Add sift 0.9.0
sift has a slightly different focus than most other grep alternatives. Code search, log search / digital forensics and data processing are the main use cases, but the primary goal is to provide safe defaults and to make it easily configurable for a specific use case. Among the features are: - Stable releases, cross platform support - Safe defaults: sift searches everywhere if not configured otherwise - Complete & working .gitignore support - High performance for many uses cases - Support for adding custom file types to narrow down searches - Multiline support - Support for big files: >50GB, >5,000,000,000 lines and >5,000,000,000 matches successfully tested WWW: https://github.com/svent/sift
Notes
Notes: svn path=/head/; revision=485802
Diffstat (limited to 'textproc/sift')
-rw-r--r--textproc/sift/Makefile31
-rw-r--r--textproc/sift/distinfo11
-rw-r--r--textproc/sift/pkg-descr14
3 files changed, 56 insertions, 0 deletions
diff --git a/textproc/sift/Makefile b/textproc/sift/Makefile
new file mode 100644
index 000000000000..5b74066261e5
--- /dev/null
+++ b/textproc/sift/Makefile
@@ -0,0 +1,31 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= sift
+PORTVERSION= 0.9.0
+DISTVERSIONPREFIX= v
+CATEGORIES= textproc
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Fast and powerful open source alternative to grep
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go
+
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${GH_PROJECT}
+
+PLIST_FILES= bin/sift
+
+GH_ACCOUNT= svent
+GH_TUPLE= golang:crypto:3d3f9f4:golang_crypto/../src/golang.org/x/crypto \
+ golang:sys:62eef0e:golang_sys/../src/golang.org/x/sys \
+ svent:go-flags:4bcbad3:svent_goflags/../src/github.com/svent/go-flags \
+ svent:go-nbreader:7cef48d:svent_gonbreader/../src/github.com/svent/go-nbreader
+USE_GITHUB= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${GO_WRKDIR_BIN}/sift ${STAGEDIR}${PREFIX}/bin/sift
+
+.include <bsd.port.mk>
diff --git a/textproc/sift/distinfo b/textproc/sift/distinfo
new file mode 100644
index 000000000000..0ee699396a68
--- /dev/null
+++ b/textproc/sift/distinfo
@@ -0,0 +1,11 @@
+TIMESTAMP = 1543074658
+SHA256 (svent-sift-v0.9.0_GH0.tar.gz) = bbbd5c472c36b78896cd7ae673749d3943621a6d5523d47973ed2fc6800ae4c8
+SIZE (svent-sift-v0.9.0_GH0.tar.gz) = 37442
+SHA256 (golang-crypto-3d3f9f4_GH0.tar.gz) = 4cac408ad0b69d6117d973764bc8dab1f9cf5bee6bf7c78041459241afa0b414
+SIZE (golang-crypto-3d3f9f4_GH0.tar.gz) = 1644646
+SHA256 (golang-sys-62eef0e_GH0.tar.gz) = ad3c32771a961d18cb8a1ae96c56e8927f49bc97f281a3f6333c05c4ee32d005
+SIZE (golang-sys-62eef0e_GH0.tar.gz) = 1115440
+SHA256 (svent-go-flags-4bcbad3_GH0.tar.gz) = 8fb342e5d1ad220c7040a6f185f39a38679f9c88e24716fcc6f2fef2ee09825a
+SIZE (svent-go-flags-4bcbad3_GH0.tar.gz) = 45988
+SHA256 (svent-go-nbreader-7cef48d_GH0.tar.gz) = 62e0248ba434aa54461f554afc532cd5a4393ce55c35fdf750175fa14f997448
+SIZE (svent-go-nbreader-7cef48d_GH0.tar.gz) = 2777
diff --git a/textproc/sift/pkg-descr b/textproc/sift/pkg-descr
new file mode 100644
index 000000000000..9bd03b4c9ea5
--- /dev/null
+++ b/textproc/sift/pkg-descr
@@ -0,0 +1,14 @@
+sift has a slightly different focus than most other grep alternatives. Code
+search, log search / digital forensics and data processing are the main use
+cases, but the primary goal is to provide safe defaults and to make it easily
+configurable for a specific use case. Among the features are:
+- Stable releases, cross platform support
+- Safe defaults: sift searches everywhere if not configured otherwise
+- Complete & working .gitignore support
+- High performance for many uses cases
+- Support for adding custom file types to narrow down searches
+- Multiline support
+- Support for big files: >50GB, >5,000,000,000 lines and >5,000,000,000 matches
+ successfully tested
+
+WWW: https://github.com/svent/sift