aboutsummaryrefslogtreecommitdiff
path: root/textproc/sigil
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-07-10 05:54:30 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-07-10 05:54:30 +0000
commit63c31ee5feed6e1b616ae67c5960fa130647b8d2 (patch)
tree49d7b79a4c7ef355fc286681f22eb7c74bcfd3a3 /textproc/sigil
parent231884223e4ad4bc064ea2cce78fa868351a0637 (diff)
downloadports-63c31ee5feed6e1b616ae67c5960fa130647b8d2.tar.gz
ports-63c31ee5feed6e1b616ae67c5960fa130647b8d2.zip
textproc/sigil: Fix Preview Mode with Qt5.15
Fix the preview panel on the right due to a behavioral change in Qt5.15 PR: 247864 Submitted by: jonc@chen.org.nz (maintainer)
Notes
Notes: svn path=/head/; revision=541840
Diffstat (limited to 'textproc/sigil')
-rw-r--r--textproc/sigil/Makefile5
-rw-r--r--textproc/sigil/files/patch-local-content12
2 files changed, 15 insertions, 2 deletions
diff --git a/textproc/sigil/Makefile b/textproc/sigil/Makefile
index b123354a2391..3b9f69ae1995 100644
--- a/textproc/sigil/Makefile
+++ b/textproc/sigil/Makefile
@@ -3,6 +3,7 @@
PORTNAME= sigil
PORTVERSION= 1.2.1
+PORTREVISION= 1
CATEGORIES= textproc
MAINTAINER= jonc@chen.org.nz
@@ -27,6 +28,8 @@ USE_GITHUB= yes
GH_ACCOUNT= Sigil-Ebook
GH_PROJECT= Sigil
+USE_LDCONFIG= ${PREFIX}/lib/sigil
+
USE_QT= concurrent core declarative gui location network printsupport \
svg webchannel webengine widgets xml xmlpatterns \
buildtools_build linguisttools_build qmake_build \
@@ -34,8 +37,6 @@ USE_QT= concurrent core declarative gui location network printsupport \
CMAKE_ARGS= -DUSE_SYSTEM_LIBS:BOOL=1
-USE_LDCONFIG= ${PREFIX}/lib/sigil
-
# Upstream uses pkg-config output to pass libhunspell-1.7.so and
# libpcre16.so to the linker. pkg-config output does not include full
# paths, so add a workaround to keep the port linking for now.
diff --git a/textproc/sigil/files/patch-local-content b/textproc/sigil/files/patch-local-content
new file mode 100644
index 000000000000..38af417a2689
--- /dev/null
+++ b/textproc/sigil/files/patch-local-content
@@ -0,0 +1,12 @@
+diff -ruN ../Sigil-1.2.1/src/MainUI/MainWindow.cpp ./src/MainUI/MainWindow.cpp
+--- ../Sigil-1.2.1/src/MainUI/MainWindow.cpp 2020-03-30 09:54:01.000000000 +1300
++++ ./src/MainUI/MainWindow.cpp 2020-07-09 15:23:47.027951000 +1200
+@@ -4277,7 +4277,7 @@
+ web_settings->setAttribute(QWebEngineSettings::JavascriptCanOpenWindows, false);
+ web_settings->setAttribute(QWebEngineSettings::JavascriptCanAccessClipboard, false);
+ web_settings->setAttribute(QWebEngineSettings::LocalContentCanAccessRemoteUrls, (settings.remoteOn() == 1));
+- web_settings->setAttribute(QWebEngineSettings::LocalContentCanAccessFileUrls, false);
++ web_settings->setAttribute(QWebEngineSettings::LocalContentCanAccessFileUrls, true);
+ web_settings->setAttribute(QWebEngineSettings::PluginsEnabled, false);
+ web_settings->setAttribute(QWebEngineSettings::AutoLoadIconsForPage, false);
+ web_settings->setAttribute(QWebEngineSettings::FocusOnNavigationEnabled, true);