aboutsummaryrefslogtreecommitdiff
path: root/textproc/spiff
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2015-05-06 17:42:40 +0000
committerSteve Wills <swills@FreeBSD.org>2015-05-06 17:42:40 +0000
commit73036258707ae064639be8e8a8f10f5803fd8e15 (patch)
tree2bd339d49dc7de4fd2dec59ff5cbef28bfec8b3c /textproc/spiff
parentdf2a0e42351c2f3401a0fbbe636c97cc141a5cc9 (diff)
downloadports-73036258707ae064639be8e8a8f10f5803fd8e15.tar.gz
ports-73036258707ae064639be8e8a8f10f5803fd8e15.zip
textproc/spiff: add port
A declarative YAML templating system tuned for BOSH deployment manifests. WWW: https://github.com/cloudfoundry-incubator/spiff
Notes
Notes: svn path=/head/; revision=385531
Diffstat (limited to 'textproc/spiff')
-rw-r--r--textproc/spiff/Makefile55
-rw-r--r--textproc/spiff/distinfo2
-rw-r--r--textproc/spiff/pkg-descr3
3 files changed, 60 insertions, 0 deletions
diff --git a/textproc/spiff/Makefile b/textproc/spiff/Makefile
new file mode 100644
index 000000000000..b06a77698f08
--- /dev/null
+++ b/textproc/spiff/Makefile
@@ -0,0 +1,55 @@
+# $FreeBSD$
+
+PORTNAME= spiff
+PORTVERSION= 1.0.6
+DISTVERSIONPREFIX= v
+CATEGORIES= textproc
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= Declarative YAML templating system tuned for BOSH deployment manifests
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/go:${PORTSDIR}/lang/go
+
+USE_GITHUB= yes
+GH_ACCOUNT= cloudfoundry-incubator
+GH_PROJECT= spiff
+
+PLIST_FILES= bin/spiff
+
+PORTDOCS= LICENSE README.md examples/cf-aws.yml \
+ examples/multi-az-cf-aws.yml examples/tutorial.md
+
+STRIP= # stripping can break go binaries
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @cd ${WRKSRC} ; ${MKDIR} src/github.com/${GH_ACCOUNT}/${GH_PROJECT} ; \
+ ${MV} .gitignore .travis.yml Godeps LICENSE Makefile README.md \
+ compare dynaml examples flow init_test.go scripts spiff.go \
+ spiff_test.go yaml \
+ src/github.com/${GH_ACCOUNT}/${GH_PROJECT}
+ @${MV} ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${GH_PROJECT}/Godeps/_workspace/src/github.com/${GH_ACCOUNT}/candiedyaml \
+ ${WRKSRC}/src/github.com/${GH_ACCOUNT}
+ @${MV} ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${GH_PROJECT}/Godeps/_workspace/src/github.com/codegangsta \
+ ${WRKSRC}/src/github.com
+
+do-build:
+ @cd ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${GH_PROJECT} ; \
+ ${SETENV} GOPATH=${WRKSRC} go build spiff.go
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${GH_PROJECT}/${PORTNAME} \
+ ${STAGEDIR}${PREFIX}/bin/
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${CP} ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${GH_PROJECT}/LICENSE \
+ ${STAGEDIR}${DOCSDIR}
+ ${CP} ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${GH_PROJECT}/README.md \
+ ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${GH_PROJECT} && ${COPYTREE_SHARE} examples ${STAGEDIR}${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/spiff/distinfo b/textproc/spiff/distinfo
new file mode 100644
index 000000000000..9d82f1f6c698
--- /dev/null
+++ b/textproc/spiff/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cloudfoundry-incubator-spiff-v1.0.6_GH0.tar.gz) = b63437485708b4df5e2515276bb0080b565959f7d82799d85e16e20323fb9617
+SIZE (cloudfoundry-incubator-spiff-v1.0.6_GH0.tar.gz) = 280939
diff --git a/textproc/spiff/pkg-descr b/textproc/spiff/pkg-descr
new file mode 100644
index 000000000000..9a0d3ac97927
--- /dev/null
+++ b/textproc/spiff/pkg-descr
@@ -0,0 +1,3 @@
+A declarative YAML templating system tuned for BOSH deployment manifests.
+
+WWW: https://github.com/cloudfoundry-incubator/spiff