aboutsummaryrefslogtreecommitdiff
path: root/textproc/stardict3/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-09-03 13:16:18 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-09-03 13:16:18 +0000
commit5d63e0f747058c7981b6a37c8d686aca947bcc1c (patch)
treeaf2ee884c0f6c23965b28a43816c340f81ad6056 /textproc/stardict3/Makefile
parenta6b2e80a0130453030d1009048b6d9f85bbc695c (diff)
downloadports-5d63e0f747058c7981b6a37c8d686aca947bcc1c.tar.gz
ports-5d63e0f747058c7981b6a37c8d686aca947bcc1c.zip
Notes
Diffstat (limited to 'textproc/stardict3/Makefile')
-rw-r--r--textproc/stardict3/Makefile20
1 files changed, 7 insertions, 13 deletions
diff --git a/textproc/stardict3/Makefile b/textproc/stardict3/Makefile
index 8deb12899673..2da534382655 100644
--- a/textproc/stardict3/Makefile
+++ b/textproc/stardict3/Makefile
@@ -19,13 +19,11 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-festival \
--disable-gucharmap \
--disable-espeak \
+ --disable-tools \
--disable-updateinfo
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
USES= gettext gmake libtool pathfix pkgconfig tar:bzip2
-CONFIGURE_WRKSRC= ${WRKSRC}/dict
-BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
-INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
PROJECTHOST= stardict-3
@@ -39,25 +37,21 @@ GCONF_SCHEMAS= stardict.schemas
INSTALLS_OMF= yes
PLIST_SUB= GNOME=""
.else
-USE_AUTOTOOLS= autoconf
USE_GNOME+= gtk20
-CONFIGURE_ARGS+=--disable-gnome-support --disable-schemas-install
+CONFIGURE_ARGS+=--disable-gnome-support --disable-schemas-install \
+ --disable-scrollkeeper
PLIST_SUB= GNOME="@comment "
-MAKE_ARGS+= AUTOMAKE="${TRUE}" ACLOCAL="${TRUE}"
.endif
post-patch:
.if !${PORT_OPTIONS:MGNOME}
@${REINPLACE_CMD} -e '/^SUBDIRS/s,help,,' ${WRKSRC}/dict/Makefile.in
- @${REINPLACE_CMD} -e '/^GNOME_DOC_INIT/d' \
- -e '/^help\/Makefile/d' ${WRKSRC}/dict/configure.ac
.endif
@${REINPLACE_CMD} -e 's,/usr/share,${PREFIX}/share,g' \
${WRKSRC}/dict/src/conf.cpp
-
-pre-configure:
- cd ${WRKSRC}/lib && \
- ${SETENV} ${CONFIGURE_ENV} ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS} && \
- ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS} ${ALL_TARGET}
+ @${REINPLACE_CMD} \
+ -e '/as_fn_error.*gnome-doc-utils/d' \
+ -e '/DEP_MODULES=/s/"$$/ gmodule-2.0"/' \
+ ${WRKSRC}/dict/configure
.include <bsd.port.mk>