aboutsummaryrefslogtreecommitdiff
path: root/textproc/sxml
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2014-08-24 07:25:09 +0000
committerThomas Zander <riggs@FreeBSD.org>2014-08-24 07:25:09 +0000
commitcb184d5ec9ad1ed49b2db07b7ca0a994d748e646 (patch)
tree202a457109a892b3aa9a6c07f243157b61a51308 /textproc/sxml
parent17622ffefd03f25d43e6f5bc195cc554d53daa6c (diff)
downloadports-cb184d5ec9ad1ed49b2db07b7ca0a994d748e646.tar.gz
ports-cb184d5ec9ad1ed49b2db07b7ca0a994d748e646.zip
- Update to upstream version 1.0.6
- Add LICENSE - Stagify - Pet portlint PR: 192811 Submitted by: tkato432@yahoo.com Approved by: mentors (implicit)
Notes
Notes: svn path=/head/; revision=365899
Diffstat (limited to 'textproc/sxml')
-rw-r--r--textproc/sxml/Makefile11
-rw-r--r--textproc/sxml/distinfo4
-rw-r--r--textproc/sxml/files/patch-Makefile.in85
-rw-r--r--textproc/sxml/pkg-descr8
4 files changed, 99 insertions, 9 deletions
diff --git a/textproc/sxml/Makefile b/textproc/sxml/Makefile
index 3d93807814bb..59d53e8e5910 100644
--- a/textproc/sxml/Makefile
+++ b/textproc/sxml/Makefile
@@ -2,16 +2,21 @@
# $FreeBSD$
PORTNAME= sxml
-PORTVERSION= 1.0.5
+PORTVERSION= 1.0.6
CATEGORIES= textproc
MASTER_SITES= http://www.MysticWALL.COM/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= Skimpy XML parsing and grafting library for C language
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= tar:bzip2
GNU_CONFIGURE= yes
-USES= tar:bzip2
USE_LDCONFIG= yes
-NO_STAGE= yes
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libsxml*.so.[0-9]*
+
.include <bsd.port.mk>
diff --git a/textproc/sxml/distinfo b/textproc/sxml/distinfo
index 107613ef0479..294428bd446e 100644
--- a/textproc/sxml/distinfo
+++ b/textproc/sxml/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sxml-1.0.5.tar.bz2) = de36369e23e8a594cab54e737a29e7e102376eaad89c75035e772fbdd44c6b42
-SIZE (sxml-1.0.5.tar.bz2) = 61771
+SHA256 (sxml-1.0.6.tar.bz2) = e26a960bd6c24021dd83c4da4d2a8006ed3b92e0a9ac85b17358e473000260d0
+SIZE (sxml-1.0.6.tar.bz2) = 82316
diff --git a/textproc/sxml/files/patch-Makefile.in b/textproc/sxml/files/patch-Makefile.in
new file mode 100644
index 000000000000..91995c0162e1
--- /dev/null
+++ b/textproc/sxml/files/patch-Makefile.in
@@ -0,0 +1,85 @@
+--- Makefile.in.orig
++++ Makefile.in
+@@ -30,11 +30,11 @@
+ EDITOR=@EDITOR@
+
+ INSTALL=@INSTALL@
+-INSTALL_PROGRAM=@INSTALL_PROGRAM@ -s
++INSTALL_PROGRAM=@INSTALL_PROGRAM@
+ INSTALL_DATA=@INSTALL_DATA@
+
+ DEFS= @DEFS@
+-OPTS= -fforce-mem -fforce-addr -fstrength-reduce -funroll-loops -finline-functions
++OPTS= -fstrength-reduce -funroll-loops -finline-functions
+ CPPFLAGS= -I@srcdir@
+ CFLAGS= ${DEFS} ${CPPFLAGS} ${OPTS} @CFLAGS@
+
+@@ -121,43 +121,43 @@
+ install:: check-dirs install-libsxml install-libsxmlrpc
+
+ install-libsxml::
+- -${RM} ${libdir}/${SXML_PLIB}
+- ${INSTALL_DATA} ${SXML_PLIB} ${libdir}
+- ${RANLIB} -t ${libdir}/${SXML_PLIB}
+- -${RM} ${libdir}/${SXML_SLIB}
+- -${RM} ${libdir}/${SXML_DLIB}
+- -${RM} ${libdir}/${SXML_LIB}
++ -${RM} ${DESTDIR}${libdir}/${SXML_PLIB}
++ ${INSTALL_DATA} ${SXML_PLIB} ${DESTDIR}${libdir}
++ ${RANLIB} -t ${DESTDIR}${libdir}/${SXML_PLIB}
++ -${RM} ${DESTDIR}${libdir}/${SXML_SLIB}
++ -${RM} ${DESTDIR}${libdir}/${SXML_DLIB}
++ -${RM} ${DESTDIR}${libdir}/${SXML_LIB}
+ if [ -f ${SXML_SLIB} ]; then \
+- ${INSTALL} ${SXML_SLIB} ${libdir}; \
+- (cd ${libdir}; ${LN_S} ${SXML_SLIB} ${SXML_LIB}); \
++ ${INSTALL} ${SXML_SLIB} ${DESTDIR}${libdir}; \
++ (cd ${DESTDIR}${libdir}; ${LN_S} ${SXML_SLIB} ${SXML_LIB}); \
+ fi
+ if [ -f ${SXML_DYLIB} ]; then \
+- ${INSTALL} ${SXML_DYLIB} ${libdir}; \
+- (cd ${libdir}; ${LN_S} ${SXML_DYLIB} ${SXML_DLIB}); \
++ ${INSTALL} ${SXML_DYLIB} ${DESTDIR}${libdir}; \
++ (cd ${DESTDIR}${libdir}; ${LN_S} ${SXML_DYLIB} ${SXML_DLIB}); \
+ fi
+- ${INSTALL_DATA} ${SXML_HDR} ${includedir}
++ ${INSTALL_DATA} ${SXML_HDR} ${DESTDIR}${includedir}
+
+ install-libsxmlrpc::
+- -${RM} ${libdir}/${SXMLRPC_PLIB}
+- ${INSTALL_DATA} ${SXMLRPC_PLIB} ${libdir}
+- ${RANLIB} -t ${libdir}/${SXMLRPC_PLIB}
+- -${RM} ${libdir}/${SXMLRPC_SLIB}
+- -${RM} ${libdir}/${SXMLRPC_DLIB}
+- -${RM} ${libdir}/${SXMLRPC_LIB}
++ -${RM} ${DESTDIR}${libdir}/${SXMLRPC_PLIB}
++ ${INSTALL_DATA} ${SXMLRPC_PLIB} ${DESTDIR}${libdir}
++ ${RANLIB} -t ${DESTDIR}${libdir}/${SXMLRPC_PLIB}
++ -${RM} ${DESTDIR}${libdir}/${SXMLRPC_SLIB}
++ -${RM} ${DESTDIR}${libdir}/${SXMLRPC_DLIB}
++ -${RM} ${DESTDIR}${libdir}/${SXMLRPC_LIB}
+ if [ -f ${SXMLRPC_SLIB} ]; then \
+- ${INSTALL} ${SXMLRPC_SLIB} ${libdir}; \
+- (cd ${libdir}; ${LN_S} ${SXMLRPC_SLIB} ${SXMLRPC_LIB}); \
++ ${INSTALL} ${SXMLRPC_SLIB} ${DESTDIR}${libdir}; \
++ (cd ${DESTDIR}${libdir}; ${LN_S} ${SXMLRPC_SLIB} ${SXMLRPC_LIB}); \
+ fi
+ if [ -f ${SXMLRPC_DYLIB} ]; then \
+- ${INSTALL} ${SXMLRPC_DYLIB} ${libdir}; \
+- (cd ${libdir}; ${LN_S} ${SXMLRPC_DYLIB} ${SXMLRPC_DLIB}); \
++ ${INSTALL} ${SXMLRPC_DYLIB} ${DESTDIR}${libdir}; \
++ (cd ${DESTDIR}${libdir}; ${LN_S} ${SXMLRPC_DYLIB} ${SXMLRPC_DLIB}); \
+ fi
+- ${INSTALL_DATA} ${SXMLRPC_HDR} ${includedir}
++ ${INSTALL_DATA} ${SXMLRPC_HDR} ${DESTDIR}${includedir}
+
+ check-dirs::
+- @if [ ! -d ${prefix} ]; then ${MKDIR} ${prefix}; fi
+- @if [ ! -d ${libdir} ]; then ${MKDIR} ${libdir}; fi
+- @if [ ! -d ${includedir} ]; then ${MKDIR} ${includedir}; fi
++ @if [ ! -d ${DESTDIR}${prefix} ]; then ${MKDIR} ${DESTDIR}${prefix}; fi
++ @if [ ! -d ${DESTDIR}${libdir} ]; then ${MKDIR} ${DESTDIR}${libdir}; fi
++ @if [ ! -d ${DESTDIR}${includedir} ]; then ${MKDIR} ${DESTDIR}${includedir}; fi
+
+ ###############################################################################
+
diff --git a/textproc/sxml/pkg-descr b/textproc/sxml/pkg-descr
index 2a74f31039b3..33e8444118bc 100644
--- a/textproc/sxml/pkg-descr
+++ b/textproc/sxml/pkg-descr
@@ -1,5 +1,5 @@
-SXML is a skimpy XML parsing and grafting C library that you can use to read
-and write XML-like configuration file for your application.
+SXML is a skimpy XML parsing and grafting C library that you can use
+to read and write XML-like configuration file for your application.
-Author: Kouichi ABE (WALL) <kouichi@MysticWALL.COM>
-WWW: http://www.MysticWALL.COM/software/sxml/index.html
+Author: Kouichi ABE (WALL) <kouichi@MysticWALL.COM>
+WWW: http://www.MysticWALL.COM/software/sxml/index.html