aboutsummaryrefslogtreecommitdiff
path: root/textproc/syck
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-03-23 17:51:36 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-03-23 17:51:36 +0000
commit893bb11fb0168068e7ec6b9285231605bf87fb04 (patch)
tree3fa290748597b6d749e31874bec2458c1d59a304 /textproc/syck
parent11ddc96b119bf086ceb3dfe590e8ec53e378f4ea (diff)
downloadports-893bb11fb0168068e7ec6b9285231605bf87fb04.tar.gz
ports-893bb11fb0168068e7ec6b9285231605bf87fb04.zip
- Unbreak build
PR: 176956 Submitted by: Stephon Chen <stephon@gmail.com>
Notes
Notes: svn path=/head/; revision=315052
Diffstat (limited to 'textproc/syck')
-rw-r--r--textproc/syck/Makefile2
-rw-r--r--textproc/syck/files/patch-lib_gram.y22
-rw-r--r--textproc/syck/files/patch-lib_syck.h11
-rw-r--r--textproc/syck/files/patch-lib_token.c34
4 files changed, 67 insertions, 2 deletions
diff --git a/textproc/syck/Makefile b/textproc/syck/Makefile
index 9e6adc022121..081c3c70fde6 100644
--- a/textproc/syck/Makefile
+++ b/textproc/syck/Makefile
@@ -9,8 +9,6 @@ MASTER_SITES= http://cloud.github.com/downloads/indeyets/syck/
MAINTAINER= ports@FreeBSD.org
COMMENT= A library for reading and writing YAML 1.0
-BROKEN= does not build
-
GNU_CONFIGURE= yes
USES= bison
CFLAGS+= -fPIC
diff --git a/textproc/syck/files/patch-lib_gram.y b/textproc/syck/files/patch-lib_gram.y
new file mode 100644
index 000000000000..5664bcd94686
--- /dev/null
+++ b/textproc/syck/files/patch-lib_gram.y
@@ -0,0 +1,22 @@
+--- lib/gram.y.orig 2013-03-14 21:31:55.000000000 +0800
++++ lib/gram.y 2013-03-14 21:32:31.000000000 +0800
+@@ -9,7 +9,8 @@
+
+ %start doc
+ %pure-parser
+-
++%parse-param {void* parser}
++%lex-param {void* parser}
+
+ %{
+
+@@ -24,9 +25,6 @@
+
+ void apply_seq_in_map( SyckParser *parser, SyckNode *n );
+
+-#define YYPARSE_PARAM parser
+-#define YYLEX_PARAM parser
+-
+ #define NULL_NODE(parser, node) \
+ SyckNode *node = syck_new_str( "", scalar_plain ); \
+ if ( ((SyckParser *)parser)->taguri_expansion == 1 ) \
diff --git a/textproc/syck/files/patch-lib_syck.h b/textproc/syck/files/patch-lib_syck.h
new file mode 100644
index 000000000000..43ce75290936
--- /dev/null
+++ b/textproc/syck/files/patch-lib_syck.h
@@ -0,0 +1,11 @@
+--- lib/syck.h.orig 2013-03-14 21:32:03.000000000 +0800
++++ lib/syck.h 2013-03-14 21:32:45.000000000 +0800
+@@ -467,7 +467,7 @@
+ /*
+ * Lexer prototypes
+ */
+-void syckerror( const char * );
++void syckerror( void *, const char * );
+ int syckparse( void * );
+
+ #if defined(__cplusplus)
diff --git a/textproc/syck/files/patch-lib_token.c b/textproc/syck/files/patch-lib_token.c
new file mode 100644
index 000000000000..83d31be8d93a
--- /dev/null
+++ b/textproc/syck/files/patch-lib_token.c
@@ -0,0 +1,34 @@
+--- lib/token.c.orig 2013-03-14 21:32:08.000000000 +0800
++++ lib/token.c 2013-03-14 21:33:14.000000000 +0800
+@@ -200,7 +200,7 @@
+ { \
+ if ( *indent == '\t' ) \
+ { \
+- syckerror("TAB found in your indentation, please remove"); \
++ syckerror(0, "TAB found in your indentation, please remove"); \
+ return 0; \
+ } \
+ else if ( is_newline( ++indent ) ) \
+@@ -266,11 +266,11 @@
+ return sycklex_yaml_utf8( sycklval, parser );
+
+ case syck_yaml_utf16:
+- syckerror( "UTF-16 is not currently supported in Syck.\nPlease contribute code to help this happen!" );
++ syckerror( 0, "UTF-16 is not currently supported in Syck.\nPlease contribute code to help this happen!" );
+ break;
+
+ case syck_yaml_utf32:
+- syckerror( "UTF-32 is not currently supported in Syck.\nPlease contribute code to help this happen!" );
++ syckerror( 0, "UTF-32 is not currently supported in Syck.\nPlease contribute code to help this happen!" );
+ break;
+
+ case syck_bytecode_utf8:
+@@ -2758,7 +2758,7 @@
+ }
+
+ void
+-syckerror( const char *msg )
++syckerror( void * parser, const char *msg )
+ {
+ if ( syck_parser_ptr->error_handler == NULL )
+ syck_parser_ptr->error_handler = syck_default_error_handler;