aboutsummaryrefslogtreecommitdiff
path: root/textproc/tei-p4/Makefile
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2003-07-01 06:21:09 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2003-07-01 06:21:09 +0000
commit7464f336e31fd80c931c3eb1c4c62776e4e3f7f1 (patch)
tree967c3aa47957c6218b6c16c34cfdf4261490cfc6 /textproc/tei-p4/Makefile
parentd7f26aaaed78fb07382fa672754350cb37ec40e0 (diff)
Notes
Diffstat (limited to 'textproc/tei-p4/Makefile')
-rw-r--r--textproc/tei-p4/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/textproc/tei-p4/Makefile b/textproc/tei-p4/Makefile
index 9dcaa7086f8a..24acaca88842 100644
--- a/textproc/tei-p4/Makefile
+++ b/textproc/tei-p4/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tei
PORTVERSION= p4
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= http://www.tei-c.org/P4X/DTD/
DISTNAME= dtd
@@ -14,18 +15,21 @@ DISTNAME= dtd
MAINTAINER= henrik.motakef@web.de
COMMENT= DTD of the Text Encoding Initiative
-RUN_DEPENDS= ${MKCATALOG}:${PORTSDIR}/textproc/mkcatalog
+RUN_DEPENDS= ${XMLCATMGR}:${PORTSDIR}/textproc/xmlcatmgr
USE_ZIP= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
-PLIST_SUB= DTD_NAME=${PORTNAME} DTD_VERSION=${PORTVERSION} \
- MKCATALOG=${MKCATALOG}
+PLIST_SUB= XMLCATMGR=${XMLCATMGR} \
+ DTDDIR=${DTDDIR} \
+ CATALOG_PORTS_SGML=${CATALOG_PORTS_SGML}
DTD= dtd.zip
SGMLDIR= ${PREFIX}/share/sgml
INSTDIR= ${SGMLDIR}/${PORTNAME}/${PORTVERSION}
-MKCATALOG= ${PREFIX}/sbin/mkcatalog
+DTDDIR= ${PORTNAME}/${PORTVERSION}
+XMLCATMGR= ${LOCALBASE}/bin/xmlcatmgr
+CATALOG_PORTS_SGML= ${PREFIX}/share/sgml/catalog.ports
pre-install:
@[ -d ${INSTDIR} ] || ${MKDIR} ${INSTDIR}
@@ -35,9 +39,9 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/*.ent ${INSTDIR}
${INSTALL_DATA} ${WRKSRC}/*.dec ${INSTDIR}
${INSTALL_DATA} ${WRKSRC}/teicatalog.xml ${INSTDIR}
- ${SED} -e "s!&DTDpath;!${INSTDIR}/!" ${WRKSRC}/catalog.tei > ${INSTDIR}/catalog
+ ${SED} -e "s!&DTDpath;!!" ${WRKSRC}/catalog.tei > ${INSTDIR}/catalog
post-install:
- @${MKCATALOG} -q install ${PORTNAME}/${PORTVERSION}
+ ${XMLCATMGR} -sc ${CATALOG_PORTS_SGML} add CATALOG ${DTDDIR}/catalog
.include <bsd.port.mk>