aboutsummaryrefslogtreecommitdiff
path: root/textproc/templates_parser
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-06-21 08:48:52 +0000
committerJohn Marino <marino@FreeBSD.org>2015-06-21 08:48:52 +0000
commit42ca37be339b551778f05e3a3f0695e1e82a76b5 (patch)
treeef3046409967bc72612cd5106ae3c952f1547f6f /textproc/templates_parser
parentd23aeaef3d3c773d58fb8b129129af0673c00646 (diff)
downloadports-42ca37be339b551778f05e3a3f0695e1e82a76b5.tar.gz
ports-42ca37be339b551778f05e3a3f0695e1e82a76b5.zip
Notes
Diffstat (limited to 'textproc/templates_parser')
-rw-r--r--textproc/templates_parser/Makefile8
-rw-r--r--textproc/templates_parser/distinfo4
-rw-r--r--textproc/templates_parser/files/patch-Makefile13
-rw-r--r--textproc/templates_parser/pkg-plist2
4 files changed, 20 insertions, 7 deletions
diff --git a/textproc/templates_parser/Makefile b/textproc/templates_parser/Makefile
index 737b0fe2b651..933906c17deb 100644
--- a/textproc/templates_parser/Makefile
+++ b/textproc/templates_parser/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= templates_parser
-PORTVERSION= 11.9.0.0
-PORTREVISION= 1
+PORTVERSION= 11.10.0.0
CATEGORIES= textproc
MASTER_SITES= http://downloads.dragonlace.net/src/
@@ -17,9 +16,10 @@ BUILD_DEPENDS= gprbuild:${PORTSDIR}/devel/gprbuild \
RUN_DEPENDS= xmlada>=4.4:${PORTSDIR}/textproc/xmlada
USES= ada gmake tar:bzip2
-MAKEFILE= makefile
DESTINC= ${STAGEDIR}${PREFIX}/include/templates_parser
+PLIST_SUB= LIBVER=11.10.0w
MAKE_ARGS+= PROCESSORS=${MAKE_JOBS_NUMBER} \
+ ENABLE_SHARED=true \
HOST=${CONFIGURE_TARGET} \
TARGET=${CONFIGURE_TARGET} \
prefix=${PREFIX}
@@ -34,7 +34,7 @@ DOCS_BUILD_DEPENDS= sphinx-build:${PORTSDIR}/textproc/py-sphinx
do-build:
# Override build target to avoid -jX getting passed to makefile
# Parallel builds are handled with PROCESSORS setting
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS}
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} build
.if ${PORT_OPTIONS:MDOCS}
cd ${WRKSRC}/docs && ${SETENV} ${MAKE_ENV} \
${MAKE_CMD} ${MAKE_ARGS} html
diff --git a/textproc/templates_parser/distinfo b/textproc/templates_parser/distinfo
index 3799c2e118d9..c4ada89bec5c 100644
--- a/textproc/templates_parser/distinfo
+++ b/textproc/templates_parser/distinfo
@@ -1,2 +1,2 @@
-SHA256 (templates_parser-11.9.0.0.tar.bz2) = 0133de55a834f79a85f620d59c3fd9ddece8f43753813f38427e2362166eff91
-SIZE (templates_parser-11.9.0.0.tar.bz2) = 168785
+SHA256 (templates_parser-11.10.0.0.tar.bz2) = bd1a332cbc9284488dadc13600d7735fbcea462a9d0df2b6cf796ef95e3d184e
+SIZE (templates_parser-11.10.0.0.tar.bz2) = 168905
diff --git a/textproc/templates_parser/files/patch-Makefile b/textproc/templates_parser/files/patch-Makefile
new file mode 100644
index 000000000000..391f31c666a8
--- /dev/null
+++ b/textproc/templates_parser/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig 2015-06-21 07:30:14 UTC
++++ Makefile
+@@ -112,8 +112,8 @@ GPROPTS += -XPRJ_BUILD=$(PRJ_BUILD) -XTP
+
+ GPR_DEFAULT = -XLIBRARY_TYPE=$(DEFAULT_LIBRARY_TYPE) \
+ -XXMLADA_BUILD=$(DEFAULT_LIBRARY_TYPE)
+-GPR_OTHER = -XLIBRARY_TYPE=$(DEFAULT_LIBRARY_TYPE) \
+- -XXMLADA_BUILD=$(DEFAULT_LIBRARY_TYPE)
++GPR_OTHER = -XLIBRARY_TYPE=$(OTHER_LIBRARY_TYPE) \
++ -XXMLADA_BUILD=$(OTHER_LIBRARY_TYPE)
+
+ #######################################################################
+ # build
diff --git a/textproc/templates_parser/pkg-plist b/textproc/templates_parser/pkg-plist
index 717bca36385e..cc286c955f46 100644
--- a/textproc/templates_parser/pkg-plist
+++ b/textproc/templates_parser/pkg-plist
@@ -42,7 +42,7 @@ include/templates_parser/templates_parser_tasking.ads
include/templates_parser/templates_parser_tasking__standard_tasking.adb
lib/gnat/templates_parser.gpr
lib/libtemplates_parser.so
-lib/templates_parser.relocatable/libtemplates_parser-11.9.0w.so
+lib/templates_parser.relocatable/libtemplates_parser-%%LIBVER%%.so
lib/templates_parser.relocatable/libtemplates_parser.so
lib/templates_parser.relocatable/templates_parser-configuration__standalone.ali
lib/templates_parser.relocatable/templates_parser-debug.ali