aboutsummaryrefslogtreecommitdiff
path: root/textproc/tidyp
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-03-02 02:04:38 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-03-02 02:04:38 +0000
commited20927f56068f7e4f7f6de93a89e652213b8fa4 (patch)
treed0e047b4dcde009cf1539819deacca9da49c5337 /textproc/tidyp
parentc1e27ba336df12f87a700c1fe56bcb6083ce2f74 (diff)
downloadports-ed20927f56068f7e4f7f6de93a89e652213b8fa4.tar.gz
ports-ed20927f56068f7e4f7f6de93a89e652213b8fa4.zip
- Update to 1.04
- Fix CONFIGURE_ARGS of WITH_ACCESS - Use bsd.port.options.mk - Use PLIST_FILES/DIRS instead of PLIST - Space/tab twiddle
Notes
Notes: svn path=/head/; revision=270098
Diffstat (limited to 'textproc/tidyp')
-rw-r--r--textproc/tidyp/Makefile60
-rw-r--r--textproc/tidyp/distinfo5
-rw-r--r--textproc/tidyp/pkg-plist12
3 files changed, 37 insertions, 40 deletions
diff --git a/textproc/tidyp/Makefile b/textproc/tidyp/Makefile
index ff82d7bf459d..ec374f00aae5 100644
--- a/textproc/tidyp/Makefile
+++ b/textproc/tidyp/Makefile
@@ -5,41 +5,51 @@
# $FreeBSD$
#
-PORTNAME= tidyp
-PORTVERSION= 1.02
-CATEGORIES= textproc www
-MASTER_SITES= http://cloud.github.com/downloads/petdance/tidyp/ \
- LOCAL/sunpoet
-
-MAINTAINER= sunpoet@FreeBSD.org
-COMMENT= A library and program to validate and fix HTML
-
-GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
-
-OPTIONS= ACCESS "Support Accessibility checks" off \
- ASIAN "Support Asian encoding" off \
- DEBUG "Enable debugging" off \
- UTF16 "Support UTF-16 encoding" off
-
-PLIST_SUB+= TIDYP_VER="${PORTVERSION}"
-
-.include <bsd.port.pre.mk>
+PORTNAME= tidyp
+PORTVERSION= 1.04
+CATEGORIES= textproc www
+MASTER_SITES= http://cloud.github.com/downloads/petdance/tidyp/ \
+ LOCAL/sunpoet
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= A library and program to validate and fix HTML
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+OPTIONS= ACCESS "Support Accessibility checks" off \
+ ASIAN "Support Asian encoding" off \
+ DEBUG "Enable debugging" off \
+ UTF16 "Support UTF-16 encoding" off
+
+PLIST_FILES= bin/${PORTNAME} \
+ include/${PORTNAME}/buffio.h \
+ include/${PORTNAME}/platform.h \
+ include/${PORTNAME}/tidyp.h \
+ include/${PORTNAME}/tidypenum.h \
+ lib/lib${PORTNAME}-${PORTVERSION}.so \
+ lib/lib${PORTNAME}-${PORTVERSION}.so.0 \
+ lib/lib${PORTNAME}.a \
+ lib/lib${PORTNAME}.la \
+ lib/lib${PORTNAME}.so
+PLIST_DIRS= include/${PORTNAME}
+
+.include <bsd.port.options.mk>
.if defined(WITH_ACCESS)
-CONFIGURE_ARGS+= --enable-debug
+CONFIGURE_ARGS+=--enable-access
.endif
.if defined(WITH_ASIAN)
-CONFIGURE_ARGS+= --enable-asian
+CONFIGURE_ARGS+=--enable-asian
.endif
.if defined(WITH_DEBUG)
-CONFIGURE_ARGS+= --enable-debug
+CONFIGURE_ARGS+=--enable-debug
.endif
.if defined(WITH_UTF16)
-CONFIGURE_ARGS+= --enable-utf16
+CONFIGURE_ARGS+=--enable-utf16
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/tidyp/distinfo b/textproc/tidyp/distinfo
index c6e2e02ca3e9..bb535fcb19b1 100644
--- a/textproc/tidyp/distinfo
+++ b/textproc/tidyp/distinfo
@@ -1,3 +1,2 @@
-MD5 (tidyp-1.02.tar.gz) = 4fc6f0ba8fb1e2ffafbf8f5963f58969
-SHA256 (tidyp-1.02.tar.gz) = 6ff0eb94a1ac548339a1ea3d377e72bb1261491ffa7df29851aaa1c25e168004
-SIZE (tidyp-1.02.tar.gz) = 674947
+SHA256 (tidyp-1.04.tar.gz) = 20b0fad32c63575bd4685ed09b8c5ca222bbc7b15284210d4b576d0223f0b338
+SIZE (tidyp-1.04.tar.gz) = 662801
diff --git a/textproc/tidyp/pkg-plist b/textproc/tidyp/pkg-plist
deleted file mode 100644
index 120ede53cb7c..000000000000
--- a/textproc/tidyp/pkg-plist
+++ /dev/null
@@ -1,12 +0,0 @@
-@comment $FreeBSD$
-bin/tidyp
-include/tidyp/buffio.h
-include/tidyp/platform.h
-include/tidyp/tidyp.h
-include/tidyp/tidypenum.h
-lib/libtidyp-%%TIDYP_VER%%.so
-lib/libtidyp-%%TIDYP_VER%%.so.0
-lib/libtidyp.a
-lib/libtidyp.la
-lib/libtidyp.so
-@dirrm include/tidyp