aboutsummaryrefslogtreecommitdiff
path: root/textproc/tinyxml2
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-05-26 16:49:07 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-05-26 16:49:07 +0000
commite320d09aed46ae2b8e2d5ff6852d8fa927d66878 (patch)
treec096d163c91684ebeb9a1f7a6ba8fd757d420153 /textproc/tinyxml2
parent9af0e0e046745e5989534d94edcf4b6fb6b70835 (diff)
downloadports-e320d09aed46ae2b8e2d5ff6852d8fa927d66878.tar.gz
ports-e320d09aed46ae2b8e2d5ff6852d8fa927d66878.zip
Notes
Diffstat (limited to 'textproc/tinyxml2')
-rw-r--r--textproc/tinyxml2/Makefile34
1 files changed, 14 insertions, 20 deletions
diff --git a/textproc/tinyxml2/Makefile b/textproc/tinyxml2/Makefile
index 973454e6442a..fc3c757e81b1 100644
--- a/textproc/tinyxml2/Makefile
+++ b/textproc/tinyxml2/Makefile
@@ -11,34 +11,28 @@ COMMENT= Small C++ XML Parser
LICENSE= ZLIB
-CMAKE_ARGS= -DBUILD_SHARED_LIBS:BOOL=ON -DBUILD_STATIC_LIBS:BOOL=ON
-USE_GITHUB= yes
-USE_LDCONFIG= yes
-USES= cmake dos2unix
+OPTIONS_DEFINE= EXAMPLES
-GH_ACCOUNT= leethomason
+CMAKE_ARGS= -DBUILD_SHARED_LIBS=ON -DBUILD_STATIC_LIBS=ON
+USE_LDCONFIG= yes
+USES= cmake dos2unix pathfix
PLIST_FILES= include/tinyxml2.h \
lib/libtinyxml2.a \
lib/libtinyxml2.so \
- lib/libtinyxml2.so.4 \
- lib/libtinyxml2.so.4.0.1 \
+ lib/libtinyxml2.so.${PORTVERSION:R:R} \
+ lib/libtinyxml2.so.${PORTVERSION} \
libdata/pkgconfig/tinyxml2.pc
-PORTEXAMPLES= xmltest.cpp resources
+PORTEXAMPLES= resources xmltest.cpp
-OPTIONS_DEFINE= EXAMPLES
-
-post-patch:
- @${REINPLACE_CMD} -E \
- -e 's@(DESTINATION )(.*)(/pkgconfig)@\1${PREFIX}/libdata\3@' \
- ${WRKSRC}/CMakeLists.txt
+GH_ACCOUNT= leethomason
+USE_GITHUB= yes
-check regression-test test: build
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} test ; \
- ./test
+post-install-EXAMPLES-on:
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/
+ cd ${WRKSRC}/ && ${COPYTREE_SHARE} "${PORTEXAMPLES}" ${STAGEDIR}${EXAMPLESDIR}/
-post-install:
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- @cd ${WRKSRC}; ${COPYTREE_SHARE} "${PORTEXAMPLES}" ${STAGEDIR}${EXAMPLESDIR}
+do-test:
+ cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} xmltest && ./xmltest
.include <bsd.port.mk>