aboutsummaryrefslogtreecommitdiff
path: root/textproc/wdiff
diff options
context:
space:
mode:
authorMIHIRA Sanpei Yoshiro <sanpei@FreeBSD.org>2004-04-15 09:47:39 +0000
committerMIHIRA Sanpei Yoshiro <sanpei@FreeBSD.org>2004-04-15 09:47:39 +0000
commitd0d5a9f83f3d1f80c5d442cb3bea8f7e9c72d754 (patch)
tree07e9a8467f88d22d220350993a70d3f08767e7c7 /textproc/wdiff
parent32e5f06b3e9a9a9be07be6e9e4bcbd90e5b08a6d (diff)
downloadports-d0d5a9f83f3d1f80c5d442cb3bea8f7e9c72d754.tar.gz
ports-d0d5a9f83f3d1f80c5d442cb3bea8f7e9c72d754.zip
Notes
Diffstat (limited to 'textproc/wdiff')
-rw-r--r--textproc/wdiff/Makefile4
-rw-r--r--textproc/wdiff/files/patch-aa25
-rw-r--r--textproc/wdiff/files/patch-ab116
-rw-r--r--textproc/wdiff/files/patch-ac95
-rw-r--r--textproc/wdiff/files/patch-ad20
-rw-r--r--textproc/wdiff/files/patch-ae14
6 files changed, 260 insertions, 14 deletions
diff --git a/textproc/wdiff/Makefile b/textproc/wdiff/Makefile
index 7c0dff9bc9ff..e5c87b6f9e45 100644
--- a/textproc/wdiff/Makefile
+++ b/textproc/wdiff/Makefile
@@ -7,7 +7,7 @@
PORTNAME= wdiff
PORTVERSION= 0.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= wdiff
@@ -20,6 +20,6 @@ GNU_CONFIGURE= yes
MAN1= wdiff.1
post-install:
- @install-info ${PREFIX}/info/wdiff.info ${PREFIX}/info/dir
+ @install-info ${PREFIX}/${INFO_PATH}/wdiff.info ${PREFIX}/${INFO_PATH}/dir
.include <bsd.port.mk>
diff --git a/textproc/wdiff/files/patch-aa b/textproc/wdiff/files/patch-aa
index 6b3e9c0a9ff1..87ac9806c1e1 100644
--- a/textproc/wdiff/files/patch-aa
+++ b/textproc/wdiff/files/patch-aa
@@ -1,5 +1,5 @@
--- Makefile.in.org Sun Nov 6 16:45:13 1994
-+++ Makefile.in Thu Sep 18 01:40:06 1997
++++ Makefile.in Thu Apr 15 18:22:59 2004
@@ -129,7 +129,7 @@
check: wdiff
$(srcdir)/check_it
@@ -9,3 +9,26 @@
$(srcdir)/mkinstalldirs $(bindir) $(infodir)
for name in $(PROGRAMS); do \
$(INSTALL_PROGRAM) $$name \
+@@ -194,17 +194,17 @@
+ CONFIG_FILES=$@ CONFIG_HEADERS= ./config.status
+ config.status: configure
+ ./config.status --recheck
+-configure: configure.in aclocal.m4
+- cd $(srcdir) && autoconf
++#configure: configure.in aclocal.m4
++# cd $(srcdir) && autoconf
+
+ config.h: stamp-h
+ stamp-h: config.h.in config.status
+ CONFIG_FILES= CONFIG_HEADERS=config.h ./config.status
+ date > stamp-h
+ config.h.in: stamp-h.in
+-stamp-h.in: configure.in aclocal.m4 acconfig.h
+- cd $(srcdir) && autoheader
+- date > $(srcdir)/stamp-h.in
++#stamp-h.in: configure.in aclocal.m4 acconfig.h
++# cd $(srcdir) && autoheader
++# date > $(srcdir)/stamp-h.in
+
+ # Tell versions [3.59,3.63) of GNU make not to export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/textproc/wdiff/files/patch-ab b/textproc/wdiff/files/patch-ab
index 1054da7adb04..e7af9b83aba8 100644
--- a/textproc/wdiff/files/patch-ab
+++ b/textproc/wdiff/files/patch-ab
@@ -1,10 +1,114 @@
--- configure.orig Sun Nov 6 16:59:26 1994
-+++ configure Thu Sep 18 02:08:30 1997
-@@ -1159,6 +1159,7 @@
++++ configure Thu Apr 15 18:29:36 2004
+@@ -1159,55 +1159,6 @@
-+LIBS="$saved_LIBS -ltermcap"
- for ac_func in strerror tputs
- do
- echo $ac_n "checking for $ac_func""... $ac_c" 1>&4
+-for ac_func in strerror tputs
+-do
+-echo $ac_n "checking for $ac_func""... $ac_c" 1>&4
+-if eval "test \"`echo '${'ac_cv_func_$ac_func'+set}'`\" = set"; then
+- echo $ac_n "(cached) $ac_c" 1>&4
+-else
+- cat > conftest.$ac_ext <<EOF
+-#line 1170 "configure"
+-#include "confdefs.h"
+-#include <ctype.h> /* Arbitrary system header to define __stub macros. */
+-/* Override any gcc2 internal prototype to avoid an error. */
+-char $ac_func();
+-
+-int main() { return 0; }
+-int t() {
+-
+-/* The GNU C library defines this for functions which it implements
+- to always fail with ENOSYS. Some functions are actually named
+- something starting with __ and the normal name is an alias. */
+-#if defined (__stub_$ac_func) || defined (__stub___$ac_func)
+-choke me
+-#else
+-$ac_func();
+-#endif
+-
+-; return 0; }
+-EOF
+-if eval $ac_link; then
+- rm -rf conftest*
+- eval "ac_cv_func_$ac_func=yes"
+-else
+- rm -rf conftest*
+- eval "ac_cv_func_$ac_func=no"
+-fi
+-rm -f conftest*
+-
+-fi
+-if eval "test \"`echo '$ac_cv_func_'$ac_func`\" = yes"; then
+- echo "$ac_t""yes" 1>&4
+- ac_tr_func=HAVE_`echo $ac_func | tr '[a-z]' '[A-Z]'`
+- cat >> confdefs.h <<EOF
+-#define $ac_tr_func 1
+-EOF
+-
+-else
+- echo "$ac_t""no" 1>&4
+-fi
+-done
+-
+ # The Ultrix 4.2 mips builtin alloca declared by alloca.h only works
+ # for constant arguments. Useless!
+ echo $ac_n "checking for working alloca.h""... $ac_c" 1>&4
+@@ -1712,6 +1663,55 @@
+
+ fi
+ rm -f conftest*
++
++for ac_func in strerror tputs mkstemp
++do
++echo $ac_n "checking for $ac_func""... $ac_c" 1>&4
++if eval "test \"`echo '${'ac_cv_func_$ac_func'+set}'`\" = set"; then
++ echo $ac_n "(cached) $ac_c" 1>&4
++else
++ cat > conftest.$ac_ext <<EOF
++#line 1170 "configure"
++#include "confdefs.h"
++#include <ctype.h> /* Arbitrary system header to define __stub macros. */
++/* Override any gcc2 internal prototype to avoid an error. */
++char $ac_func();
++
++int main() { return 0; }
++int t() {
++
++/* The GNU C library defines this for functions which it implements
++ to always fail with ENOSYS. Some functions are actually named
++ something starting with __ and the normal name is an alias. */
++#if defined (__stub_$ac_func) || defined (__stub___$ac_func)
++choke me
++#else
++$ac_func();
++#endif
++
++; return 0; }
++EOF
++if eval $ac_link; then
++ rm -rf conftest*
++ eval "ac_cv_func_$ac_func=yes"
++else
++ rm -rf conftest*
++ eval "ac_cv_func_$ac_func=no"
++fi
++rm -f conftest*
++
++fi
++if eval "test \"`echo '$ac_cv_func_'$ac_func`\" = yes"; then
++ echo "$ac_t""yes" 1>&4
++ ac_tr_func=HAVE_`echo $ac_func | tr '[a-z]' '[A-Z]'`
++ cat >> confdefs.h <<EOF
++#define $ac_tr_func 1
++EOF
++
++else
++ echo "$ac_t""no" 1>&4
++fi
++done
+
+
+ echo $ac_n "checking if cbars is wanted""... $ac_c" 1>&4
diff --git a/textproc/wdiff/files/patch-ac b/textproc/wdiff/files/patch-ac
index 5674af964e0d..d505d033d944 100644
--- a/textproc/wdiff/files/patch-ac
+++ b/textproc/wdiff/files/patch-ac
@@ -1,5 +1,5 @@
---- wdiff.c.orig Sun Nov 6 16:57:23 1994
-+++ wdiff.c Thu Apr 15 17:58:08 2004
+--- wdiff.c.org Sun Nov 6 16:57:23 1994
++++ wdiff.c Thu Apr 15 18:21:41 2004
@@ -108,7 +108,7 @@
struct option const longopts[] =
{
@@ -9,7 +9,76 @@
{"no-deleted" , 0, NULL, '1'},
{"no-inserted" , 0, NULL, '2'},
{"no-common" , 0, NULL, '3'},
-@@ -892,8 +892,9 @@
+@@ -168,6 +168,10 @@
+ # define L_tmpnam PATH_MAX
+ #endif
+
++#ifdef HAVE_MKSTEMP
++# define MKSTEMP_TEMPLATE "/tmp/wdiffXXXXXXXX"
++#endif
++
+ typedef struct side SIDE; /* all variables for one side */
+ struct side
+ {
+@@ -555,6 +559,9 @@
+ split_file_into_words (SIDE *side)
+ {
+ struct stat stat_buffer; /* for checking if file is directory */
++#ifdef HAVE_MKSTEMP
++ int fd;
++#endif
+
+ /* Open files. */
+
+@@ -566,10 +573,23 @@
+ this temporary local file. Once done, prepare it for reading.
+ We do not need the file name itself anymore. */
+
++#ifdef HAVE_MKSTEMP
++ strcpy (side->temp_name, MKSTEMP_TEMPLATE);
++ if ((fd = mkstemp(side->temp_name)) < 0)
++ error (EXIT_OTHER_REASON, 0, "mkstemp failed");
++ side->file = fdopen (fd, "w+");
++ if (side->file == NULL)
++ {
++ int e = errno;
++ (void) unlink (side->temp_name);
++ error (EXIT_OTHER_REASON, e, side->temp_name);
++ }
++#else
+ tmpnam (side->temp_name);
+ side->file = fopen (side->temp_name, "w+");
+ if (side->file == NULL)
+ error (EXIT_OTHER_REASON, errno, side->temp_name);
++#endif
+ if (unlink (side->temp_name) != 0)
+ error (EXIT_OTHER_REASON, errno, side->temp_name);
+ while (side->character = getchar (), side->character != EOF)
+@@ -593,10 +613,23 @@
+ side->character = getc (side->file);
+ side->position = 0;
+
++#ifdef HAVE_MKSTEMP
++ strcpy (side->temp_name, MKSTEMP_TEMPLATE);
++ if ((fd = mkstemp(side->temp_name)) < 0)
++ error (EXIT_OTHER_REASON, 0, "mkstemp failed");
++ side->temp_file = fdopen (fd, "w");
++ if (side->temp_file == NULL)
++ {
++ int e = errno;
++ (void) unlink (side->temp_name);
++ error (EXIT_OTHER_REASON, e, side->temp_name);
++ }
++#else
+ tmpnam (side->temp_name);
+ side->temp_file = fopen (side->temp_name, "w");
+ if (side->temp_file == NULL)
+ error (EXIT_OTHER_REASON, errno, side->temp_name);
++#endif
+
+ /* Complete splitting input file into words on output. */
+
+@@ -892,8 +925,9 @@
{
/* Launch the diff program. */
@@ -20,7 +89,7 @@
right_side->temp_name, NULL);
else
input_file = readpipe (DIFF_PROGRAM, left_side->temp_name,
-@@ -1111,7 +1112,7 @@
+@@ -1111,7 +1145,7 @@
Mandatory arguments to long options are mandatory for short options too.\n\
\n\
-C, --copyright print Copyright then exit\n\
@@ -29,7 +98,16 @@
-1, --no-deleted inhibit output of deleted words\n\
-2, --no-inserted inhibit output of inserted words\n\
-3, --no-common inhibit output of common words\n\
-@@ -1173,7 +1174,7 @@
+@@ -1135,7 +1169,7 @@
+ | Main program. |
+ `---------------*/
+
+-void
++int
+ main (int argc, char *const argv[])
+ {
+ int option_char; /* option character */
+@@ -1173,7 +1207,7 @@
count_changed_left = 0;
count_changed_right = 0;
@@ -38,3 +116,10 @@
longopts, NULL),
option_char != EOF)
switch (option_char)
+@@ -1329,5 +1363,5 @@
+ || count_changed_left || count_changed_right)
+ exit (EXIT_ANY_DIFFERENCE);
+
+- exit (EXIT_NO_DIFFERENCES);
++ return EXIT_NO_DIFFERENCES;
+ }
diff --git a/textproc/wdiff/files/patch-ad b/textproc/wdiff/files/patch-ad
new file mode 100644
index 000000000000..4aa693a7c7c3
--- /dev/null
+++ b/textproc/wdiff/files/patch-ad
@@ -0,0 +1,20 @@
+$NetBSD: patch-aa,v 1.1 2003/01/24 14:12:04 itohy Exp $
+
+--- configure.in.orig Sun Nov 6 13:15:50 1994
++++ configure.in Fri Jan 24 22:23:43 2003
+@@ -40,7 +40,6 @@
+ AC_HEADER_STDC
+ AC_TYPE_SIGNAL
+
+-AC_CHECK_FUNCS(strerror tputs)
+ AC_FUNC_ALLOCA
+ test "$ALLOCA" = alloca.o && LIBOBJS="$LIBOBJS xmalloc.o"
+ AC_FUNC_VPRINTF
+@@ -60,6 +59,7 @@
+ AC_MSG_RESULT(no)
+ LIBS="$LIBS -ltermcap"
+ ])
++AC_CHECK_FUNCS(strerror tputs mkstemp)
+
+ AC_MSG_CHECKING(if cbars is wanted)
+ AC_ARG_ENABLE(cbars,
diff --git a/textproc/wdiff/files/patch-ae b/textproc/wdiff/files/patch-ae
new file mode 100644
index 000000000000..993e96951cee
--- /dev/null
+++ b/textproc/wdiff/files/patch-ae
@@ -0,0 +1,14 @@
+$NetBSD: patch-ac,v 1.1 2003/01/24 14:12:04 itohy Exp $
+
+--- config.h.in.orig Wed Nov 2 02:23:02 1994
++++ config.h.in Fri Jan 24 22:30:16 2003
+@@ -79,6 +79,9 @@
+ /* Define if you have the tputs function. */
+ #undef HAVE_TPUTS
+
++/* Define if you have the mkstemp function. */
++#undef HAVE_MKSTEMP
++
+ /* Define if you have the <string.h> header file. */
+ #undef HAVE_STRING_H
+