aboutsummaryrefslogtreecommitdiff
path: root/textproc/xenv
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-02-15 17:06:19 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-02-15 17:06:19 +0000
commit5ae1849250ccaa1a7ccf5332a2b3a9caf13f87ab (patch)
treed3c801e51aff0ff32a9a92bfff883b6fc070773a /textproc/xenv
parent7f0255f13c55034ec14ea055d04d947a0c42a2c6 (diff)
downloadports-5ae1849250ccaa1a7ccf5332a2b3a9caf13f87ab.tar.gz
ports-5ae1849250ccaa1a7ccf5332a2b3a9caf13f87ab.zip
Xenv is a text preprocessor that expands references to environment
variables in the input text to their actual values. Requested by: maintainer
Notes
Notes: svn path=/head/; revision=565318
Diffstat (limited to 'textproc/xenv')
-rw-r--r--textproc/xenv/Makefile27
-rw-r--r--textproc/xenv/distinfo3
-rw-r--r--textproc/xenv/pkg-descr6
3 files changed, 36 insertions, 0 deletions
diff --git a/textproc/xenv/Makefile b/textproc/xenv/Makefile
new file mode 100644
index 000000000000..21ce19b94c83
--- /dev/null
+++ b/textproc/xenv/Makefile
@@ -0,0 +1,27 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= xenv
+PORTVERSION= 1.1
+CATEGORIES= textproc
+MASTER_SITES= https://download.gnu.org.ua/release/xenv/
+
+MAINTAINER= zeus@gnu.org.ua
+COMMENT= Text preprocessor for environment variable expansion
+
+LICENSE= GPLv3+
+
+MAKE_ARGS= CFLAGS="${CFLAGS} -Wall"
+ALL_TARGET= ${PORTNAME}
+TEST_TARGET= check
+
+PLIST_FILES= bin/xenv share/man/man1/xenv.1.gz
+PORTDOCS= NEWS README
+
+OPTIONS_DEFINE= DOCS
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/textproc/xenv/distinfo b/textproc/xenv/distinfo
new file mode 100644
index 000000000000..ce305a11d482
--- /dev/null
+++ b/textproc/xenv/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1613051608
+SHA256 (xenv-1.1.tar.gz) = 2109c40f68e33ac55f0ad46a746a732ed1b5d58d19755506d2adcf51981896de
+SIZE (xenv-1.1.tar.gz) = 62311
diff --git a/textproc/xenv/pkg-descr b/textproc/xenv/pkg-descr
new file mode 100644
index 000000000000..01bd6593297b
--- /dev/null
+++ b/textproc/xenv/pkg-descr
@@ -0,0 +1,6 @@
+Xenv is a text preprocessor that expands references to environment
+variables in the input text to their actual values. Environment variables
+are referenced using POSIX-compatible shell syntax. Text is read from the
+standard input and expanded text goes to the standard output.
+
+WWW: https://gnu.org.ua/software/xenv/