aboutsummaryrefslogtreecommitdiff
path: root/textproc/xhtml-basic
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-12-03 09:01:21 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-12-03 09:01:21 +0000
commit15f98549816cb99c97c39f0bf11529e4713ff07a (patch)
tree8c381b986d77da7b728579bff4708b0004c6ad09 /textproc/xhtml-basic
parentb6dba4548cc30d9e18dbae97f96daabdc5bb7801 (diff)
downloadports-15f98549816cb99c97c39f0bf11529e4713ff07a.tar.gz
ports-15f98549816cb99c97c39f0bf11529e4713ff07a.zip
- Add NO_ARCH
- Switch to USES=tar - Switch to options helpers
Notes
Notes: svn path=/head/; revision=427606
Diffstat (limited to 'textproc/xhtml-basic')
-rw-r--r--textproc/xhtml-basic/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/textproc/xhtml-basic/Makefile b/textproc/xhtml-basic/Makefile
index d337030c0d44..27330f96b785 100644
--- a/textproc/xhtml-basic/Makefile
+++ b/textproc/xhtml-basic/Makefile
@@ -7,38 +7,37 @@ PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= http://www.w3.org/TR/2000/REC-${PORTNAME}-${RECDATE}/
DISTNAME= ${PORTNAME}
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= W3C's XHTML Basic DTD
-OPTIONS_DEFINE= DOCS
-
RUN_DEPENDS= xmlcatmgr:textproc/xmlcatmgr \
${LOCALBASE}/share/xml/dtd/xhtml-modularization/catalog.xml:textproc/xhtml-modularization
RECDATE= 20001219
-NO_MTREE= YES
-NO_BUILD= YES
+USES= tar:tgz
+NO_MTREE= yes
+NO_BUILD= yes
+NO_ARCH= yes
WRKSRC= ${WRKDIR}/REC-${PORTNAME}-${RECDATE}
PORTDATA= xhtml-basic10-model-1.mod \
xhtml-basic10.cat \
xhtml-basic10.dtd \
xml1.dcl
-
-PLIST_FILES+= "@xmlcatmgr %%DATADIR%%/catalog.xml"
-
PORTDOCS= Overview.html \
W3C-REC.css \
logo-REC.png \
w3c_home.png \
xhtml-basic.css
+PLIST_FILES= "@xmlcatmgr %%DATADIR%%/catalog.xml"
SUB_FILES= catalog.xml
DATADIR= ${PREFIX}/share/xml/dtd/xhtml-basic
+OPTIONS_DEFINE= DOCS
+
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
(cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDATA} \
@@ -46,10 +45,9 @@ do-install:
${INSTALL_DATA} ${WRKDIR}/catalog.xml \
${STAGEDIR}${DATADIR}/catalog.xml
-post-install-DOCS-on:
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} \
${STAGEDIR}${DOCSDIR})
-
.include <bsd.port.mk>