aboutsummaryrefslogtreecommitdiff
path: root/textproc/xhtml-basic
diff options
context:
space:
mode:
authorJacques Vidrine <nectar@FreeBSD.org>2003-12-15 14:01:16 +0000
committerJacques Vidrine <nectar@FreeBSD.org>2003-12-15 14:01:16 +0000
commitaee4e200124ad5180545ed409dd44a5abaa25784 (patch)
tree751cb5285800480e0331e33c68177067f2bf8d52 /textproc/xhtml-basic
parent0c03fa142b6ca311cb0ea246606cfea4773afc04 (diff)
downloadports-aee4e200124ad5180545ed409dd44a5abaa25784.tar.gz
ports-aee4e200124ad5180545ed409dd44a5abaa25784.zip
Add xhtml-basic and xhtml-modularization, a customizable version
of XHTML and the modular DTDs on which it depends.
Notes
Notes: svn path=/head/; revision=95883
Diffstat (limited to 'textproc/xhtml-basic')
-rw-r--r--textproc/xhtml-basic/Makefile87
-rw-r--r--textproc/xhtml-basic/contents.inc10
-rw-r--r--textproc/xhtml-basic/distinfo1
-rw-r--r--textproc/xhtml-basic/files/catalog.xml20
-rw-r--r--textproc/xhtml-basic/pkg-descr19
5 files changed, 137 insertions, 0 deletions
diff --git a/textproc/xhtml-basic/Makefile b/textproc/xhtml-basic/Makefile
new file mode 100644
index 000000000000..9c6d7950539e
--- /dev/null
+++ b/textproc/xhtml-basic/Makefile
@@ -0,0 +1,87 @@
+# New ports collection makefile for: xhtml-basic
+# Date created: Dec 2, 2003
+# Whom: nectar
+#
+# $FreeBSD$
+#
+
+PORTNAME= xhtml-basic
+PORTVERSION= 1.0.${RECDATE}
+PORTREVISION= 0
+CATEGORIES= textproc
+MASTER_SITES= http://www.w3.org/TR/2000/REC-${PORTNAME}-${RECDATE}/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= nectar@FreeBSD.org
+COMMENT= W3C's XHTML Basic DTD
+
+RUN_DEPENDS= ${XMLCATMGR}:${PORTSDIR}/textproc/xmlcatmgr \
+ ${LOCALBASE}/share/xml/dtd/xhtml-modularization/catalog.xml:${PORTSDIR}/textproc/xhtml-modularization
+
+RECDATE= 20001219
+
+NO_MTREE= YES
+NO_BUILD= YES
+WRKSRC= ${WRKDIR}/REC-${PORTNAME}-${RECDATE}
+
+PLIST= ${WRKDIR}/PLIST
+dir_DTD= share/xml/dtd/xhtml-basic
+dir_DOC= share/doc/xhtml-basic
+
+XMLCATMGR= ${LOCALBASE}/bin/xmlcatmgr
+SGMLCAT= ${PREFIX}/share/sgml/catalog.ports
+XMLCAT= ${PREFIX}/share/xml/catalog.ports
+
+XMLCAT_ADD= ${XMLCATMGR} -c ${XMLCAT} add nextCatalog \
+ ${PREFIX}/${dir_DTD}/catalog.xml
+XMLCAT_RM= ${XMLCATMGR} -c ${XMLCAT} remove \
+ ${PREFIX}/${dir_DTD}/catalog.xml
+SGMLCAT_ADD= ${XMLCATMGR} -sc ${SGMLCAT} add CATALOG \
+ ${PREFIX}/${dir_DTD}/xhtml-basic10.cat
+SGMLCAT_RM= ${XMLCATMGR} -sc ${SGMLCAT} remove \
+ ${PREFIX}/${dir_DTD}/xhtml-basic10.cat
+
+CATALOG_PORTS_SGML= ${PREFIX}/share/sgml/catalog.ports
+CATALOG_PORTS_XML= ${PREFIX}/share/xml/catalog.ports
+
+.include "${.CURDIR}/contents.inc"
+
+# I'd much rather do this stuff in line with the actual installation
+# in do-install, but the PLIST must be generated in pre-install.
+pre-install:
+ ${CAT} /dev/null > ${PLIST}
+.for f in ${contents_DTD}
+ ${ECHO} ${dir_DTD}/${f} >> ${PLIST}
+.endfor
+.for f in ${contents_DOC}
+ ${ECHO} ${dir_DOC}/${f} >> ${PLIST}
+.endfor
+ ${ECHO} ${dir_DTD}/catalog.xml >> ${PLIST}
+ ${ECHO} "@unexec ${XMLCAT_RM}" >> ${PLIST}
+ ${ECHO} "@exec ${XMLCAT_ADD}" >> ${PLIST}
+ ${ECHO} "@unexec ${SGMLCAT_RM}" >> ${PLIST}
+ ${ECHO} "@exec ${SGMLCAT_ADD}" >> ${PLIST}
+ ${ECHO} "@dirrm ${dir_DTD}" >> ${PLIST}
+ ${ECHO} '@unexec rmdir %D share/xml/dtd 2>/dev/null || true' >> \
+ ${PLIST}
+ ${ECHO} "@dirrm ${dir_DOC}" >> ${PLIST}
+
+do-install:
+ @[ -d ${PREFIX}/${dir_DTD} ] || \
+ ${MKDIR} ${PREFIX}/${dir_DTD}
+ @[ -d ${PREFIX}/${dir_DOC} ] || \
+ ${MKDIR} ${PREFIX}/${dir_DOC}
+.for f in ${contents_DTD}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/${dir_DTD}/${f}
+.endfor
+.for f in ${contents_DOC}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/${dir_DOC}/${f}
+.endfor
+ ${SED} -e "s;@@PREFIX@@;${PREFIX};g" ${FILESDIR}/catalog.xml > \
+ ${WRKDIR}/catalog.xml
+ ${INSTALL_DATA} ${WRKDIR}/catalog.xml ${PREFIX}/${dir_DTD}/catalog.xml
+ ${XMLCAT_ADD}
+ ${SGMLCAT_ADD}
+
+.include <bsd.port.mk>
diff --git a/textproc/xhtml-basic/contents.inc b/textproc/xhtml-basic/contents.inc
new file mode 100644
index 000000000000..b49c08018da7
--- /dev/null
+++ b/textproc/xhtml-basic/contents.inc
@@ -0,0 +1,10 @@
+contents_DTD+= xhtml-basic10-model-1.mod
+contents_DTD+= xhtml-basic10.cat
+contents_DTD+= xhtml-basic10.dtd
+contents_DTD+= xml1.dcl
+
+contents_DOC+= Overview.html
+contents_DOC+= W3C-REC.css
+contents_DOC+= logo-REC.png
+contents_DOC+= w3c_home.png
+contents_DOC+= xhtml-basic.css
diff --git a/textproc/xhtml-basic/distinfo b/textproc/xhtml-basic/distinfo
new file mode 100644
index 000000000000..4c65687633fe
--- /dev/null
+++ b/textproc/xhtml-basic/distinfo
@@ -0,0 +1 @@
+MD5 (xhtml-basic.tgz) = 836eb2a447bdf7b451e30a892b5bdd54
diff --git a/textproc/xhtml-basic/files/catalog.xml b/textproc/xhtml-basic/files/catalog.xml
new file mode 100644
index 000000000000..f8d03f71ebd9
--- /dev/null
+++ b/textproc/xhtml-basic/files/catalog.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0"?>
+<!DOCTYPE catalog PUBLIC "-//OASIS//DTD Entity Resolution XML Catalog V1.0//EN"
+ "http://www.oasis-open.org/committees/entity/release/1.0/catalog.dtd" >
+
+<catalog xmlns="urn:oasis:names:tc:entity:xmlns:xml:catalog"
+ prefer="public"
+ xml:base="file://@@PREFIX@@/share/xml/dtd/xhtml-basic/">
+
+ <rewriteSystem
+ systemIdStartString="http://www.w3.org/TR/xhtml-basic/"
+ rewritePrefix="./" />
+
+ <public
+ publicId="-//W3C//DTD XHTML Basic 1.0//EN"
+ uri="xhtml-basic10.dtd" />
+ <public
+ publicId="-//W3C//DTD XHTML Basic Document Model 1.0//EN"
+ uri="xhtml-basic10-model-1.mod" />
+
+</catalog>
diff --git a/textproc/xhtml-basic/pkg-descr b/textproc/xhtml-basic/pkg-descr
new file mode 100644
index 000000000000..c44b71fa8dfe
--- /dev/null
+++ b/textproc/xhtml-basic/pkg-descr
@@ -0,0 +1,19 @@
+From the abstract:
+ The XHTML Basic document type includes the minimal set of modules
+ required to be an XHTML host language document type, and in addition
+ it includes images, forms, basic tables, and object support. It
+ is designed for Web clients that do not support the full set of
+ XHTML features; for example, Web clients such as mobile phones,
+ PDAs, pagers, and settop boxes. The document type is rich enough for
+ content authoring.
+
+ XHTML Basic is designed as a common base that may be extended. For
+ example, an event module that is more generic than the traditional
+ HTML 4 event system could be added or it could be extended by
+ additional modules from XHTML Modularization such as the Scripting
+ Module. The goal of XHTML Basic is to serve as a common language
+ supported by various kinds of user agents.
+
+The document type definition is implemented using XHTML
+modules as defined in "Modularization of XHTML", found in
+ports/textproc/xhtml-modularization.