aboutsummaryrefslogtreecommitdiff
path: root/textproc/xhtml1-xsd
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-08-07 14:54:01 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-08-07 14:54:01 +0000
commit8534aabac6f01feb6dd6d2e1b6ccfa61934645ff (patch)
tree2607dd383ab7de75b6b394313662f582883c992d /textproc/xhtml1-xsd
parent93f5cc717482c675ceef91bca3042dd9a90d9980 (diff)
downloadports-8534aabac6f01feb6dd6d2e1b6ccfa61934645ff.tar.gz
ports-8534aabac6f01feb6dd6d2e1b6ccfa61934645ff.zip
- Add staging support
- Switch to PLIST_FILES
Notes
Notes: svn path=/head/; revision=364283
Diffstat (limited to 'textproc/xhtml1-xsd')
-rw-r--r--textproc/xhtml1-xsd/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/textproc/xhtml1-xsd/Makefile b/textproc/xhtml1-xsd/Makefile
index e18d173409e8..501db4dd674d 100644
--- a/textproc/xhtml1-xsd/Makefile
+++ b/textproc/xhtml1-xsd/Makefile
@@ -18,13 +18,14 @@ EXTRACT_BEFORE_ARGS= # empty
EXTRACT_AFTER_ARGS= .
NO_BUILD= yes
-NO_STAGE= yes
+PLIST_FILES= ${DATADIR_REL}/xhtml1-frameset.xsd \
+ ${DATADIR_REL}/xhtml1-strict.xsd \
+ ${DATADIR_REL}/xhtml1-transitional.xsd
+PLIST_DIRS= ${DATADIR_REL}
+
do-install:
- @${MKDIR} ${DATADIR}
- @${CP} -R ${WRKSRC}/* ${DATADIR}
- @${FIND} ${DATADIR} -type f | \
- ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
- @${FIND} ${DATADIR} -type d | ${SORT} -r | \
- ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PLIST_FILES:S|^${DATADIR_REL}/||} \
+ ${STAGEDIR}${DATADIR})
.include <bsd.port.mk>