aboutsummaryrefslogtreecommitdiff
path: root/textproc/xmlroff
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2005-03-03 02:16:03 +0000
committerHiroki Sato <hrs@FreeBSD.org>2005-03-03 02:16:03 +0000
commit54bc0cbd7bacb717f4bfd1368c4fa3e6544a68c3 (patch)
tree80b30553384570c05a4e5fe2ab7b67b670c58501 /textproc/xmlroff
parent34ec27584704f2a54f0b4048649646c3dd506185 (diff)
downloadports-54bc0cbd7bacb717f4bfd1368c4fa3e6544a68c3.tar.gz
ports-54bc0cbd7bacb717f4bfd1368c4fa3e6544a68c3.zip
Notes
Diffstat (limited to 'textproc/xmlroff')
-rw-r--r--textproc/xmlroff/Makefile2
-rw-r--r--textproc/xmlroff/distinfo4
-rw-r--r--textproc/xmlroff/files/patch-datatype::fo-color.c17
-rw-r--r--textproc/xmlroff/files/patch-expr::fo-expr-eval.c67
-rw-r--r--textproc/xmlroff/pkg-plist7
5 files changed, 86 insertions, 11 deletions
diff --git a/textproc/xmlroff/Makefile b/textproc/xmlroff/Makefile
index fcf7b940a903..35c36d611c37 100644
--- a/textproc/xmlroff/Makefile
+++ b/textproc/xmlroff/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xmlroff
-PORTVERSION= 0.3.1
+PORTVERSION= 0.3.2
PORTREVISION= 0
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
diff --git a/textproc/xmlroff/distinfo b/textproc/xmlroff/distinfo
index 1d3f27d0d764..07cada8a662e 100644
--- a/textproc/xmlroff/distinfo
+++ b/textproc/xmlroff/distinfo
@@ -1,2 +1,2 @@
-MD5 (xmlroff-0.3.1.tar.gz) = 013d91b20b3dd3f5a153cbfe6d5dc73d
-SIZE (xmlroff-0.3.1.tar.gz) = 2415955
+MD5 (xmlroff-0.3.2.tar.gz) = 451907a30fa50ad1db00d540933c067a
+SIZE (xmlroff-0.3.2.tar.gz) = 2452081
diff --git a/textproc/xmlroff/files/patch-datatype::fo-color.c b/textproc/xmlroff/files/patch-datatype::fo-color.c
new file mode 100644
index 000000000000..a06859cb7b1b
--- /dev/null
+++ b/textproc/xmlroff/files/patch-datatype::fo-color.c
@@ -0,0 +1,17 @@
+--- datatype/fo-color.c.orig Thu Mar 3 10:50:38 2005
++++ datatype/fo-color.c Thu Mar 3 10:51:09 2005
+@@ -307,12 +307,13 @@
+ guint blue)
+ {
+ FoDatatype *color = fo_color_new ();
++ FoDatatype *hashed_color;
+
+ fo_color_set_red (color, red);
+ fo_color_set_blue (color, blue);
+ fo_color_set_green (color, green);
+
+- FoDatatype *hashed_color =
++ hashed_color =
+ (FoDatatype *) fo_hash_table_lookup (FO_COLOR_GET_CLASS(color)->colors,
+ FO_OBJECT (color),
+ NULL);
diff --git a/textproc/xmlroff/files/patch-expr::fo-expr-eval.c b/textproc/xmlroff/files/patch-expr::fo-expr-eval.c
index e8214801276d..53e064bfa0a8 100644
--- a/textproc/xmlroff/files/patch-expr::fo-expr-eval.c
+++ b/textproc/xmlroff/files/patch-expr::fo-expr-eval.c
@@ -1,6 +1,6 @@
---- expr/fo-expr-eval.c.orig Mon Jan 10 13:58:52 2005
-+++ expr/fo-expr-eval.c Mon Jan 10 14:02:29 2005
-@@ -1244,14 +1244,22 @@
+--- expr/fo-expr-eval.c.orig Mon Feb 28 20:55:34 2005
++++ expr/fo-expr-eval.c Thu Mar 3 10:55:21 2005
+@@ -1240,14 +1240,22 @@
static void
eval_padding_expr (FoExprContext *context)
{
@@ -24,7 +24,7 @@
do
{
FoDatatype *intermediate_value = NULL;
-@@ -1349,10 +1357,10 @@
+@@ -1345,10 +1353,10 @@
* A fifth entry on the stack indicates an error.
*/
@@ -37,7 +37,7 @@
/* Handle possible conditions for top stack entry. */
if (stack_first == NULL)
-@@ -1371,7 +1379,7 @@
+@@ -1367,7 +1375,7 @@
}
/* Second stack entry */
@@ -46,7 +46,7 @@
/* Handle possible conditions for second stack entry. */
if (stack_second == NULL)
-@@ -1391,7 +1399,7 @@
+@@ -1387,7 +1395,7 @@
}
/* third stack entry */
@@ -55,7 +55,7 @@
/* Handle possible conditions for third stack entry. */
if (stack_third == NULL)
-@@ -1411,7 +1419,7 @@
+@@ -1407,7 +1415,7 @@
}
/* fourth stack entry */
@@ -64,3 +64,56 @@
/* Handle possible conditions for fourth stack entry. */
if (stack_fourth == NULL)
+@@ -1575,6 +1583,12 @@
+ static void
+ eval_border_color_expr (FoExprContext *context)
+ {
++ FoDatatype *result_datatype = NULL;
++ FoDatatype *stack_first;
++ FoDatatype *stack_second;
++ FoDatatype *stack_third;
++ FoDatatype *stack_fourth;
++
+ /* If not 'inherit', then one to four <color> or 'transparent' values. */
+ do
+ {
+@@ -1658,10 +1672,10 @@
+ * A fifth entry on the stack indicates an error.
+ */
+
+- FoDatatype *result_datatype = NULL;
++ result_datatype = NULL;
+
+ /* First stack entry */
+- FoDatatype *stack_first = fo_expr_context_pop_stack (context);
++ stack_first = fo_expr_context_pop_stack (context);
+
+ /* Handle possible conditions for top stack entry. */
+ if (stack_first == NULL)
+@@ -1680,7 +1694,7 @@
+ }
+
+ /* Second stack entry */
+- FoDatatype *stack_second = fo_expr_context_pop_stack (context);
++ stack_second = fo_expr_context_pop_stack (context);
+
+ /* Handle possible conditions for second stack entry. */
+ if (stack_second == NULL)
+@@ -1700,7 +1714,7 @@
+ }
+
+ /* third stack entry */
+- FoDatatype *stack_third = fo_expr_context_pop_stack (context);
++ stack_third = fo_expr_context_pop_stack (context);
+
+ /* Handle possible conditions for third stack entry. */
+ if (stack_third == NULL)
+@@ -1720,7 +1734,7 @@
+ }
+
+ /* fourth stack entry */
+- FoDatatype *stack_fourth = fo_expr_context_pop_stack (context);
++ stack_fourth = fo_expr_context_pop_stack (context);
+
+ /* Handle possible conditions for fourth stack entry. */
+ if (stack_fourth == NULL)
diff --git a/textproc/xmlroff/pkg-plist b/textproc/xmlroff/pkg-plist
index a20d2d6a5fe1..3d77294f69e9 100644
--- a/textproc/xmlroff/pkg-plist
+++ b/textproc/xmlroff/pkg-plist
@@ -26,6 +26,7 @@ include/libfo-0.3/libfo/fo-xsl-formatter.c
include/libfo-0.3/libfo/fo-xsl-formatter.h
include/libfo-0.3/libfo/fo-xslt-transformer.h
include/libfo-0.3/property/fo-property.h
+include/libfo-0.3/util/fo-hash-table.h
lib/libfo-0.3.a
lib/libfo-0.3.so
lib/libfo-0.3.so.300
@@ -91,6 +92,7 @@ libdata/pkgconfig/libfo-0.3.pc
%%DOCSDIR%%/areas.html
%%DOCSDIR%%/background-color.html
%%DOCSDIR%%/baseline-shift.html
+%%DOCSDIR%%/basic-interface.html
%%DOCSDIR%%/basic-link.html
%%DOCSDIR%%/bidi-override.html
%%DOCSDIR%%/block-container.html
@@ -262,6 +264,7 @@ libdata/pkgconfig/libfo-0.3.pc
%%DOCSDIR%%/title.html
%%DOCSDIR%%/unicode-bidi.html
%%DOCSDIR%%/up.png
+%%DOCSDIR%%/utility-objects.html
%%DOCSDIR%%/widows.html
%%DOCSDIR%%/width.html
%%DOCSDIR%%/wrap-option.html
@@ -271,6 +274,7 @@ libdata/pkgconfig/libfo-0.3.pc
%%DOCSDIR%%/xmlroff-FoDocGP.html
%%DOCSDIR%%/xmlroff-FoError.html
%%DOCSDIR%%/xmlroff-FoFontDesc.html
+%%DOCSDIR%%/xmlroff-FoHashTable.html
%%DOCSDIR%%/xmlroff-FoLayout.html
%%DOCSDIR%%/xmlroff-FoLibfoContext.html
%%DOCSDIR%%/xmlroff-FoNeutralFoIface.html
@@ -284,7 +288,6 @@ libdata/pkgconfig/libfo-0.3.pc
%%DOCSDIR%%/xmlroff-block-progression-dimensionminimum.html
%%DOCSDIR%%/xmlroff-block-progression-dimensionoptimum.html
%%DOCSDIR%%/xmlroff-border.html
-%%DOCSDIR%%/xmlroff-code-rules.html
%%DOCSDIR%%/xmlroff-float.html
%%DOCSDIR%%/xmlroff-fo-block-area.html
%%DOCSDIR%%/xmlroff-fo-block-block-area.html
@@ -296,6 +299,7 @@ libdata/pkgconfig/libfo-0.3.pc
%%DOCSDIR%%/xmlroff-fo-list-item-body-area.html
%%DOCSDIR%%/xmlroff-fo-list-item-label-area.html
%%DOCSDIR%%/xmlroff-fo-page-sequence-area.html
+%%DOCSDIR%%/xmlroff-fo-property-border-color.html
%%DOCSDIR%%/xmlroff-fo-region-body-area.html
%%DOCSDIR%%/xmlroff-fo-retrieve-marker.html
%%DOCSDIR%%/xmlroff-fo-table-area.html
@@ -347,6 +351,7 @@ share/xml/libfo-0.3.1/xmlroff.fo
@dirrm share/xml/libfo-0.3.1
@unexec rmdir %D/share/xml 2>/dev/null || true
@dirrm %%DOCSDIR%%
+@dirrm include/libfo-0.3/util
@dirrm include/libfo-0.3/property
@dirrm include/libfo-0.3/libfo
@dirrm include/libfo-0.3/fo