aboutsummaryrefslogtreecommitdiff
path: root/textproc/xmlto
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2013-10-23 22:12:47 +0000
committerMatthias Andree <mandree@FreeBSD.org>2013-10-23 22:12:47 +0000
commite8bbb307c444161aef690f446a906412c862f34e (patch)
tree346fd70806a5ed325568a33c734c64217984a5b2 /textproc/xmlto
parentffbe907dead130cd710340d7503b48680a17fe9d (diff)
downloadports-e8bbb307c444161aef690f446a906412c862f34e.tar.gz
ports-e8bbb307c444161aef690f446a906412c862f34e.zip
Make sure to not read/pollute the building user's HOME.
Add LICENSE. The port is GPLv2+. No longer install COPYING separately (which is another copy of the GPLv2 text). Remove MAKE_JOBS_UNSAFE.
Notes
Notes: svn path=/head/; revision=331433
Diffstat (limited to 'textproc/xmlto')
-rw-r--r--textproc/xmlto/Makefile13
-rw-r--r--textproc/xmlto/files/patch-xmlto.in11
2 files changed, 16 insertions, 8 deletions
diff --git a/textproc/xmlto/Makefile b/textproc/xmlto/Makefile
index 06e1bcabfc6b..622e7f42c93e 100644
--- a/textproc/xmlto/Makefile
+++ b/textproc/xmlto/Makefile
@@ -3,12 +3,15 @@
PORTNAME= xmlto
PORTVERSION= 0.0.25
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= https://fedorahosted.org/releases/x/m/xmlto/
MAINTAINER= mandree@FreeBSD.org
COMMENT= Front-end to an XSL toolchain
+LICENSE= GPLv2
+
BUILD_DEPENDS= ${BASH_CMD}:${PORTSDIR}/shells/bash \
${GETOPT_CMD}:${PORTSDIR}/misc/getopt \
xmllint:${PORTSDIR}/textproc/libxml2 \
@@ -19,8 +22,6 @@ BUILD_DEPENDS= ${BASH_CMD}:${PORTSDIR}/shells/bash \
${LOCALBASE}/share/xml/docbook/4.2/docbookx.dtd:${PORTSDIR}/textproc/docbook-xml
RUN_DEPENDS:= ${BUILD_DEPENDS}
-MAKE_JOBS_UNSAFE= yes
-
OPTIONS_DEFINE= DBLATEX FOP PASSIVETEX
DBLATEX_DESC= Add dependency on Dblatex
FOP_DESC= Add dependency on FOP (needs Java)
@@ -36,10 +37,10 @@ GETOPT_CMD= ${LOCALBASE}/bin/getopt
XSL_DIR= ${LOCALBASE}/share/xsl/docbook
PDFXMLTEX_CMD= ${LOCALBASE}/bin/pdftex
-PORTDOCS= AUTHORS COPYING ChangeLog NEWS THANKS
-# these two documentation files do not convey information useful for
-# the FreeBSD port at this time:
-# PORTDOCS+= FAQ README
+PORTDOCS= AUTHORS ChangeLog NEWS THANKS
+# these documentation files do not convey information useful for
+# the FreeBSD port at this time, or are provided by the ports framework:
+# PORTDOCS+= COPYING FAQ README
.include <bsd.port.pre.mk>
diff --git a/textproc/xmlto/files/patch-xmlto.in b/textproc/xmlto/files/patch-xmlto.in
index eb0df17b4b5c..07feb8a41709 100644
--- a/textproc/xmlto/files/patch-xmlto.in
+++ b/textproc/xmlto/files/patch-xmlto.in
@@ -1,5 +1,5 @@
---- ./xmlto.in.orig 2012-02-09 02:08:09.000000000 +0100
-+++ ./xmlto.in 2012-02-09 02:08:09.000000000 +0100
+--- ./xmlto.in.orig 2011-11-29 12:49:57.000000000 +0100
++++ ./xmlto.in 2013-10-07 23:52:57.000000000 +0200
@@ -262,7 +262,7 @@
# Process any options
@@ -9,3 +9,10 @@
-n xmlto -- x:m:o:p:v "$@")
[ $? != 0 ] && { usage; exit 1; }
eval set -- "$ARGS"
+@@ -611,4 +611,6 @@
+ # Extremely verbose
+ BASH="${BASH} -x"
+ fi
++make_temp -d temphome HOME || exit 1
++export HOME
+ ${BASH} "$FORMAT" post-process || exit 1