aboutsummaryrefslogtreecommitdiff
path: root/textproc/xmlwrapp
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2007-07-03 08:20:49 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2007-07-03 08:20:49 +0000
commitd819eff487b0ccdaa97c587cc173e95c317f9092 (patch)
treeddb83864ef8a87f9c6ade7f501b0f6ab712166a3 /textproc/xmlwrapp
parenta322d0385bef4a4b1bcafbbcd3267ee1943b6bab (diff)
downloadports-d819eff487b0ccdaa97c587cc173e95c317f9092.tar.gz
ports-d819eff487b0ccdaa97c587cc173e95c317f9092.zip
- Unbreak with recent GCC
- Consistencify sed(1) regexps
Notes
Notes: svn path=/head/; revision=194762
Diffstat (limited to 'textproc/xmlwrapp')
-rw-r--r--textproc/xmlwrapp/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/textproc/xmlwrapp/Makefile b/textproc/xmlwrapp/Makefile
index b8d678e88012..dd62f6632760 100644
--- a/textproc/xmlwrapp/Makefile
+++ b/textproc/xmlwrapp/Makefile
@@ -27,10 +27,6 @@ CFLAGS+= -fPIC
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
.if ${HAVE_GNOME:Mlibxslt}!=""
USE_GNOME+= libxslt
.else
@@ -38,6 +34,10 @@ CONFIGURE_ARGS+= --disable-xslt
.endif
post-patch:
- @${REINPLACE_CMD} "s:/usr/bin/perl:${PERL}:" ${WRKSRC}/configure.pl
+ @${REINPLACE_CMD} -e 's,/usr/bin/perl,${PERL},' ${WRKSRC}/configure.pl
+# Fix for GCC 4.2
+ @${REINPLACE_CMD} -e 's,^std::ostream,namespace xml { &,' \
+ -e '/^namespace/s,xml::,,g' -e '$$s,^,} ,' \
+ ${WRKSRC}/src/libxml/node.cxx
.include <bsd.port.post.mk>