aboutsummaryrefslogtreecommitdiff
path: root/textproc/zorba
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-04-04 10:11:48 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-04-04 10:11:48 +0000
commit07f01c0c21eec601d04ea287ce14b3a2256a683a (patch)
treec1f7658d4355510e81a5d7804f7572b829d76c6c /textproc/zorba
parentdf697ff0b394f864adb5b8916b881d495677fd19 (diff)
downloadports-07f01c0c21eec601d04ea287ce14b3a2256a683a.tar.gz
ports-07f01c0c21eec601d04ea287ce14b3a2256a683a.zip
textproc/zorba: unbreak with ICU 61
In file included from src/functions/func_any_uri.cpp:27: In file included from src/functions/func_any_uri.h:30: In file included from src/functions/function_impl.h:25: In file included from src/context/static_context.h:43: In file included from src/zorbautils/hashmap_zstring.h:23: src/util/utf8_util.h:784:22: error: unknown type name 'Collator'; did you mean 'UCollator'? return static_cast<Collator*>( collation->getCollator() )->compare(us1, us2); ^~~~~~~~ UCollator /usr/local/include/unicode/ucol.h:58:26: note: 'UCollator' declared here typedef struct UCollator UCollator; ^ In file included from src/runtime/full_text/default_tokenizer.cpp:25: src/runtime/full_text/icu_tokenizer.h:56:27: error: unknown type name 'RuleBasedBreakIterator'; did you mean 'icu::RuleBasedBreakIterator'? typedef std::unique_ptr<RuleBasedBreakIterator> rbbi_ptr; ^~~~~~~~~~~~~~~~~~~~~~ icu::RuleBasedBreakIterator /usr/local/include/unicode/rbbi.h:53:20: note: 'icu::RuleBasedBreakIterator' declared here class U_COMMON_API RuleBasedBreakIterator /*U_FINAL*/ : public BreakIterator { ^ https://ssl.icu-project.org/trac/changeset/40705 PR: 227042 Reported by: antoine (via exp-run)
Notes
Notes: svn path=/head/; revision=466416
Diffstat (limited to 'textproc/zorba')
-rw-r--r--textproc/zorba/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/textproc/zorba/Makefile b/textproc/zorba/Makefile
index 74c4b9aec4cc..70f7355ab93b 100644
--- a/textproc/zorba/Makefile
+++ b/textproc/zorba/Makefile
@@ -41,6 +41,7 @@ USES= cmake:outsource compiler:c++11-lib libedit
USE_GNOME= libxml2 libxslt
USE_LDCONFIG= yes
USE_CXXSTD= c++11
+CXXFLAGS+= -DU_USING_ICU_NAMESPACE=1
CXXFLAGS+= -I${LOCALBASE}/include -O1 # compiler hangs with -O2 on CURRENT
LDFLAGS+= -L${LOCALBASE}/lib
CMAKE_ARGS= -DCMAKE_REQUIRED_FLAGS:STRING="-I${LOCALBASE}/include -L${LOCALBASE}/lib" \