aboutsummaryrefslogtreecommitdiff
path: root/textproc/zorba
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-12-19 16:10:12 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-12-19 16:10:12 +0000
commit45715f6197d7d58ec6648fa024bd72a8580a1dd3 (patch)
tree1bc66db58a27e4bde5e614541a3c127866f64640 /textproc/zorba
parent1afa5c8a429183ce5c3fcae03f5a404798ebda86 (diff)
downloadports-45715f6197d7d58ec6648fa024bd72a8580a1dd3.tar.gz
ports-45715f6197d7d58ec6648fa024bd72a8580a1dd3.zip
The DOCS option must not install doxygen.
Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=428947
Diffstat (limited to 'textproc/zorba')
-rw-r--r--textproc/zorba/Makefile10
-rw-r--r--textproc/zorba/pkg-plist88
2 files changed, 51 insertions, 47 deletions
diff --git a/textproc/zorba/Makefile b/textproc/zorba/Makefile
index 7659142acad4..163a3747b275 100644
--- a/textproc/zorba/Makefile
+++ b/textproc/zorba/Makefile
@@ -3,7 +3,7 @@
PORTNAME= zorba
PORTVERSION= 2.7.0
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= textproc
MASTER_SITES= https://launchpadlibrarian.net/119058962/
DISTNAME= ${PORTNAME}-src-${PORTVERSION}
@@ -22,10 +22,11 @@ RUN_DEPENDS= fop:textproc/fop
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-OPTIONS_DEFINE= PHP PYTHON RUBY JAVA DOCS
+OPTIONS_DEFINE= PHP PYTHON RUBY JAVA DOCS DOXYGEN
OPTIONS_SUB= yes
-DOCS_BUILD_DEPENDS+= doxygen:devel/doxygen
+DOXYGEN_BUILD_DEPENDS+= doxygen:devel/doxygen
+DOXYGEN_IMPLIES= DOCS
PHP_CMAKE_BOOL= WITH_PHP5
PYTHON_CMAKE_BOOL= WITH_PYTHON
RUBY_CMAKE_BOOL= WITH_RUBY
@@ -101,6 +102,9 @@ post-patch:
post-install:
${LN} -sf libzorba_simplestore.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libzorba_simplestore.so.${PORTVERSION:R:R}
+.if ${PORT_OPTIONS:MDOCS} && !${PORT_OPTIONS:MDOXYGEN}
+ cd ${STAGEDIR}${DOCSDIR} && rmdir c/html code/html code cxx/html zorba/html
+.endif
test: build
cd ${BUILD_WRKSRC} && ${MAKE} test
diff --git a/textproc/zorba/pkg-plist b/textproc/zorba/pkg-plist
index e1d8291468f8..7a139a26f4cf 100644
--- a/textproc/zorba/pkg-plist
+++ b/textproc/zorba/pkg-plist
@@ -113,17 +113,17 @@ lib/zorba/core/%%FULLVERSION%%/org/expath/ns/libfile_2.0.so
%%PORTDOCS%%%%DOCSDIR%%/c/examples/csequences.c
%%PORTDOCS%%%%DOCSDIR%%/c/examples/cserialization.c
%%PORTDOCS%%%%DOCSDIR%%/c/examples/csimple.c
-%%PORTDOCS%%%%DOCSDIR%%/c/html/documentation.png
-%%PORTDOCS%%%%DOCSDIR%%/c/html/download.png
-%%PORTDOCS%%%%DOCSDIR%%/c/html/modules.png
-%%PORTDOCS%%%%DOCSDIR%%/c/html/noisepattern.png
-%%PORTDOCS%%%%DOCSDIR%%/c/html/rtab_b.gif
-%%PORTDOCS%%%%DOCSDIR%%/c/html/rtab_l.gif
-%%PORTDOCS%%%%DOCSDIR%%/c/html/rtab_r.gif
-%%PORTDOCS%%%%DOCSDIR%%/c/html/terminal.png
-%%PORTDOCS%%%%DOCSDIR%%/code/html/rtab_b.gif
-%%PORTDOCS%%%%DOCSDIR%%/code/html/rtab_l.gif
-%%PORTDOCS%%%%DOCSDIR%%/code/html/rtab_r.gif
+%%DOXYGEN%%%%DOCSDIR%%/c/html/documentation.png
+%%DOXYGEN%%%%DOCSDIR%%/c/html/download.png
+%%DOXYGEN%%%%DOCSDIR%%/c/html/modules.png
+%%DOXYGEN%%%%DOCSDIR%%/c/html/noisepattern.png
+%%DOXYGEN%%%%DOCSDIR%%/c/html/rtab_b.gif
+%%DOXYGEN%%%%DOCSDIR%%/c/html/rtab_l.gif
+%%DOXYGEN%%%%DOCSDIR%%/c/html/rtab_r.gif
+%%DOXYGEN%%%%DOCSDIR%%/c/html/terminal.png
+%%DOXYGEN%%%%DOCSDIR%%/code/html/rtab_b.gif
+%%DOXYGEN%%%%DOCSDIR%%/code/html/rtab_l.gif
+%%DOXYGEN%%%%DOCSDIR%%/code/html/rtab_r.gif
%%PORTDOCS%%%%DOCSDIR%%/cxx/examples/Makefile
%%PORTDOCS%%%%DOCSDIR%%/cxx/examples/binary.cpp
%%PORTDOCS%%%%DOCSDIR%%/cxx/examples/callback.cpp
@@ -141,14 +141,14 @@ lib/zorba/core/%%FULLVERSION%%/org/expath/ns/libfile_2.0.so
%%PORTDOCS%%%%DOCSDIR%%/cxx/examples/serialization.cpp
%%PORTDOCS%%%%DOCSDIR%%/cxx/examples/simple.cpp
%%PORTDOCS%%%%DOCSDIR%%/cxx/examples/uri_resolvers.cpp
-%%PORTDOCS%%%%DOCSDIR%%/cxx/html/documentation.png
-%%PORTDOCS%%%%DOCSDIR%%/cxx/html/download.png
-%%PORTDOCS%%%%DOCSDIR%%/cxx/html/modules.png
-%%PORTDOCS%%%%DOCSDIR%%/cxx/html/noisepattern.png
-%%PORTDOCS%%%%DOCSDIR%%/cxx/html/rtab_b.gif
-%%PORTDOCS%%%%DOCSDIR%%/cxx/html/rtab_l.gif
-%%PORTDOCS%%%%DOCSDIR%%/cxx/html/rtab_r.gif
-%%PORTDOCS%%%%DOCSDIR%%/cxx/html/terminal.png
+%%DOXYGEN%%%%DOCSDIR%%/cxx/html/documentation.png
+%%DOXYGEN%%%%DOCSDIR%%/cxx/html/download.png
+%%DOXYGEN%%%%DOCSDIR%%/cxx/html/modules.png
+%%DOXYGEN%%%%DOCSDIR%%/cxx/html/noisepattern.png
+%%DOXYGEN%%%%DOCSDIR%%/cxx/html/rtab_b.gif
+%%DOXYGEN%%%%DOCSDIR%%/cxx/html/rtab_l.gif
+%%DOXYGEN%%%%DOCSDIR%%/cxx/html/rtab_r.gif
+%%DOXYGEN%%%%DOCSDIR%%/cxx/html/terminal.png
%%PORTDOCS%%%%DOCSDIR%%/xqdoc/generator/xqdoc-html.xq
%%PORTDOCS%%%%DOCSDIR%%/xqdoc/generator/xqdoc-xml.xq
%%PORTDOCS%%%%DOCSDIR%%/xqdoc/requisites/images/External.gif
@@ -189,34 +189,34 @@ lib/zorba/core/%%FULLVERSION%%/org/expath/ns/libfile_2.0.so
%%PORTDOCS%%%%DOCSDIR%%/xqdoc/requisites/templates/www.functx.com_index.html
%%PORTDOCS%%%%DOCSDIR%%/xqdoc/requisites/templates/www.w3.org_2005_xpath-functions.html
%%PORTDOCS%%%%DOCSDIR%%/xqdoc/requisites/templates/www.w3.org_2005_xpath-functions_math.html
-%%JAVA%%%%PORTDOCS%%%%DOCSDIR%%/xqj/html/rtab_b.gif
-%%JAVA%%%%PORTDOCS%%%%DOCSDIR%%/xqj/html/rtab_r.gif
-%%JAVA%%%%PORTDOCS%%%%DOCSDIR%%/xqj/html/rtab_l.gif
-%%PORTDOCS%%%%DOCSDIR%%/zorba/html/JSONforXQuery.html
-%%PORTDOCS%%%%DOCSDIR%%/zorba/html/W3C-WD.css
-%%PORTDOCS%%%%DOCSDIR%%/zorba/html/XQueryforJSON.html
-%%PORTDOCS%%%%DOCSDIR%%/zorba/html/documentation.png
-%%PORTDOCS%%%%DOCSDIR%%/zorba/html/download.png
-%%PORTDOCS%%%%DOCSDIR%%/zorba/html/modules.png
-%%PORTDOCS%%%%DOCSDIR%%/zorba/html/noisepattern.png
-%%PORTDOCS%%%%DOCSDIR%%/zorba/html/rtab_b.gif
-%%PORTDOCS%%%%DOCSDIR%%/zorba/html/rtab_l.gif
-%%PORTDOCS%%%%DOCSDIR%%/zorba/html/rtab_r.gif
-%%PORTDOCS%%%%DOCSDIR%%/zorba/html/scripting_spec.html
-%%PORTDOCS%%%%DOCSDIR%%/zorba/html/terminal.png
-%%PORTDOCS%%%%DOCSDIR%%/zorba/xqdoc/Makefile
-%%PYTHON%%%%PORTDOCS%%%%DOCSDIR%%/python/html/rtab_b.gif
-%%PYTHON%%%%PORTDOCS%%%%DOCSDIR%%/python/html/rtab_r.gif
-%%PYTHON%%%%PORTDOCS%%%%DOCSDIR%%/python/html/rtab_l.gif
+%%JAVA%%%%DOXYGEN%%%%DOCSDIR%%/xqj/html/rtab_b.gif
+%%JAVA%%%%DOXYGEN%%%%DOCSDIR%%/xqj/html/rtab_r.gif
+%%JAVA%%%%DOXYGEN%%%%DOCSDIR%%/xqj/html/rtab_l.gif
+%%DOXYGEN%%%%DOCSDIR%%/zorba/html/JSONforXQuery.html
+%%DOXYGEN%%%%DOCSDIR%%/zorba/html/W3C-WD.css
+%%DOXYGEN%%%%DOCSDIR%%/zorba/html/XQueryforJSON.html
+%%DOXYGEN%%%%DOCSDIR%%/zorba/html/documentation.png
+%%DOXYGEN%%%%DOCSDIR%%/zorba/html/download.png
+%%DOXYGEN%%%%DOCSDIR%%/zorba/html/modules.png
+%%DOXYGEN%%%%DOCSDIR%%/zorba/html/noisepattern.png
+%%DOXYGEN%%%%DOCSDIR%%/zorba/html/rtab_b.gif
+%%DOXYGEN%%%%DOCSDIR%%/zorba/html/rtab_l.gif
+%%DOXYGEN%%%%DOCSDIR%%/zorba/html/rtab_r.gif
+%%DOXYGEN%%%%DOCSDIR%%/zorba/html/scripting_spec.html
+%%DOXYGEN%%%%DOCSDIR%%/zorba/html/terminal.png
+%%DOXYGEN%%%%DOCSDIR%%/zorba/xqdoc/Makefile
+%%PYTHON%%%%DOXYGEN%%%%DOCSDIR%%/python/html/rtab_b.gif
+%%PYTHON%%%%DOXYGEN%%%%DOCSDIR%%/python/html/rtab_r.gif
+%%PYTHON%%%%DOXYGEN%%%%DOCSDIR%%/python/html/rtab_l.gif
%%PYTHON%%%%PORTDOCS%%%%DOCSDIR%%/python/examples/python_test.py
%%RUBY%%share/ruby/zorba_api.so
-%%RUBY%%%%PORTDOCS%%%%DOCSDIR%%/ruby/html/rtab_b.gif
-%%RUBY%%%%PORTDOCS%%%%DOCSDIR%%/ruby/html/rtab_l.gif
-%%RUBY%%%%PORTDOCS%%%%DOCSDIR%%/ruby/html/rtab_r.gif
+%%RUBY%%%%DOXYGEN%%%%DOCSDIR%%/ruby/html/rtab_b.gif
+%%RUBY%%%%DOXYGEN%%%%DOCSDIR%%/ruby/html/rtab_l.gif
+%%RUBY%%%%DOXYGEN%%%%DOCSDIR%%/ruby/html/rtab_r.gif
%%RUBY%%%%PORTDOCS%%%%DOCSDIR%%/ruby/examples/ruby_test.rb
-%%JAVA%%%%PORTDOCS%%%%DOCSDIR%%/java/html/rtab_b.gif
-%%JAVA%%%%PORTDOCS%%%%DOCSDIR%%/java/html/rtab_l.gif
-%%JAVA%%%%PORTDOCS%%%%DOCSDIR%%/java/html/rtab_r.gif
+%%JAVA%%%%DOXYGEN%%%%DOCSDIR%%/java/html/rtab_b.gif
+%%JAVA%%%%DOXYGEN%%%%DOCSDIR%%/java/html/rtab_l.gif
+%%JAVA%%%%DOXYGEN%%%%DOCSDIR%%/java/html/rtab_r.gif
%%DATADIR%%/uris/core/%%FULLVERSION%%/com/functx/www/index.xq
%%DATADIR%%/uris/core/%%FULLVERSION%%/com/functx/www/index_0.0.xq
%%DATADIR%%/uris/core/%%FULLVERSION%%/com/functx/www/index_0.xq