aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2018-04-06 10:47:03 +0000
committerWen Heping <wen@FreeBSD.org>2018-04-06 10:47:03 +0000
commit031a825de3e936f95852f6a6808cf31f3ee84be8 (patch)
treee575bdfb920de866f6da82623f154997e4fce3ad /textproc
parent5bc9a45aefe945d82b8c30d45f705145b33e489d (diff)
downloadports-031a825de3e936f95852f6a6808cf31f3ee84be8.tar.gz
ports-031a825de3e936f95852f6a6808cf31f3ee84be8.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-tablib/Makefile27
-rw-r--r--textproc/py-tablib/distinfo3
-rw-r--r--textproc/py-tablib/pkg-descr6
4 files changed, 37 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 8d2d5450d887..9dc0adf2f3fc 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1394,6 +1394,7 @@
SUBDIR += py-stemming
SUBDIR += py-syck
SUBDIR += py-tabletext
+ SUBDIR += py-tablib
SUBDIR += py-terminaltables
SUBDIR += py-textfsm
SUBDIR += py-texttable
diff --git a/textproc/py-tablib/Makefile b/textproc/py-tablib/Makefile
new file mode 100644
index 000000000000..c03249526115
--- /dev/null
+++ b/textproc/py-tablib/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= tablib
+DISTVERSION= 0.12.1
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= freebsd_ports@k-worx.org
+COMMENT= Format agnostic tabular data library (XLS, JSON, YAML, CSV)
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}odfpy>0:devel/py-odfpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}openpyxl>0:textproc/py-openpyxl@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>0:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}unicodecsv>0:devel/py-unicodecsv@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}xlrd>0:textproc/py-xlrd@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}xlwt>0:textproc/py-xlwt@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/py-tablib/distinfo b/textproc/py-tablib/distinfo
new file mode 100644
index 000000000000..724bda4d0c1a
--- /dev/null
+++ b/textproc/py-tablib/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522915318
+SHA256 (tablib-0.12.1.tar.gz) = b8cf50a61d66655229993f2ee29220553fb2c80403479f8e6de77c0c24649d87
+SIZE (tablib-0.12.1.tar.gz) = 63420
diff --git a/textproc/py-tablib/pkg-descr b/textproc/py-tablib/pkg-descr
new file mode 100644
index 000000000000..2779b3de0c76
--- /dev/null
+++ b/textproc/py-tablib/pkg-descr
@@ -0,0 +1,6 @@
+Tablib is an format-agnostic tabular dataset library, written in Python. It
+allows one to import, export, and manipulate tabular data sets. Advanced
+features include, segregation, dynamic columns, tags & filtering, and seamless
+format import & export.
+
+WWW: http://python-tablib.org