aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-05-31 09:01:12 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-05-31 09:01:12 +0000
commit050ee3ebee5379d981b32a1d2e023a0bbb4cd316 (patch)
tree8f44ce9e414a36ddc98b54fc6784ac763eb57c55 /textproc
parent6fd88f18e4367f623b9c506710833e277af18197 (diff)
downloadports-050ee3ebee5379d981b32a1d2e023a0bbb4cd316.tar.gz
ports-050ee3ebee5379d981b32a1d2e023a0bbb4cd316.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/xml_ez_out/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/textproc/xml_ez_out/Makefile b/textproc/xml_ez_out/Makefile
index f7e5749a78b0..ee3520dff194 100644
--- a/textproc/xml_ez_out/Makefile
+++ b/textproc/xml_ez_out/Makefile
@@ -22,18 +22,16 @@ PORTEXAMPLES= example.gpr tmeztf.adb runme.sh
OPTIONS_DEFINE= DOCS EXAMPLES
-.include <bsd.port.options.mk>
-
post-extract:
- ${CP} ${FILESDIR}/xezo_bld.gpr ${WRKSRC}
- ${SED} -e "s,@PREFIX@,${LOCALBASE},g" ${FILESDIR}/runme.sh.in \
+ @${CP} ${FILESDIR}/xezo_bld.gpr ${WRKSRC}
+ @${SED} -e "s,@PREFIX@,${LOCALBASE},g" ${FILESDIR}/runme.sh.in \
> ${WRKSRC}/runme.sh
do-build:
(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} gnatmake -p -Pxezo_bld)
do-install:
- ${MKDIR} ${STAGEDIR}${PREFIX}/lib/gnat \
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/gnat \
${STAGEDIR}${PREFIX}/lib/xml_ez_out \
${STAGEDIR}${PREFIX}/include/xml_ez_out
${INSTALL_DATA} ${FILESDIR}/xml_ez_out.gpr \
@@ -42,15 +40,15 @@ do-install:
${STAGEDIR}${PREFIX}/include/xml_ez_out
${INSTALL_DATA} ${WRKSRC}/lib/* \
${STAGEDIR}${PREFIX}/lib/xml_ez_out
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${BUILD_WRKSRC}/README ${STAGEDIR}${DOCSDIR}
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
- ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+
+do-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_SCRIPT} ${WRKSRC}/runme.sh ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${BUILD_WRKSRC}/tmeztf.adb \
${FILESDIR}/example.gpr ${STAGEDIR}${EXAMPLESDIR}
-.endif
.include <bsd.port.mk>