aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-21 16:33:15 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-21 16:36:23 +0000
commit311310846ac4091c729aa71d303275436ea79c5a (patch)
tree9059aa59d4308df1738b73c3fdff4aa380a039b2 /textproc
parent37f5e92501dba3e43fc0d335ff9120c1032b2008 (diff)
downloadports-311310846ac4091c729aa71d303275436ea79c5a.tar.gz
ports-311310846ac4091c729aa71d303275436ea79c5a.zip
textproc/py-ini2toml: Add FULL and LITE options
- Bump PORTREVISION for dependency change
Diffstat (limited to 'textproc')
-rw-r--r--textproc/py-ini2toml/Makefile18
1 files changed, 17 insertions, 1 deletions
diff --git a/textproc/py-ini2toml/Makefile b/textproc/py-ini2toml/Makefile
index cf923dba2125..eae08a6d67cb 100644
--- a/textproc/py-ini2toml/Makefile
+++ b/textproc/py-ini2toml/Makefile
@@ -2,6 +2,7 @@
PORTNAME= ini2toml
PORTVERSION= 0.10
+PORTREVISION= 1
CATEGORIES= textproc python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -19,4 +20,19 @@ USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
-.include <bsd.port.mk>
+OPTIONS_DEFINE= FULL LITE
+OPTIONS_DEFAULT=FULL
+FULL_DESC= Create TOML document with TOML-equivalent comment
+LITE_DESC= Create TOML document without comment
+
+FULL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}configupdater>=3.0.1<4:devel/py-configupdater@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tomlkit>=0.10.0<2:textproc/py-tomlkit@${PY_FLAVOR}
+LITE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tomli-w>=0.4.0<2:textproc/py-tomli-w@${PY_FLAVOR}
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 30800 && (${PORT_OPTIONS:MFULL} || ${PORT_OPTIONS:MLITE})
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-metadata>=0:devel/py-importlib-metadata@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>