aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2018-02-21 03:12:49 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2018-02-21 03:12:49 +0000
commit5938a3070d90de06f45ae2fbfd05617a75ec3557 (patch)
tree31d66685b560cc4a30800f094af30da40c55e37c /textproc
parent24fd2356ad9358dc8abeb1a25907e478c260fb3f (diff)
downloadports-5938a3070d90de06f45ae2fbfd05617a75ec3557.tar.gz
ports-5938a3070d90de06f45ae2fbfd05617a75ec3557.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/libepubgen/Makefile43
-rw-r--r--textproc/libepubgen/distinfo3
-rw-r--r--textproc/libepubgen/pkg-descr7
-rw-r--r--textproc/libepubgen/pkg-plist11
5 files changed, 65 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 2319ab4b9a0d..26f80a2530b5 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -416,6 +416,7 @@
SUBDIR += libcue
SUBDIR += libe-book
SUBDIR += libebml
+ SUBDIR += libepubgen
SUBDIR += libextractor
SUBDIR += libexttextcat
SUBDIR += libflate
diff --git a/textproc/libepubgen/Makefile b/textproc/libepubgen/Makefile
new file mode 100644
index 000000000000..b8342d8fa861
--- /dev/null
+++ b/textproc/libepubgen/Makefile
@@ -0,0 +1,43 @@
+# $FreeBSD$
+
+PORTNAME= libepubgen
+PORTVERSION= 0.1.0
+CATEGORIES= textproc
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= greg@unrelenting.technology
+COMMENT= Library for generating documents in ePub format
+
+LICENSE= MPL20
+
+LIB_DEPENDS= librevenge-0.0.so:textproc/librevenge
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/algorithm/string/classification.hpp:devel/boost-libs \
+ ${LOCALBASE}/include/boost/algorithm/string/join.hpp:devel/boost-libs \
+ ${LOCALBASE}/include/boost/algorithm/string/split.hpp:devel/boost-libs \
+ ${LOCALBASE}/include/boost/algorithm/string/trim.hpp:devel/boost-libs \
+ ${LOCALBASE}/include/boost/assign/list_of.hpp:devel/boost-libs \
+ ${LOCALBASE}/include/boost/cstdint.hpp:devel/boost-libs \
+ ${LOCALBASE}/include/boost/functional/hash.hpp:devel/boost-libs
+
+CONFIGURE_ARGS= --disable-werror
+CPPFLAGS+= -I${LOCALBASE}/include
+
+GNU_CONFIGURE= yes
+USES= compiler:features libtool pathfix pkgconfig tar:xz
+USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+
+OPTIONS_DEFINE= DOXYGEN TEST
+OPTIONS_DEFAULT=
+OPTIONS_SUB= yes
+
+TEST_TARGET= check
+TEST_LIB_DEPENDS= libxml2.so:textproc/libxml2 \
+ libcppunit.so:devel/cppunit
+TEST_CONFIGURE_ENABLE= tests
+
+PORTDOCS= *
+DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
+DOXYGEN_CONFIGURE_OFF= --without-docs
+
+.include <bsd.port.mk>
diff --git a/textproc/libepubgen/distinfo b/textproc/libepubgen/distinfo
new file mode 100644
index 000000000000..5f9e449dced7
--- /dev/null
+++ b/textproc/libepubgen/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1517410235
+SHA256 (libepubgen-0.1.0.tar.xz) = eeaa2c19cc487c821b6477194a01b4373bce9368afb644d768d088935e3b3994
+SIZE (libepubgen-0.1.0.tar.xz) = 319652
diff --git a/textproc/libepubgen/pkg-descr b/textproc/libepubgen/pkg-descr
new file mode 100644
index 000000000000..e9e82e60da38
--- /dev/null
+++ b/textproc/libepubgen/pkg-descr
@@ -0,0 +1,7 @@
+libepubgen is a library for generating documents in ePub format, implementing
+librevenge document interfaces. It supports conversion of text documents,
+presentations and vector drawings. Spreadsheets are not supported. As these
+interfaces are used by multiple libraries, libepubgen can be used to generate
+EPUB from many sources.
+
+WWW: http://libepubgen.sourceforge.net/
diff --git a/textproc/libepubgen/pkg-plist b/textproc/libepubgen/pkg-plist
new file mode 100644
index 000000000000..76604a16a58b
--- /dev/null
+++ b/textproc/libepubgen/pkg-plist
@@ -0,0 +1,11 @@
+include/libepubgen-0.1/libepubgen/EPUBDrawingGenerator.h
+include/libepubgen-0.1/libepubgen/EPUBPackage.h
+include/libepubgen-0.1/libepubgen/EPUBPresentationGenerator.h
+include/libepubgen-0.1/libepubgen/EPUBTextGenerator.h
+include/libepubgen-0.1/libepubgen/libepubgen-api.h
+include/libepubgen-0.1/libepubgen/libepubgen-decls.h
+include/libepubgen-0.1/libepubgen/libepubgen.h
+lib/libepubgen-0.1.so
+lib/libepubgen-0.1.so.1
+lib/libepubgen-0.1.so.1.0.0
+libdata/pkgconfig/libepubgen-0.1.pc