aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-04-08 09:55:01 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-04-08 09:55:32 +0000
commit5d88e7c9a90067a3a73c30314e125883d5a1d3c1 (patch)
treec56127459c5f998d5c3c71eba72a79cbc65ff210 /textproc
parent6b408353b42cf859f7349e0a4528dec0e0478b63 (diff)
downloadports-5d88e7c9a90067a3a73c30314e125883d5a1d3c1.tar.gz
ports-5d88e7c9a90067a3a73c30314e125883d5a1d3c1.zip
- Allow to build `textproc/highlight' with optional GUI
- Depend the particular Boost header file while I'm here
Diffstat (limited to 'textproc')
-rw-r--r--textproc/highlight/Makefile17
-rw-r--r--textproc/highlight/pkg-plist11
2 files changed, 26 insertions, 2 deletions
diff --git a/textproc/highlight/Makefile b/textproc/highlight/Makefile
index 2734e5f60d66..2b1f9a9c39c3 100644
--- a/textproc/highlight/Makefile
+++ b/textproc/highlight/Makefile
@@ -12,7 +12,7 @@ COMMENT= Customizable syntax highlighter
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= boost-libs>0:devel/boost-libs
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/scoped_array.hpp:devel/boost-libs
USES= compiler:c++11-lib gmake lua pkgconfig tar:bzip2
USE_CXXSTD= c++11
@@ -20,10 +20,23 @@ MAKEFILE= makefile
MAKE_ARGS= CXX="${CXX}" \
CFLAGS="${CXXFLAGS} ${CPPFLAGS} -DHAVE_DECL_GETOPT" \
LDFLAGS="${LDFLAGS}"
+ALL_TARGET= all # cli
+INSTALL_TARGET= install
PORTDOCS= *
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS GUI
+OPTIONS_SUB= yes
+
+GUI_USES= qt:5
+GUI_USE= QT=buildtools_build,qmake_build,core,gui,widgets
+GUI_ALL_TARGET= gui
+GUI_INSTALL_TARGET= install-gui
+
+post-patch:
+ @${REINPLACE_CMD} -e '/PKGCONFIG/s,lua,&-${LUA_VER}, ; \
+ /LIBS/s,-llua,&-${LUA_VER},' \
+ ${WRKSRC}/src/gui-qt/highlight.pro
post-install:
.for cfg in filetypes lsp
diff --git a/textproc/highlight/pkg-plist b/textproc/highlight/pkg-plist
index d38c739fcb7e..da8fc244b505 100644
--- a/textproc/highlight/pkg-plist
+++ b/textproc/highlight/pkg-plist
@@ -1,8 +1,19 @@
bin/highlight
+%%GUI%%bin/highlight-gui
@sample %%ETCDIR%%/filetypes.conf.sample
@sample %%ETCDIR%%/lsp.conf.sample
man/man1/highlight.1.gz
man/man5/filetypes.conf.5.gz
+%%GUI%%share/applications/highlight.desktop
+%%GUI%%share/icons/hicolor/256x256/apps/highlight.png
+%%GUI%%%%DATADIR%%/gui_files/ext/fileopenfilter.conf
+%%GUI%%%%DATADIR%%/gui_files/l10n/highlight_bg_BG.qm
+%%GUI%%%%DATADIR%%/gui_files/l10n/highlight_cs_CZ.qm
+%%GUI%%%%DATADIR%%/gui_files/l10n/highlight_de_DE.qm
+%%GUI%%%%DATADIR%%/gui_files/l10n/highlight_es_ES.qm
+%%GUI%%%%DATADIR%%/gui_files/l10n/highlight_fr_FR.qm
+%%GUI%%%%DATADIR%%/gui_files/l10n/highlight_it_IT.qm
+%%GUI%%%%DATADIR%%/gui_files/l10n/highlight_zh_CN.qm
%%DATADIR%%/langDefs/abap.lang
%%DATADIR%%/langDefs/abc.lang
%%DATADIR%%/langDefs/abnf.lang