aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-01-09 06:04:05 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-01-09 06:04:05 +0000
commit5dace82881ebf62aedc57d07ec76b50b37ee743e (patch)
tree8736abfc58f3f5cc8489ee6227fc7cc79ac8a7a3 /textproc
parent9853736c5417baa077c981296a8ee32ada261ced (diff)
downloadports-5dace82881ebf62aedc57d07ec76b50b37ee743e.tar.gz
ports-5dace82881ebf62aedc57d07ec76b50b37ee743e.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/ocaml-yaxpo/Makefile50
-rw-r--r--textproc/ocaml-yaxpo/distinfo1
-rw-r--r--textproc/ocaml-yaxpo/pkg-comment1
-rw-r--r--textproc/ocaml-yaxpo/pkg-descr11
-rw-r--r--textproc/ocaml-yaxpo/pkg-plist38
6 files changed, 102 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 82c09123915d..daefa0ae1ab8 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -142,6 +142,7 @@
SUBDIR += nl-ispell
SUBDIR += no-aspell
SUBDIR += no-ispell
+ SUBDIR += ocaml-yaxpo
SUBDIR += openjade
SUBDIR += opensched
SUBDIR += opensp
diff --git a/textproc/ocaml-yaxpo/Makefile b/textproc/ocaml-yaxpo/Makefile
new file mode 100644
index 000000000000..71d409e4e44e
--- /dev/null
+++ b/textproc/ocaml-yaxpo/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: ocaml yaxpo
+# Date created: Thu Jan 9 05:25:48 UTC 2003
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= yaxpo
+PORTVERSION= 0.0.${DATE_VERSION}
+CATEGORIES= textproc
+MASTER_SITES= http://mikelin.mit.edu/yaxpo/
+PKGNAMEPREFIX= ocaml-
+DISTNAME= yaxpo
+
+MAINTAINER= lioux@FreeBSD.org
+
+BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
+
+USE_REINPLACE= yes
+
+ALL_TARGET= yaxpo
+
+DATE_VERSION= 20020816
+
+.ifndef(NOPORTDOCS)
+ALL_TARGET+= doc
+.endif
+
+post-configure:
+# PREFIX safeness
+ @${REINPLACE_CMD} -E -e \
+ 's|^(INSTALLDIR).*$$|\1=${PREFIX}/lib/ocaml|' \
+ ${WRKSRC}/Makefile
+
+pre-install:
+# in pre-install to make sure we're using the correct user:group
+# combo
+ @${REINPLACE_CMD} -E -e \
+ 's|cp -f |${INSTALL_DATA} |' \
+ ${WRKSRC}/Makefile
+# create installation dir
+ @${MKDIR} ${PREFIX}/lib/ocaml
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/ocaml-yaxpo/distinfo b/textproc/ocaml-yaxpo/distinfo
new file mode 100644
index 000000000000..c3581985b706
--- /dev/null
+++ b/textproc/ocaml-yaxpo/distinfo
@@ -0,0 +1 @@
+MD5 (yaxpo.tar.gz) = e873b78a042606058cd1f9bafc132faf
diff --git a/textproc/ocaml-yaxpo/pkg-comment b/textproc/ocaml-yaxpo/pkg-comment
new file mode 100644
index 000000000000..18a3695cdfca
--- /dev/null
+++ b/textproc/ocaml-yaxpo/pkg-comment
@@ -0,0 +1 @@
+Non-validating XML 1.0 + XMLNS processing suite for Objective Caml
diff --git a/textproc/ocaml-yaxpo/pkg-descr b/textproc/ocaml-yaxpo/pkg-descr
new file mode 100644
index 000000000000..f7d8a49f001b
--- /dev/null
+++ b/textproc/ocaml-yaxpo/pkg-descr
@@ -0,0 +1,11 @@
+[ excerpt from developer's www site ]
+
+Yaxpo is a hand-written nonvalidating XML 1.0 + XMLNS processing
+suite for Objective Caml, designed for flexibility in new and unusual
+applications of XML. The Yaxpo parser provides all three pull, push
+(SAX-like), and accumulate (DOM-like) interfaces. The latter of
+these provides a data model complete with DOM-like constructors,
+accessors, mutators, and serializers, enabling you to manipulate
+and emit XML as well as parse it.
+
+WWW: http://mikelin.mit.edu/yaxpo/
diff --git a/textproc/ocaml-yaxpo/pkg-plist b/textproc/ocaml-yaxpo/pkg-plist
new file mode 100644
index 000000000000..c0f66672448f
--- /dev/null
+++ b/textproc/ocaml-yaxpo/pkg-plist
@@ -0,0 +1,38 @@
+lib/ocaml/cps_reader.cmi
+lib/ocaml/u_char.cmi
+lib/ocaml/utf8_char.cmi
+lib/ocaml/yaxpo.a
+lib/ocaml/yaxpo.cma
+lib/ocaml/yaxpo.cmi
+lib/ocaml/yaxpo.cmxa
+lib/ocaml/yaxpodom.cmi
+lib/ocaml/yaxposax.cmi
+%%PORTDOCS%%share/doc/yaxpo/Cps_reader.html
+%%PORTDOCS%%share/doc/yaxpo/Cps_reader.t.html
+%%PORTDOCS%%share/doc/yaxpo/U_char.html
+%%PORTDOCS%%share/doc/yaxpo/Utf8_char.html
+%%PORTDOCS%%share/doc/yaxpo/Yaxpo.html
+%%PORTDOCS%%share/doc/yaxpo/Yaxpodom.Namespace_utils.html
+%%PORTDOCS%%share/doc/yaxpo/Yaxpodom.html
+%%PORTDOCS%%share/doc/yaxpo/Yaxposax.html
+%%PORTDOCS%%share/doc/yaxpo/index.html
+%%PORTDOCS%%share/doc/yaxpo/index_attributes.html
+%%PORTDOCS%%share/doc/yaxpo/index_class_types.html
+%%PORTDOCS%%share/doc/yaxpo/index_classes.html
+%%PORTDOCS%%share/doc/yaxpo/index_exceptions.html
+%%PORTDOCS%%share/doc/yaxpo/index_methods.html
+%%PORTDOCS%%share/doc/yaxpo/index_module_types.html
+%%PORTDOCS%%share/doc/yaxpo/index_modules.html
+%%PORTDOCS%%share/doc/yaxpo/index_types.html
+%%PORTDOCS%%share/doc/yaxpo/index_values.html
+%%PORTDOCS%%share/doc/yaxpo/style.css
+%%PORTDOCS%%share/doc/yaxpo/type_Cps_reader.html
+%%PORTDOCS%%share/doc/yaxpo/type_Cps_reader.t.html
+%%PORTDOCS%%share/doc/yaxpo/type_U_char.html
+%%PORTDOCS%%share/doc/yaxpo/type_Utf8_char.html
+%%PORTDOCS%%share/doc/yaxpo/type_Yaxpo.html
+%%PORTDOCS%%share/doc/yaxpo/type_Yaxpodom.Namespace_utils.html
+%%PORTDOCS%%share/doc/yaxpo/type_Yaxpodom.html
+%%PORTDOCS%%share/doc/yaxpo/type_Yaxposax.html
+%%PORTDOCS%%@dirrm share/doc/yaxpo
+@unexec rmdir %D/lib/ocaml 2>/dev/null || true