aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2022-06-24 20:21:29 +0000
committerThierry Thomas <thierry@FreeBSD.org>2022-06-24 21:05:52 +0000
commit6ea978e4f4873797ca06257d90cc294747b01de4 (patch)
tree6f3700e900f0f8be9fb31037d13ba3d61a3d34b1 /textproc
parente43ac399ad9ff933be33b50785c56e9cbcb2f300 (diff)
downloadports-6ea978e4f4873797ca06257d90cc294747b01de4.tar.gz
ports-6ea978e4f4873797ca06257d90cc294747b01de4.zip
textproc/py-wordcloud: upgrade to 1.8.1
Remark: no more docs nor examples, just run `wordcloud_cli --help'.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/py-wordcloud/Makefile35
-rw-r--r--textproc/py-wordcloud/distinfo6
-rw-r--r--textproc/py-wordcloud/files/patch-wordcloud_query__integral__image.c82
-rw-r--r--textproc/py-wordcloud/pkg-plist6
4 files changed, 12 insertions, 117 deletions
diff --git a/textproc/py-wordcloud/Makefile b/textproc/py-wordcloud/Makefile
index 2d284a9a1e31..8d24cb9a1b42 100644
--- a/textproc/py-wordcloud/Makefile
+++ b/textproc/py-wordcloud/Makefile
@@ -1,50 +1,33 @@
# Created by: Thierry Thomas <thierry@pompo.net>
-PORTNAME= word_cloud
-DISTVERSION= 1.5.0
+PORTNAME= wordcloud
+DISTVERSION= 1.8.1
CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= thierry@FreeBSD.org
COMMENT= Little word cloud generator in Python
LICENSE= MIT
-LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYNUMPY} \
${PY_PILLOW}
RUN_DEPENDS= ${PYNUMPY} \
${PY_PILLOW} \
${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${PY_FLAVOR}
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pluggy>0:devel/py-pluggy@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${PY_FLAVOR}
-USE_GITHUB= yes
-GH_ACCOUNT= amueller
+#USE_GITHUB= yes
+#GH_ACCOUNT= amueller
-USES= python:3.7+ shebangfix
+USES= python:3.7+
USE_PYTHON= distutils
-SHEBANG_FILES= doc/*.sh examples/*.py
-
-OPTIONS_DEFINE= DOCS EXAMPLES
PLIST_SUB+= VER=${PORTVERSION}
TEST_TARGET= test
-PORTDOCS= *
-PORTEXAMPLES= *
-
-post-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${CP} -R ${WRKSRC}/doc/ ${STAGEDIR}${DOCSDIR}
-
-post-install-EXAMPLES-on:
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${CP} -R ${WRKSRC}/examples/ ${STAGEDIR}${EXAMPLESDIR}
-do-test: install
- ${REINPLACE_CMD} -e 's|--cov --cov-report xml ||' ${WRKSRC}/setup.cfg
- ${REINPLACE_CMD} -e 's|"python |"${PYTHON_CMD} |' ${WRKSRC}/test/test_wordcloud_cli.py
- (cd ${TEST_WRKSRC} && py.test)
+.if !defined(WITH_DEBUG)
+LDFLAGS+= -s
+.endif
.include <bsd.port.mk>
diff --git a/textproc/py-wordcloud/distinfo b/textproc/py-wordcloud/distinfo
index 00ee0d56ff93..42d5addd8531 100644
--- a/textproc/py-wordcloud/distinfo
+++ b/textproc/py-wordcloud/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1608913996
-SHA256 (amueller-word_cloud-1.5.0_GH0.tar.gz) = 685f35ded1f8a69736fd6faba20ec153d6aeb4475d8b22d8a04f600036c7c4d2
-SIZE (amueller-word_cloud-1.5.0_GH0.tar.gz) = 25431213
+TIMESTAMP = 1656089754
+SHA256 (wordcloud-1.8.1.tar.gz) = e6ef771aac17c1cf8558c8d5ef025796184066d7b78f8118aefe011fb0d22952
+SIZE (wordcloud-1.8.1.tar.gz) = 220696
diff --git a/textproc/py-wordcloud/files/patch-wordcloud_query__integral__image.c b/textproc/py-wordcloud/files/patch-wordcloud_query__integral__image.c
deleted file mode 100644
index 13eaff49342d..000000000000
--- a/textproc/py-wordcloud/files/patch-wordcloud_query__integral__image.c
+++ /dev/null
@@ -1,82 +0,0 @@
---- wordcloud/query_integral_image.c.orig 2018-07-26 16:13:02 UTC
-+++ wordcloud/query_integral_image.c
-@@ -15445,7 +15445,9 @@ static PyTypeObject __pyx_type___pyx_array = {
- sizeof(struct __pyx_array_obj), /*tp_basicsize*/
- 0, /*tp_itemsize*/
- __pyx_tp_dealloc_array, /*tp_dealloc*/
-+#if PY_VERSION_HEX < 0x03090000
- 0, /*tp_print*/
-+#endif
- 0, /*tp_getattr*/
- 0, /*tp_setattr*/
- #if PY_MAJOR_VERSION < 3
-@@ -15553,7 +15555,9 @@ static PyTypeObject __pyx_type___pyx_MemviewEnum = {
- sizeof(struct __pyx_MemviewEnum_obj), /*tp_basicsize*/
- 0, /*tp_itemsize*/
- __pyx_tp_dealloc_Enum, /*tp_dealloc*/
-+#if PY_VERSION_HEX < 0x03090000
- 0, /*tp_print*/
-+#endif
- 0, /*tp_getattr*/
- 0, /*tp_setattr*/
- #if PY_MAJOR_VERSION < 3
-@@ -15803,7 +15807,9 @@ static PyTypeObject __pyx_type___pyx_memoryview = {
- sizeof(struct __pyx_memoryview_obj), /*tp_basicsize*/
- 0, /*tp_itemsize*/
- __pyx_tp_dealloc_memoryview, /*tp_dealloc*/
-+#if PY_VERSION_HEX < 0x03090000
- 0, /*tp_print*/
-+#endif
- 0, /*tp_getattr*/
- 0, /*tp_setattr*/
- #if PY_MAJOR_VERSION < 3
-@@ -15930,7 +15936,9 @@ static PyTypeObject __pyx_type___pyx_memoryviewslice =
- sizeof(struct __pyx_memoryviewslice_obj), /*tp_basicsize*/
- 0, /*tp_itemsize*/
- __pyx_tp_dealloc__memoryviewslice, /*tp_dealloc*/
-+#if PY_VERSION_HEX < 0x03090000
- 0, /*tp_print*/
-+#endif
- 0, /*tp_getattr*/
- 0, /*tp_setattr*/
- #if PY_MAJOR_VERSION < 3
-@@ -16519,13 +16527,17 @@ static int __Pyx_modinit_type_init_code(void) {
- /*--- Type init code ---*/
- __pyx_vtabptr_array = &__pyx_vtable_array;
- __pyx_vtable_array.get_memview = (PyObject *(*)(struct __pyx_array_obj *))__pyx_array_get_memview;
-+#if PY_VERSION_HEX < 0x03090000
- if (PyType_Ready(&__pyx_type___pyx_array) < 0) __PYX_ERR(1, 104, __pyx_L1_error)
- __pyx_type___pyx_array.tp_print = 0;
-+#endif
- if (__Pyx_SetVtable(__pyx_type___pyx_array.tp_dict, __pyx_vtabptr_array) < 0) __PYX_ERR(1, 104, __pyx_L1_error)
- if (__Pyx_setup_reduce((PyObject*)&__pyx_type___pyx_array) < 0) __PYX_ERR(1, 104, __pyx_L1_error)
- __pyx_array_type = &__pyx_type___pyx_array;
-+#if PY_VERSION_HEX < 0x03090000
- if (PyType_Ready(&__pyx_type___pyx_MemviewEnum) < 0) __PYX_ERR(1, 278, __pyx_L1_error)
- __pyx_type___pyx_MemviewEnum.tp_print = 0;
-+#endif
- if ((CYTHON_USE_TYPE_SLOTS && CYTHON_USE_PYTYPE_LOOKUP) && likely(!__pyx_type___pyx_MemviewEnum.tp_dictoffset && __pyx_type___pyx_MemviewEnum.tp_getattro == PyObject_GenericGetAttr)) {
- __pyx_type___pyx_MemviewEnum.tp_getattro = __Pyx_PyObject_GenericGetAttr;
- }
-@@ -16539,8 +16551,10 @@ static int __Pyx_modinit_type_init_code(void) {
- __pyx_vtable_memoryview.setitem_indexed = (PyObject *(*)(struct __pyx_memoryview_obj *, PyObject *, PyObject *))__pyx_memoryview_setitem_indexed;
- __pyx_vtable_memoryview.convert_item_to_object = (PyObject *(*)(struct __pyx_memoryview_obj *, char *))__pyx_memoryview_convert_item_to_object;
- __pyx_vtable_memoryview.assign_item_from_object = (PyObject *(*)(struct __pyx_memoryview_obj *, char *, PyObject *))__pyx_memoryview_assign_item_from_object;
-+#if PY_VERSION_HEX < 0x03090000
- if (PyType_Ready(&__pyx_type___pyx_memoryview) < 0) __PYX_ERR(1, 329, __pyx_L1_error)
- __pyx_type___pyx_memoryview.tp_print = 0;
-+#endif
- if ((CYTHON_USE_TYPE_SLOTS && CYTHON_USE_PYTYPE_LOOKUP) && likely(!__pyx_type___pyx_memoryview.tp_dictoffset && __pyx_type___pyx_memoryview.tp_getattro == PyObject_GenericGetAttr)) {
- __pyx_type___pyx_memoryview.tp_getattro = __Pyx_PyObject_GenericGetAttr;
- }
-@@ -16552,8 +16566,10 @@ static int __Pyx_modinit_type_init_code(void) {
- __pyx_vtable__memoryviewslice.__pyx_base.convert_item_to_object = (PyObject *(*)(struct __pyx_memoryview_obj *, char *))__pyx_memoryviewslice_convert_item_to_object;
- __pyx_vtable__memoryviewslice.__pyx_base.assign_item_from_object = (PyObject *(*)(struct __pyx_memoryview_obj *, char *, PyObject *))__pyx_memoryviewslice_assign_item_from_object;
- __pyx_type___pyx_memoryviewslice.tp_base = __pyx_memoryview_type;
-+#if PY_VERSION_HEX < 0x03090000
- if (PyType_Ready(&__pyx_type___pyx_memoryviewslice) < 0) __PYX_ERR(1, 960, __pyx_L1_error)
- __pyx_type___pyx_memoryviewslice.tp_print = 0;
-+#endif
- if ((CYTHON_USE_TYPE_SLOTS && CYTHON_USE_PYTYPE_LOOKUP) && likely(!__pyx_type___pyx_memoryviewslice.tp_dictoffset && __pyx_type___pyx_memoryviewslice.tp_getattro == PyObject_GenericGetAttr)) {
- __pyx_type___pyx_memoryviewslice.tp_getattro = __Pyx_PyObject_GenericGetAttr;
- }
diff --git a/textproc/py-wordcloud/pkg-plist b/textproc/py-wordcloud/pkg-plist
index acbbb5392c93..996556c1176f 100644
--- a/textproc/py-wordcloud/pkg-plist
+++ b/textproc/py-wordcloud/pkg-plist
@@ -1,10 +1,4 @@
bin/wordcloud_cli
-%%PYTHON_SITELIBDIR%%/wordcloud-%%VER%%-py%%PYTHON_VER%%.egg-info/PKG-INFO
-%%PYTHON_SITELIBDIR%%/wordcloud-%%VER%%-py%%PYTHON_VER%%.egg-info/SOURCES.txt
-%%PYTHON_SITELIBDIR%%/wordcloud-%%VER%%-py%%PYTHON_VER%%.egg-info/dependency_links.txt
-%%PYTHON_SITELIBDIR%%/wordcloud-%%VER%%-py%%PYTHON_VER%%.egg-info/entry_points.txt
-%%PYTHON_SITELIBDIR%%/wordcloud-%%VER%%-py%%PYTHON_VER%%.egg-info/requires.txt
-%%PYTHON_SITELIBDIR%%/wordcloud-%%VER%%-py%%PYTHON_VER%%.egg-info/top_level.txt
%%PYTHON_SITELIBDIR%%/wordcloud/DroidSansMono.ttf
%%PYTHON_SITELIBDIR%%/wordcloud/__init__.py
%%PYTHON_SITELIBDIR%%/wordcloud/__main__.py