aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2008-08-30 17:16:29 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2008-08-30 17:16:29 +0000
commit7c5c013873db523675449a5de31f53876c4fa34a (patch)
treea50ec038aed97c07e18890c451cc902fb945cb6c /textproc
parentbf3903ec82d5035bd07817da41c417a5308006ea (diff)
downloadports-7c5c013873db523675449a5de31f53876c4fa34a.tar.gz
ports-7c5c013873db523675449a5de31f53876c4fa34a.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Text-Flow/Makefile26
-rw-r--r--textproc/p5-Text-Flow/distinfo3
-rw-r--r--textproc/p5-Text-Flow/pkg-descr9
-rw-r--r--textproc/p5-Text-Flow/pkg-plist7
5 files changed, 46 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index da472152b078..000b653a135c 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -584,6 +584,7 @@
SUBDIR += p5-Text-FixEOL
SUBDIR += p5-Text-FixedLength
SUBDIR += p5-Text-FixedLength-Extra
+ SUBDIR += p5-Text-Flow
SUBDIR += p5-Text-Flowchart
SUBDIR += p5-Text-Flowed
SUBDIR += p5-Text-Format
diff --git a/textproc/p5-Text-Flow/Makefile b/textproc/p5-Text-Flow/Makefile
new file mode 100644
index 000000000000..2e3cb9e41de9
--- /dev/null
+++ b/textproc/p5-Text-Flow/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Text-Flow
+# Date created: 2008/08/30
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-Flow
+DISTVERSION= 0.01
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Flexible text flowing and word wrapping for not just ASCII output
+
+RUN_DEPENDS= p5-Moose>=0.45:${PORTSDIR}/devel/p5-Moose \
+ p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-Test-LongString>=0:${PORTSDIR}/devel/p5-Test-LongString
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= ${PORTNAME:S/-/::/g}.3 Text::Flow::Wrap.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Text-Flow/distinfo b/textproc/p5-Text-Flow/distinfo
new file mode 100644
index 000000000000..fb70aa0866cc
--- /dev/null
+++ b/textproc/p5-Text-Flow/distinfo
@@ -0,0 +1,3 @@
+MD5 (Text-Flow-0.01.tar.gz) = 0f5dc1346537813ed9d71585d627c511
+SHA256 (Text-Flow-0.01.tar.gz) = 468d2a6442492174814ba1ec5b2da0655645c5f2fc24c3613a2648b4de8cddf7
+SIZE (Text-Flow-0.01.tar.gz) = 11571
diff --git a/textproc/p5-Text-Flow/pkg-descr b/textproc/p5-Text-Flow/pkg-descr
new file mode 100644
index 000000000000..9a0873cfd09d
--- /dev/null
+++ b/textproc/p5-Text-Flow/pkg-descr
@@ -0,0 +1,9 @@
+This module provides a flexible way to wrap and flow text for both ASCII and
+non-ASCII outputs.
+
+The main purpose of this module is to provide text wrapping and flowing
+features without being tied down to ASCII based output and fixed-width
+fonts. My needs were for a more sophisticated text control in PDF and GIF
+output formats in particular.
+
+WWW: http://search.cpan.org/dist/Text-Flow/
diff --git a/textproc/p5-Text-Flow/pkg-plist b/textproc/p5-Text-Flow/pkg-plist
new file mode 100644
index 000000000000..419ee2d6c7bc
--- /dev/null
+++ b/textproc/p5-Text-Flow/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/Flow/.packlist
+%%SITE_PERL%%/Text/Flow.pm
+%%SITE_PERL%%/Text/Flow/Wrap.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/Flow
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text
+@dirrmtry %%SITE_PERL%%/Text/Flow
+@dirrmtry %%SITE_PERL%%/Text