aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2020-12-24 13:46:01 +0000
committerKai Knoblich <kai@FreeBSD.org>2020-12-24 13:46:01 +0000
commit9cb5898561b302d952fec8e2fac66a945a2c4915 (patch)
tree9274631a296b893d582fb8062e2f256a3a8c8d77 /textproc
parent7d195372928d0063fee4bc1fcf003eae95a2451e (diff)
downloadports-9cb5898561b302d952fec8e2fac66a945a2c4915.tar.gz
ports-9cb5898561b302d952fec8e2fac66a945a2c4915.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/py-jsonslicer/Makefile2
-rw-r--r--textproc/py-libxml2/Makefile2
-rw-r--r--textproc/py-markupsafe/Makefile2
-rw-r--r--textproc/py-mwparserfromhell/Makefile2
-rw-r--r--textproc/py-patiencediff/Makefile2
-rw-r--r--textproc/py-pikepdf/Makefile2
-rw-r--r--textproc/py-pyahocorasick/Makefile2
-rw-r--r--textproc/py-pystemmer/Makefile2
-rw-r--r--textproc/py-regex/Makefile2
9 files changed, 9 insertions, 9 deletions
diff --git a/textproc/py-jsonslicer/Makefile b/textproc/py-jsonslicer/Makefile
index dbb8a0e9d99b..86f0b48b1590 100644
--- a/textproc/py-jsonslicer/Makefile
+++ b/textproc/py-jsonslicer/Makefile
@@ -22,7 +22,7 @@ USE_PYTHON= autoplist distutils
CC= ${CXX}
post-install:
- @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/jsonslicer.so
+ @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/jsonslicer*.so
do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
diff --git a/textproc/py-libxml2/Makefile b/textproc/py-libxml2/Makefile
index c45e46232573..c2841e263a35 100644
--- a/textproc/py-libxml2/Makefile
+++ b/textproc/py-libxml2/Makefile
@@ -28,6 +28,6 @@ DOCSDIR= ${PREFIX}/share/doc/py-libxml2
EXAMPLESDIR= ${PREFIX}/share/examples/py-libxml2
post-install:
- @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/libxml2mod.so
+ @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/libxml2mod*.so
.include "${MASTERDIR}/Makefile"
diff --git a/textproc/py-markupsafe/Makefile b/textproc/py-markupsafe/Makefile
index 420865511b20..67acca6324ac 100644
--- a/textproc/py-markupsafe/Makefile
+++ b/textproc/py-markupsafe/Makefile
@@ -18,6 +18,6 @@ USES= python
USE_PYTHON= autoplist concurrent distutils
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/markupsafe/_speedups.so
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/markupsafe/_speedups*.so
.include <bsd.port.mk>
diff --git a/textproc/py-mwparserfromhell/Makefile b/textproc/py-mwparserfromhell/Makefile
index eb0c9dcb92c3..6413180c302e 100644
--- a/textproc/py-mwparserfromhell/Makefile
+++ b/textproc/py-mwparserfromhell/Makefile
@@ -17,7 +17,7 @@ USES= python
USE_PYTHON= autoplist distutils
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/mwparserfromhell/parser/_tokenizer.so
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/mwparserfromhell/parser/_tokenizer*.so
do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
diff --git a/textproc/py-patiencediff/Makefile b/textproc/py-patiencediff/Makefile
index 7869fb796f0e..dc3df90df1ab 100644
--- a/textproc/py-patiencediff/Makefile
+++ b/textproc/py-patiencediff/Makefile
@@ -17,7 +17,7 @@ USES= python
USE_PYTHON= distutils autoplist
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/patiencediff/_patiencediff_c.so
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/patiencediff/_patiencediff_c*.so
do-test:
cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -v build/
diff --git a/textproc/py-pikepdf/Makefile b/textproc/py-pikepdf/Makefile
index 97196f599e00..bbb6544a0f18 100644
--- a/textproc/py-pikepdf/Makefile
+++ b/textproc/py-pikepdf/Makefile
@@ -39,7 +39,7 @@ JBIG2_DESC= Support for extracting JBIG2 images
JBIG2_RUN_DEPENDS= jbig2dec:graphics/jbig2dec
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/pikepdf/_qpdf.so
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/pikepdf/_qpdf*.so
do-test:
@(cd ${WRKSRC} && ${SETENV} LC_ALL=en_US.UTF-8 ${PYTHON_CMD} -m pytest -rs -v )
diff --git a/textproc/py-pyahocorasick/Makefile b/textproc/py-pyahocorasick/Makefile
index 97930b9f2b20..b4bb736ae2f5 100644
--- a/textproc/py-pyahocorasick/Makefile
+++ b/textproc/py-pyahocorasick/Makefile
@@ -20,7 +20,7 @@ PORTDOCS= README.rst
OPTIONS_DEFINE= DOCS
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/ahocorasick.so
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/ahocorasick*.so
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/textproc/py-pystemmer/Makefile b/textproc/py-pystemmer/Makefile
index d59731ede2a9..3c58626082d9 100644
--- a/textproc/py-pystemmer/Makefile
+++ b/textproc/py-pystemmer/Makefile
@@ -19,6 +19,6 @@ USES= python
USE_PYTHON= autoplist cython distutils
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/Stemmer.so
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/Stemmer*.so
.include <bsd.port.mk>
diff --git a/textproc/py-regex/Makefile b/textproc/py-regex/Makefile
index 802761e935bd..0070574f37cc 100644
--- a/textproc/py-regex/Makefile
+++ b/textproc/py-regex/Makefile
@@ -15,6 +15,6 @@ USES= python
USE_PYTHON= autoplist distutils
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/regex/_regex.so
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/regex/_regex*.so
.include <bsd.port.mk>