aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-10-13 18:41:12 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-10-13 18:41:12 +0000
commita2eb819fd570166d35e02ca8d929a447282662a4 (patch)
treeecfe4ff4ce31a899bfcb9bc1f59dc617ef39825f /textproc
parent62ca169cf406818bbda283372cf9cf35dda1923b (diff)
downloadports-a2eb819fd570166d35e02ca8d929a447282662a4.tar.gz
ports-a2eb819fd570166d35e02ca8d929a447282662a4.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/iiimf-csconv/Makefile41
-rw-r--r--textproc/iiimf-csconv/distinfo4
-rw-r--r--textproc/iiimf-csconv/files/patch-lib_CSConv_configure26
-rw-r--r--textproc/iiimf-csconv/files/patch-lib_CSConv_configure.ac35
-rw-r--r--textproc/iiimf-csconv/files/patch-lib_CSConv_converterPI_configure18
-rw-r--r--textproc/iiimf-csconv/pkg-plist1
6 files changed, 59 insertions, 66 deletions
diff --git a/textproc/iiimf-csconv/Makefile b/textproc/iiimf-csconv/Makefile
index 6f450c36a5a4..e1a08d8fa0d8 100644
--- a/textproc/iiimf-csconv/Makefile
+++ b/textproc/iiimf-csconv/Makefile
@@ -5,43 +5,46 @@
# $FreeBSD$
#
-PORTNAME= iiimf-csconv
-PORTVERSION= ${IIIMF_VER:S/_/./:C/-.*//}
-PORTREVISION= 1
+PORTNAME= csconv
+PORTVERSION= ${IIIMF_VER:S/_/./g:C/-.*//}
CATEGORIES= textproc
-MASTER_SITES= http://www.openi18n.org/download/docs/im-sdk/
+MASTER_SITES= http://www.openi18n.org/download/im-sdk/src/
+PKGNAMEPREFIX= iiimf-
DISTNAME= im-sdk
-DISTFILES= ${DISTNAME}.${IIIMF_VER:S/-/./}${EXTRACT_SUFX}
+DISTFILES= ${DISTNAME}-src-${IIIMF_VER}.tgz
MAINTAINER= kcwu@csie.org
COMMENT= Internet/Intranet Input Method Framework encoding convert library
-IIIMF_VER= r11_4-1467
+IIIMF_VER= r12_0_1-svn1891
WRKSRC= ${WRKDIR}/${DISTNAME}-${IIIMF_VER}/lib/CSConv
-USE_BZIP2= yes
+PATCH_WRKSRC= ${WRKDIR}/${DISTNAME}-${IIIMF_VER}
+USE_ICONV= yes
USE_GMAKE= yes
-INSTALLS_SHLIB= yes
USE_REINPLACE= yes
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX}
+USE_AUTOCONF_VER=259
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -liconv" \
+ PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" PTHREAD_LIBS="${PTHREAD_LIBS}"
post-patch:
- ${REINPLACE_CMD} -e "s,-lpthread,-pthread,g" \
- -e "s,-D_POSIX_C_SOURCE=199506L,,g" \
- -e "s,has_xiccallback=no,has_xiccallback=yes,g" \
- -e "s,/usr/lib/im,${PREFIX}/lib/im,g" \
- -e 's,x"gcc",x"cc",g' \
- ${WRKSRC}/configure
${REINPLACE_CMD} -e "s,/usr/lib/im,${PREFIX}/lib/im,g" \
+ ${WRKSRC}/../../acfiles/im_common.m4 \
+ ${WRKSRC}/configure.ac \
+ ${WRKSRC}/aclocal.m4 \
${WRKSRC}/csconv.h \
${WRKSRC}/converterPI/test/icutest4linux.c \
${WRKSRC}/converterPI/icuconv_relay.c \
- ${WRKSRC}/converterPI/configure \
+ ${WRKSRC}/converterPI/configure.in \
${WRKSRC}/converterPI/icuconv/common/config.h
- ${REINPLACE_CMD} -e "s,-lpthread,-pthread,g" -e "s,-ldl,," \
+ ${REINPLACE_CMD} -e "s,-lpthread,${PTHREAD_LIBS},g" -e "s,-ldl,," -e 's,-lc$$,,' \
${WRKSRC}/converterPI/icuconv/common/Makefile.in \
- ${WRKSRC}/converterPI/icuconv/tools/toolutil/Makefile.in
+ ${WRKSRC}/converterPI/icuconv/tools/toolutil/Makefile.in \
+ ${WRKSRC}/converter/compoundtext/Makefile.in
${REINPLACE_CMD} -e "s,ELIBBAD,-2," \
${WRKSRC}/converterPI/icuconv/common/icuconv.c
+ ${REINPLACE_CMD} -e "s,(LIBS),(LIBS) ${PTHREAD_LIBS},g" \
+ ${WRKSRC}/converterPI/icuconv/tools/makeconv/Makefile.in \
+ ${WRKSRC}/converterPI/icuconv/tools/gencnval/Makefile.in
.include <bsd.port.mk>
diff --git a/textproc/iiimf-csconv/distinfo b/textproc/iiimf-csconv/distinfo
index 69d32b06e569..29d049a782bc 100644
--- a/textproc/iiimf-csconv/distinfo
+++ b/textproc/iiimf-csconv/distinfo
@@ -1,2 +1,2 @@
-MD5 (im-sdk.r11_4.1467.tar.bz2) = ca6b6ac7c41641db6eaa0fa395748f90
-SIZE (im-sdk.r11_4.1467.tar.bz2) = 7253894
+MD5 (im-sdk-src-r12_0_1-svn1891.tgz) = 4e51e4fd07391bd957622db0e89aeefe
+SIZE (im-sdk-src-r12_0_1-svn1891.tgz) = 18206118
diff --git a/textproc/iiimf-csconv/files/patch-lib_CSConv_configure b/textproc/iiimf-csconv/files/patch-lib_CSConv_configure
deleted file mode 100644
index 78e2bc447e73..000000000000
--- a/textproc/iiimf-csconv/files/patch-lib_CSConv_configure
+++ /dev/null
@@ -1,26 +0,0 @@
---- configure.orig Sat Aug 23 09:33:31 2003
-+++ configure Wed Apr 21 12:04:17 2004
-@@ -2772,7 +2772,6 @@
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-lc $LIBS"
- cat >conftest.$ac_ext <<_ACEOF
- #line $LINENO "configure"
- /* confdefs.h. */
-@@ -2819,7 +2818,6 @@
- #define HAVE_LIBC 1
- _ACEOF
-
-- LIBS="-lc $LIBS"
-
- fi
-
-@@ -6220,6 +6218,7 @@
- case "${host}" in
- *solaris*) platform=SOLARIS ;;
- *linux*) platform=LINUX ;;
-+ *freebsd*) platform=FREEBSD ;;
- esac
-
-
diff --git a/textproc/iiimf-csconv/files/patch-lib_CSConv_configure.ac b/textproc/iiimf-csconv/files/patch-lib_CSConv_configure.ac
new file mode 100644
index 000000000000..a0938558e7e1
--- /dev/null
+++ b/textproc/iiimf-csconv/files/patch-lib_CSConv_configure.ac
@@ -0,0 +1,35 @@
+--- lib/CSConv/configure.ac.orig Fri Jun 13 00:27:08 2003
++++ lib/CSConv/configure.ac Sat Sep 4 05:39:51 2004
+@@ -55,8 +55,6 @@
+ AC_PATH_PROG(RM, rm)
+ AC_PATH_PROG(SED, sed)
+
+-AC_CHECK_LIB(c, main)
+-AC_CHECK_LIB(dl, main)
+
+
+ dnl FreeBSD -pthread check - Jonathan McDowell <noodles@earth.li>
+@@ -294,13 +292,8 @@
+ CDEBUGFLAGS=
+ ARFLAGS=ru
+
+- if test x"${CC}" = x"gcc" ; then
+- SHLIBCFLAGS='-fpic'
+- SHLIBLDFLAGS='-shared'
+- else
+- SHLIBCFLAGS=
+- SHLIBLDFLAGS=
+- fi
++ SHLIBCFLAGS='-fpic'
++ SHLIBLDFLAGS='-shared'
+
+ csc_system_name="`uname -s`"
+ ;;
+@@ -314,6 +307,7 @@
+ case "${host}" in
+ *solaris*) platform=SOLARIS ;;
+ *linux*) platform=LINUX ;;
++ *freebsd*) platform=FREEBSD ;;
+ esac
+ AC_SUBST(platform)
+
diff --git a/textproc/iiimf-csconv/files/patch-lib_CSConv_converterPI_configure b/textproc/iiimf-csconv/files/patch-lib_CSConv_converterPI_configure
deleted file mode 100644
index b6fb8419605d..000000000000
--- a/textproc/iiimf-csconv/files/patch-lib_CSConv_converterPI_configure
+++ /dev/null
@@ -1,18 +0,0 @@
---- converterPI/configure.orig Wed Apr 21 12:04:26 2004
-+++ converterPI/configure Wed Apr 21 12:04:34 2004
-@@ -1152,7 +1152,6 @@
- echo $ac_n "(cached) $ac_c" 1>&6
- else
- ac_save_LIBS="$LIBS"
--LIBS="-lc $LIBS"
- cat > conftest.$ac_ext <<EOF
- #line 1158 "configure"
- #include "confdefs.h"
-@@ -1182,7 +1181,6 @@
- #define $ac_tr_lib 1
- EOF
-
-- LIBS="-lc $LIBS"
-
- else
- echo "$ac_t""no" 1>&6
diff --git a/textproc/iiimf-csconv/pkg-plist b/textproc/iiimf-csconv/pkg-plist
index 8a565420591e..68d4aad205ab 100644
--- a/textproc/iiimf-csconv/pkg-plist
+++ b/textproc/iiimf-csconv/pkg-plist
@@ -32,7 +32,6 @@ csconv/ctex_wcs.so
csconv/encoding.norm
csconv/euc_ct.so
csconv/eucw_ct.so
-csconv/iconv.so
csconv/iconv_relay.so
csconv/iconv_relay_mb_wc.so
csconv/iconv_relay_wc_mb.so