aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2021-03-25 08:11:07 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2021-03-25 08:11:07 +0000
commita5a7de1a872f318ed2633c2c54bd625b2ffa2e40 (patch)
treef4673ab16e023fc4110780f67c0c18e16dd9bcd3 /textproc
parent562d171b9dacad8f63e6e4a45035824b10b59341 (diff)
downloadports-a5a7de1a872f318ed2633c2c54bd625b2ffa2e40.tar.gz
ports-a5a7de1a872f318ed2633c2c54bd625b2ffa2e40.zip
Revert r569127, half of the ports tree is skipped after this upgrade
With hat: portmgr Reported by: pkg-fallout
Notes
Notes: svn path=/head/; revision=569185
Diffstat (limited to 'textproc')
-rw-r--r--textproc/py-chardet/Makefile6
-rw-r--r--textproc/py-chardet/distinfo6
-rw-r--r--textproc/py-chardet/files/patch-test.py16
3 files changed, 23 insertions, 5 deletions
diff --git a/textproc/py-chardet/Makefile b/textproc/py-chardet/Makefile
index 2bb120b44e58..7ec9da43af8c 100644
--- a/textproc/py-chardet/Makefile
+++ b/textproc/py-chardet/Makefile
@@ -2,13 +2,15 @@
# $FreeBSD$
PORTNAME= chardet
-PORTVERSION= 4.0.0
+PORTVERSION= 3.0.4
+PORTREVISION= 3
+PORTEPOCH= 1
CATEGORIES= textproc python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= rm@FreeBSD.org
-COMMENT= Universal Character Encoding Detector
+COMMENT= Universal encoding detector for Python 2 and 3
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/LICENSE
diff --git a/textproc/py-chardet/distinfo b/textproc/py-chardet/distinfo
index 106fd302a2ef..67ca82c9295b 100644
--- a/textproc/py-chardet/distinfo
+++ b/textproc/py-chardet/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1616596503
-SHA256 (chardet-4.0.0.tar.gz) = 0d6f53a15db4120f2b08c94f11e7d93d2c911ee118b6b30a04ec3ee8310179fa
-SIZE (chardet-4.0.0.tar.gz) = 1907771
+TIMESTAMP = 1499956132
+SHA256 (chardet-3.0.4.tar.gz) = 84ab92ed1c4d4f16916e05906b6b75a6c0fb5db821cc65e70cbd64a3e2a5eaae
+SIZE (chardet-3.0.4.tar.gz) = 1868453
diff --git a/textproc/py-chardet/files/patch-test.py b/textproc/py-chardet/files/patch-test.py
new file mode 100644
index 000000000000..73c3e092398b
--- /dev/null
+++ b/textproc/py-chardet/files/patch-test.py
@@ -0,0 +1,16 @@
+From 0561ddcedcd12ea1f98b7ddedb93686ed8a5ffa4 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
+Date: Tue, 12 Mar 2019 18:44:36 +0100
+Subject: [PATCH] Support pytest 4, don't apply marks directly to parameters
+
+Fixes https://github.com/chardet/chardet/issues/173
+
+--- test.py.orig 2019-12-18 03:03:28 UTC
++++ test.py
+@@ -59,7 +59,7 @@ def gen_test_params():
+ full_path = join(path, file_name)
+ test_case = full_path, encoding
+ if full_path in EXPECTED_FAILURES:
+- test_case = pytest.mark.xfail(test_case)
++ test_case = pytest.param(*test_case, marks=pytest.mark.xfail)
+ yield test_case