aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2012-05-20 19:31:10 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2012-05-20 19:31:10 +0000
commitb9fbf5572577220135807239e1707b50afc46c4c (patch)
tree97596f010b45c87519ed9c36702adcc9dfeaf0c1 /textproc
parent9efc9d4317d713b1ff09adf93c3b8586da305438 (diff)
downloadports-b9fbf5572577220135807239e1707b50afc46c4c.tar.gz
ports-b9fbf5572577220135807239e1707b50afc46c4c.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/freexl/Makefile29
-rw-r--r--textproc/freexl/distinfo2
-rw-r--r--textproc/freexl/pkg-descr13
-rw-r--r--textproc/freexl/pkg-plist6
5 files changed, 51 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 75f05cde15e6..f9e949d221ad 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -192,6 +192,7 @@
SUBDIR += fpc-aspell
SUBDIR += fpc-libxml2
SUBDIR += freegrep
+ SUBDIR += freexl
SUBDIR += fy-aspell
SUBDIR += ga-aspell
SUBDIR += gastex
diff --git a/textproc/freexl/Makefile b/textproc/freexl/Makefile
new file mode 100644
index 000000000000..a5fccb40062f
--- /dev/null
+++ b/textproc/freexl/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: freexl
+# Date created: 19 May 2012
+# Whom: lbartoletti <coder@tuxfamily.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= freexl
+DISTVERSION= 1.0.0b
+#PORTVERSION= 1.0.0b
+CATEGORIES= textproc
+MASTER_SITES= http://www.gaia-gis.it/gaia-sins/
+
+MAINTAINER= coder@tuxfamily.org
+COMMENT= Library to extract valid data from within an Excel (.xls) spreadsheet
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_ICONV= yes
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -liconv
+CONFIGURE_ARGS+=CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+USE_LDCONFIG= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|g' \
+ ${WRKSRC}/Makefile.in
+.include <bsd.port.mk>
diff --git a/textproc/freexl/distinfo b/textproc/freexl/distinfo
new file mode 100644
index 000000000000..bfe55e3f7c31
--- /dev/null
+++ b/textproc/freexl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (freexl-1.0.0b.tar.gz) = da60c6041badd24114b3e4415d72de50c4f1c243fde179a24494e5bbcdc658f0
+SIZE (freexl-1.0.0b.tar.gz) = 909489
diff --git a/textproc/freexl/pkg-descr b/textproc/freexl/pkg-descr
new file mode 100644
index 000000000000..8c2a3db7e07c
--- /dev/null
+++ b/textproc/freexl/pkg-descr
@@ -0,0 +1,13 @@
+FreeXL is an open source library to extract valid data from within an Excel
+(.xls) spreadsheet.
+FreeXL design goals:
+
+ to be simple and lightweight
+ to be stable, robust and efficient
+ to be easily and universally portable
+ completely ignoring any GUI-related oddity
+
+Note that the final goal means that FreeXL ignores at all fonts, sizes and
+alignments, and most formats. It ignores Pivot Table, Charts, Formulas, Visual
+Basic macros and so on. FreeXL is structurally simple and quite light-weight
+(typically 40-80K of object code, stripped).
diff --git a/textproc/freexl/pkg-plist b/textproc/freexl/pkg-plist
new file mode 100644
index 000000000000..bf8bc0c3f923
--- /dev/null
+++ b/textproc/freexl/pkg-plist
@@ -0,0 +1,6 @@
+include/freexl.h
+lib/libfreexl.a
+lib/libfreexl.la
+lib/libfreexl.so
+lib/libfreexl.so.1
+libdata/pkgconfig/freexl.pc