aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2017-01-20 13:31:05 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2017-01-20 13:31:05 +0000
commitbc48b53f2c73e0f85f8d03138fd9b243c0ca023a (patch)
tree4e6d417cf35b3d210df7522c262f92c189c0e281 /textproc
parent237a2cfa909d28d3432c1a9c3f4418e09256eff9 (diff)
downloadports-bc48b53f2c73e0f85f8d03138fd9b243c0ca023a.tar.gz
ports-bc48b53f2c73e0f85f8d03138fd9b243c0ca023a.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/lowdown/Makefile18
-rw-r--r--textproc/lowdown/distinfo3
-rw-r--r--textproc/lowdown/files/patch-Makefile19
-rw-r--r--textproc/lowdown/files/patch-library.c10
-rw-r--r--textproc/lowdown/files/patch-log.c10
-rw-r--r--textproc/lowdown/pkg-descr7
7 files changed, 68 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index e18c5d131d86..203cf1f7ca22 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -453,6 +453,7 @@
SUBDIR += linuxdoc-tools
SUBDIR += localize
SUBDIR += loook
+ SUBDIR += lowdown
SUBDIR += lt-aspell
SUBDIR += lt-hyphen
SUBDIR += lttoolbox
diff --git a/textproc/lowdown/Makefile b/textproc/lowdown/Makefile
new file mode 100644
index 000000000000..c0fa66a9a449
--- /dev/null
+++ b/textproc/lowdown/Makefile
@@ -0,0 +1,18 @@
+# $FreeBSD$
+
+PORTNAME= lowdown
+PORTVERSION= 0.1.3
+CATEGORIES= textproc
+MASTER_SITES= http://kristaps.bsd.lv/lowdown/snapshots/
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Simple Markdown translator
+
+LICENSE= ISCL
+
+PLIST_FILES= bin/lowdown \
+ include/lowdown.h \
+ lib/liblowdown.a \
+ man/man1/lowdown.1.gz
+
+.include <bsd.port.mk>
diff --git a/textproc/lowdown/distinfo b/textproc/lowdown/distinfo
new file mode 100644
index 000000000000..fa5249500a84
--- /dev/null
+++ b/textproc/lowdown/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1484918286
+SHA256 (lowdown-0.1.3.tar.gz) = f72778b1fde0c1817f7283660faac16e445826eb3be3def622473285096703f5
+SIZE (lowdown-0.1.3.tar.gz) = 44173
diff --git a/textproc/lowdown/files/patch-Makefile b/textproc/lowdown/files/patch-Makefile
new file mode 100644
index 000000000000..26c45b6d2d89
--- /dev/null
+++ b/textproc/lowdown/files/patch-Makefile
@@ -0,0 +1,19 @@
+--- Makefile.orig 2017-01-19 23:17:59 UTC
++++ Makefile
+@@ -21,7 +21,7 @@ LIBDIR = $(PREFIX)/lib
+ INCLUDEDIR = $(PREFIX)/include
+ MANDIR = $(PREFIX)/man
+ WWWDIR = /var/www/vhosts/kristaps.bsd.lv/htdocs/lowdown
+-HTMLS = archive.html index.html lowdown.1.html lowdown.3.html README.html
++HTMLS = archive.html index.html lowdown.1.html README.html
+ PDFS = index.pdf README.pdf
+ MDS = index.md README.md
+ CSSS = template.css mandoc.css
+@@ -54,7 +54,6 @@ install: all
+ install -m 0644 liblowdown.a $(DESTDIR)$(LIBDIR)
+ install -m 0644 lowdown.h $(DESTDIR)$(INCLUDEDIR)
+ install -m 0644 lowdown.1 $(DESTDIR)$(MANDIR)/man1
+- install -m 0644 lowdown.3 $(DESTDIR)$(MANDIR)/man3
+
+ index.xml README.xml index.pdf README.pdf: lowdown
+
diff --git a/textproc/lowdown/files/patch-library.c b/textproc/lowdown/files/patch-library.c
new file mode 100644
index 000000000000..3719c640b5b5
--- /dev/null
+++ b/textproc/lowdown/files/patch-library.c
@@ -0,0 +1,10 @@
+--- library.c.orig 2017-01-19 23:17:59 UTC
++++ library.c
+@@ -16,6 +16,7 @@
+ */
+ #include <err.h>
+ #include <stdio.h>
++#include <stdint.h>
+ #include <stdlib.h>
+ #include <string.h>
+
diff --git a/textproc/lowdown/files/patch-log.c b/textproc/lowdown/files/patch-log.c
new file mode 100644
index 000000000000..a9cb585869b4
--- /dev/null
+++ b/textproc/lowdown/files/patch-log.c
@@ -0,0 +1,10 @@
+--- log.c.orig 2017-01-19 23:17:59 UTC
++++ log.c
+@@ -17,6 +17,7 @@
+ #include <stdarg.h>
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <stdint.h>
+ #include <string.h>
+
+ #include "lowdown.h"
diff --git a/textproc/lowdown/pkg-descr b/textproc/lowdown/pkg-descr
new file mode 100644
index 000000000000..c15f0a2ba62a
--- /dev/null
+++ b/textproc/lowdown/pkg-descr
@@ -0,0 +1,7 @@
+lowdown is just another Markdown translator. It can output traditional HTML or
+a document for your troff type-setter of choice, such as groff(1), Heirloom
+troff, or even mandoc(1). lowdown doesn't require XSLT, Python, or even Perl -
+it's just clean, secure, open source C code with no dependencies. Its
+canonical documentation is the lowdown(1) manpage.
+
+WWW: http://kristaps.bsd.lv/lowdown/