aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2021-07-23 15:30:12 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2021-07-23 15:58:45 +0000
commitc8237f49a7385cbb9e1e9a8578d174c9d5890668 (patch)
treedec53814869e596c3f2ec95ece500975871941ea /textproc
parent3f47964689016911ed8f1e04db942e36ee2e4570 (diff)
downloadports-c8237f49a7385cbb9e1e9a8578d174c9d5890668.tar.gz
ports-c8237f49a7385cbb9e1e9a8578d174c9d5890668.zip
textproc/fop: Update to 2.6
Diffstat (limited to 'textproc')
-rw-r--r--textproc/fop/Makefile2
-rw-r--r--textproc/fop/distinfo6
-rw-r--r--textproc/fop/files/patch-build.xml32
-rw-r--r--textproc/fop/pkg-plist6
4 files changed, 29 insertions, 17 deletions
diff --git a/textproc/fop/Makefile b/textproc/fop/Makefile
index 234699b9d045..249970cfab93 100644
--- a/textproc/fop/Makefile
+++ b/textproc/fop/Makefile
@@ -1,7 +1,7 @@
# Created by: KIRIYAMA Kazuhiko <kiri@FreeBSD.org>
PORTNAME= fop
-DISTVERSION= 2.5
+DISTVERSION= 2.6
CATEGORIES= textproc java
MASTER_SITES= APACHE/xmlgraphics/fop/source/:fop \
SF/offo/offo-hyphenation/2.2:hyph
diff --git a/textproc/fop/distinfo b/textproc/fop/distinfo
index ef59d14f491c..da742ea304f3 100644
--- a/textproc/fop/distinfo
+++ b/textproc/fop/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1609697810
-SHA256 (fop-2.5-src.tar.gz) = 783077318139d581d5f485566d1b08bfc576003c53cfbf5beaeba503a24b4005
-SIZE (fop-2.5-src.tar.gz) = 27447223
+TIMESTAMP = 1627051195
+SHA256 (fop-2.6-src.tar.gz) = 084fa6c9d0a3cc7b76502f69579ba52495a7390cb86341c6aa8b54c006bcb890
+SIZE (fop-2.6-src.tar.gz) = 27478217
SHA256 (offo-hyphenation.zip) = df0b863a2ef269ac7defd497f74da54480cd2c03ad665304e7c05334ab3f289f
SIZE (offo-hyphenation.zip) = 883080
diff --git a/textproc/fop/files/patch-build.xml b/textproc/fop/files/patch-build.xml
index 0b9c20f20c58..f5714e0a2e2b 100644
--- a/textproc/fop/files/patch-build.xml
+++ b/textproc/fop/files/patch-build.xml
@@ -1,6 +1,6 @@
This patch reverts FOP-2895 to avoid dependency on maven.
---- fop/build.xml.orig 2020-05-05 09:42:05 UTC
+--- fop/build.xml.orig 2021-01-12 12:15:02 UTC
+++ fop/build.xml
@@ -207,7 +207,7 @@ list of possible build targets.
<property name="lib.dir" value="${basedir}/lib"/>
@@ -80,17 +80,19 @@ This patch reverts FOP-2895 to avoid dependency on maven.
<fileset dir="${build.classes.dir}" id="transcoder-classes-files">
<patternset refid="transcoder-classes"/>
</fileset>
-@@ -614,15 +667,60 @@ list of possible build targets.
- <include name="commons-logging*.jar"/>
- <include name="xmlgraphics-commons*.jar"/>
- </fileset>
-- <target name="transcoder-pkg" depends="remove-cache" description="Generates the jar for the transcoder package for Batik">
-- <exec executable="mvn" dir="${basedir}/.." failonerror="true">
+@@ -623,28 +676,60 @@ list of possible build targets.
+ <os family="unix" />
+ </condition>
+
+- <target name="transcoder-pkg" depends="remove-cache,transcoder-pkg-unix" description="Generates the jar for the transcoder package for Batik" if="isWindows">
+- <exec executable="cmd" dir="${basedir}/.." failonerror="true">
- <env key="MAVEN_OPTS" value="-Dhttps.protocols=TLSv1,TLSv1.1,TLSv1.2"/>
+- <arg value="/c"/>
+- <arg value="mvn"/>
- <arg value="clean"/>
- <arg value="install"/>
- <arg value="-DskipTests"/>
-- </exec>
+- </exec>
- <copy file="${basedir}/../fop-transcoder/target/fop-transcoder-${version}.jar" tofile="${build.dir}/fop-transcoder.jar"/>
- <copy file="${basedir}/../fop-transcoder-allinone/target/fop-transcoder-allinone-${version}.jar" tofile="${build.dir}/fop-transcoder-allinone.jar"/>
+ <target name="uptodate-transcoder-pkg" depends="compile">
@@ -98,7 +100,17 @@ This patch reverts FOP-2895 to avoid dependency on maven.
+ <srcfiles refid="transcoder-classes-files"/>
+ <srcfiles refid="transcoder-lib-files"/>
+ </uptodate>
-+ </target>
+ </target>
+-
+- <target name="transcoder-pkg-unix" if="isUnix">
+- <exec executable="mvn" dir="${basedir}/.." failonerror="true">
+- <env key="MAVEN_OPTS" value="-Dhttps.protocols=TLSv1,TLSv1.1,TLSv1.2"/>
+- <arg value="clean"/>
+- <arg value="install"/>
+- <arg value="-DskipTests"/>
+- </exec>
+- <copy file="${basedir}/../fop-transcoder/target/fop-transcoder-${version}.jar" tofile="${build.dir}/fop-transcoder.jar"/>
+- <copy file="${basedir}/../fop-transcoder-allinone/target/fop-transcoder-allinone-${version}.jar" tofile="${build.dir}/fop-transcoder-allinone.jar"/>
+ <target name="transcoder-pkg" depends="remove-cache, uptodate-transcoder-pkg, compile" description="Generates the jar for the transcoder package for Batik" unless="transcoder.pkg.uptodate">
+ <echo message="Creating the jar file ${build.dir}/fop-transcoder.jar"/>
+ <property name="fop-transcoder.name" value="FOP Transcoder Package"/>
@@ -148,5 +160,5 @@ This patch reverts FOP-2895 to avoid dependency on maven.
+ <metainf dir="${basedir}/.." includes="LICENSE,NOTICE"/>
+ </jar>
</target>
+
<target name="all" depends="package, servlet, transcoder-pkg, junit"/>
- <!-- "all" target for us Makefile converts ;-) -->
diff --git a/textproc/fop/pkg-plist b/textproc/fop/pkg-plist
index 81c914f11b59..1ce9cd68f076 100644
--- a/textproc/fop/pkg-plist
+++ b/textproc/fop/pkg-plist
@@ -81,14 +81,14 @@ bin/fop
%%DATADIR%%/hyph/uk.xml
%%DATADIR%%/hyph/zh_Latn.xml
%%DATADIR%%/lib/README.txt
-%%DATADIR%%/lib/batik-all-1.13.jar
+%%DATADIR%%/lib/batik-all-1.14.jar
%%DATADIR%%/lib/commons-io-1.3.1.jar
%%DATADIR%%/lib/commons-logging-1.0.4.jar
-%%DATADIR%%/lib/fontbox-2.0.16.jar
+%%DATADIR%%/lib/fontbox-2.0.19.jar
%%DATADIR%%/lib/serializer-2.7.2.jar
%%DATADIR%%/lib/servlet-2.2.jar
%%DATADIR%%/lib/xalan-2.7.2.jar
%%DATADIR%%/lib/xercesImpl-2.12.0.jar
%%DATADIR%%/lib/xml-apis-1.4.01.jar
%%DATADIR%%/lib/xml-apis-ext-1.3.04.jar
-%%DATADIR%%/lib/xmlgraphics-commons-2.4.jar
+%%DATADIR%%/lib/xmlgraphics-commons-2.6.jar