aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-08-09 09:03:23 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-08-09 09:03:23 +0000
commitc83c682335482d405cf33c25e93fe651446bc971 (patch)
tree3fa9e982e6814b4cf5847d280b8e7ea96e6b5bdf /textproc
parentd02adb74b54717006e0bc0472fcb7ce16d5caeb1 (diff)
downloadports-c83c682335482d405cf33c25e93fe651446bc971.tar.gz
ports-c83c682335482d405cf33c25e93fe651446bc971.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/domc/Makefile27
-rw-r--r--textproc/domc/files/patch-Makefile9
-rw-r--r--textproc/domc/pkg-descr2
3 files changed, 21 insertions, 17 deletions
diff --git a/textproc/domc/Makefile b/textproc/domc/Makefile
index a62420ae6aa9..a34171745987 100644
--- a/textproc/domc/Makefile
+++ b/textproc/domc/Makefile
@@ -1,4 +1,4 @@
-# Created by: ijliao
+# Created by: Ying-Chieh Liao <ijliao@FreeBSD.org>
# $FreeBSD$
PORTNAME= domc
@@ -8,27 +8,26 @@ CATEGORIES= textproc
MASTER_SITES= http://www.ioplex.com/~miallen/domc/dl/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A light weight implementation of the DOM in ANSI C
+COMMENT= Lightweight implementation of the DOM in ANSI C
-LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2 \
- mba.0:${PORTSDIR}/devel/libmba
+LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libmba.so:${PORTSDIR}/devel/libmba
-MAN3= DOM_CharacterData.3m DOM_Document.3m DOM_Element.3m \
- DOM_Implementation.3m DOM_NamedNodeMap.3m DOM_Node.3m \
- DOM_NodeList.3m DOM_Text.3m
-MANCOMPRESSED= yes
-
-SHLIB_MAJOR= 0
+USES= gmake
+MAKE_ENV= SHLIB_MAJOR="${SHLIB_MAJOR}" INSTDIR=${PREFIX}
+USE_LDCONFIG= yes
-USE_GMAKE= yes
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-MAKE_ENV+= SHLIB_MAJOR="${SHLIB_MAJOR}" INSTDIR=${PREFIX}
-USE_LDCONFIG= yes
-MAKE_JOBS_UNSAFE= yes
+SHLIB_MAJOR= 0
PLIST_SUB= SHLIB_MAJOR="${SHLIB_MAJOR}"
+MAN3= DOM_CharacterData.3m DOM_Document.3m DOM_Element.3m \
+ DOM_Implementation.3m DOM_NamedNodeMap.3m DOM_Node.3m \
+ DOM_NodeList.3m DOM_Text.3m
+MANCOMPRESSED= yes
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
diff --git a/textproc/domc/files/patch-Makefile b/textproc/domc/files/patch-Makefile
index 7bcc75998ea9..0abe144e9c04 100644
--- a/textproc/domc/files/patch-Makefile
+++ b/textproc/domc/files/patch-Makefile
@@ -22,7 +22,7 @@
#CFLAGS = -Wall -W -DMSGNO -I$(includedir) -L$(libdir) $(RPM_OPT_FLAGS) -ansi -pedantic -Wbad-function-cast -Wcast-align -Wcast-qual -Wchar-subscripts -Winline -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wredundant-decls -Wshadow -Wstrict-prototypes -Wwrite-strings -Wtraditional -Wconversion -Waggregate-return -Wno-parentheses
OBJS = src/expatls.o src/events.o src/node.o src/nodelist.o src/namednodemap.o src/dom.o src/timestamp.o src/wcwidth.o src/mbs.o
MAN = DOM_CharacterData.3m.gz DOM_Document.3m.gz DOM_Element.3m.gz DOM_Implementation.3m.gz DOM_NamedNodeMap.3m.gz DOM_Node.3m.gz DOM_NodeList.3m.gz DOM_Text.3m.gz
-@@ -19,7 +17,7 @@
+@@ -19,12 +17,11 @@
all: $(ARNAME)($(OBJS)) $(SONAME) src/defines.h
$(SONAME): $(OBJS)
@@ -31,7 +31,12 @@
.c.a:
$(CC) $(CFLAGS) -c -o $*.o $<
-@@ -33,12 +31,10 @@
+ ar rv $@ $*.o
+- rm $*.o
+
+ .c.o:
+ $(CC) $(CFLAGS) -fpic -c -o $*.o $<
+@@ -33,12 +30,10 @@
install -d $(libdir)
install -d $(includedir)
install -d $(mandir)/man3
diff --git a/textproc/domc/pkg-descr b/textproc/domc/pkg-descr
index fce737733f2b..5919df8bb403 100644
--- a/textproc/domc/pkg-descr
+++ b/textproc/domc/pkg-descr
@@ -1,5 +1,5 @@
DOMC is a light weight implementation of the DOM in ANSI C as specified in
the W3C Document Object Model Level 1, Level 2, and Level 2 Events
-recommendations.
+recommendations.
WWW: http://www.ioplex.com/~miallen/domc/