aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-09-07 23:24:57 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-09-07 23:24:57 +0000
commitdf98d470f37a89f42112ef828a3701fdc5113304 (patch)
tree16e35671a6472309471cc63da30b8a45117ee8f5 /textproc
parentdbfec5c06bb061610727430fb07f12770f428159 (diff)
downloadports-df98d470f37a89f42112ef828a3701fdc5113304.tar.gz
ports-df98d470f37a89f42112ef828a3701fdc5113304.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/yaml-mode.el-emacs21/Makefile13
-rw-r--r--textproc/yaml-mode.el/Makefile34
-rw-r--r--textproc/yaml-mode.el/distinfo3
-rw-r--r--textproc/yaml-mode.el/files/patch-Makefile17
-rw-r--r--textproc/yaml-mode.el/pkg-descr3
-rw-r--r--textproc/yaml-mode.el/pkg-message8
-rw-r--r--textproc/yaml-mode.el/pkg-plist5
8 files changed, 84 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 5bad8b7318e7..dee7897d48a0 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1043,6 +1043,7 @@
SUBDIR += y2l
SUBDIR += yamcha
SUBDIR += yaml-mode.el
+ SUBDIR += yaml-mode.el-emacs21
SUBDIR += yi-aspell
SUBDIR += yodl
SUBDIR += yould
diff --git a/textproc/yaml-mode.el-emacs21/Makefile b/textproc/yaml-mode.el-emacs21/Makefile
new file mode 100644
index 000000000000..43c4834ab5e6
--- /dev/null
+++ b/textproc/yaml-mode.el-emacs21/Makefile
@@ -0,0 +1,13 @@
+# New ports collection makefile for: yaml-mode.el
+# Date created: 07 Jun 2007
+# Whom: KIMURA Yasuhiro <yasu@utahime.org>
+#
+# $FreeBSD$
+#
+
+MASTERDIR= ${.CURDIR}/../yaml-mode.el
+
+USE_EMACS= yes
+EMACS_PORT_NAME= emacs21
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/yaml-mode.el/Makefile b/textproc/yaml-mode.el/Makefile
new file mode 100644
index 000000000000..647275027afd
--- /dev/null
+++ b/textproc/yaml-mode.el/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: yaml-mode.el
+# Date created: 07 Jun 2007
+# Whom: KIMURA Yasuhiro <yasu@utahime.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= yaml-mode.el
+PORTVERSION= 0.0.3
+CATEGORIES= textproc elisp
+MASTER_SITES= http://yaml-mode.clouder.jp/attachment/wiki/WikiStart/
+PKGNAMESUFFIX= -${EMACS_PORT_NAME}
+DISTNAME= ${PORTNAME:S/.el$//}-${PORTVERSION}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}?format=raw
+
+MAINTAINER= yasu@utahime.org
+COMMENT= Simple major mode to edit YAML file for Emacsen
+
+USE_EMACS= yes
+
+MAKE_ENV+= LISPDIR=${LISPDIR}
+
+LISPDIR= ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for file in Changes README
+ ${INSTALL_MAN} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/textproc/yaml-mode.el/distinfo b/textproc/yaml-mode.el/distinfo
new file mode 100644
index 000000000000..310678faae56
--- /dev/null
+++ b/textproc/yaml-mode.el/distinfo
@@ -0,0 +1,3 @@
+MD5 (yaml-mode-0.0.3.tar.gz?format=raw) = fe3bddf9c12c2ab69f62ccd4109dc59a
+SHA256 (yaml-mode-0.0.3.tar.gz?format=raw) = f0235b33f995a2dc663b65127d298daef2ba65e31af038c5e81b597af43ee0ce
+SIZE (yaml-mode-0.0.3.tar.gz?format=raw) = 5755
diff --git a/textproc/yaml-mode.el/files/patch-Makefile b/textproc/yaml-mode.el/files/patch-Makefile
new file mode 100644
index 000000000000..b8e8cbee8b81
--- /dev/null
+++ b/textproc/yaml-mode.el/files/patch-Makefile
@@ -0,0 +1,17 @@
+--- Makefile.orig Thu Jan 25 15:51:27 2007
++++ Makefile Sat Jul 7 21:41:49 2007
+@@ -1,10 +1,10 @@
+ VERSION=0.0.3
+-EMACS = emacs
+-PREFIX = /usr/local
+-INSTALLLIBDIR = $(PREFIX)/share/emacs/site-lisp
++EMACS = $(EMACS_CMD)
++#PREFIX = /usr/local
++INSTALLLIBDIR = $(LISPDIR)
+ FLAGS = -batch -L $(INSTALLLIBDIR) -q -f batch-byte-compile
+ SRC = yaml-mode.el
+-INSTALL = /usr/bin/install -c -m 444
++INSTALL = $(BSD_INSTALL_DATA)
+
+ all: bytecompile
+
diff --git a/textproc/yaml-mode.el/pkg-descr b/textproc/yaml-mode.el/pkg-descr
new file mode 100644
index 000000000000..f8477170b8a3
--- /dev/null
+++ b/textproc/yaml-mode.el/pkg-descr
@@ -0,0 +1,3 @@
+This is a major mode for editing files in the YAML data serialization format.
+
+WWW: http://yaml-mode.clouder.jp/
diff --git a/textproc/yaml-mode.el/pkg-message b/textproc/yaml-mode.el/pkg-message
new file mode 100644
index 000000000000..11bd32399e87
--- /dev/null
+++ b/textproc/yaml-mode.el/pkg-message
@@ -0,0 +1,8 @@
+**********************************************************************
+To use yaml-mode, you should add following lines to your .emacs file:
+
+(require 'yaml-mode)
+(add-to-list 'auto-mode-alist '("\\.yaml$" . yaml-mode))
+(add-to-list 'auto-mode-alist '("\\.yml$" . yaml-mode))
+
+**********************************************************************
diff --git a/textproc/yaml-mode.el/pkg-plist b/textproc/yaml-mode.el/pkg-plist
new file mode 100644
index 000000000000..37b8bee11ca0
--- /dev/null
+++ b/textproc/yaml-mode.el/pkg-plist
@@ -0,0 +1,5 @@
+%%EMACS_VERSION_SITE_LISPDIR%%/yaml-mode.el
+%%EMACS_VERSION_SITE_LISPDIR%%/yaml-mode.elc
+%%PORTDOCS%%%%DOCSDIR%%/Changes
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%