aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-08-07 08:20:31 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-08-07 08:20:31 +0000
commitfb6ae356b8db6f7f1e096a5184086e108125e03b (patch)
tree4745088df33b52ab175df24c3df5b355bb4a2999 /textproc
parent4bfc6c801eb69c75c6aa1bfcda0b9234ccd667b8 (diff)
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/ruby-html-parser/Makefile35
-rw-r--r--textproc/ruby-html-parser/distinfo1
-rw-r--r--textproc/ruby-html-parser/pkg-comment1
-rw-r--r--textproc/ruby-html-parser/pkg-descr5
-rw-r--r--textproc/ruby-html-parser/pkg-plist5
6 files changed, 48 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index e29427714d71..12fab3104c3a 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -76,6 +76,7 @@
SUBDIR += py-xml
SUBDIR += rand
SUBDIR += rman
+ SUBDIR += ruby-racc
SUBDIR += sarep
SUBDIR += se-ispell
SUBDIR += sgmlformat
diff --git a/textproc/ruby-html-parser/Makefile b/textproc/ruby-html-parser/Makefile
new file mode 100644
index 000000000000..9b2a89e24c3b
--- /dev/null
+++ b/textproc/ruby-html-parser/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: Ruby-html-parser
+# Date created: 7 Aug 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= html-parser
+PORTVERSION= 19990912.p1
+CATEGORIES= textproc # ruby
+MASTER_SITES= http://www.jin.gr.jp/~nahi/Ruby/html-parser/
+PKGNAMEPREFIX= ruby-
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//}
+
+MAINTAINER= knu@FreeBSD.org
+
+BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+
+NO_BUILD= yes
+
+PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
+
+RUBY= ${LOCALBASE}/bin/ruby
+RUBY_VER= 1.4
+RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+
+do-install:
+ @cd ${WRKSRC}; ${RUBY} install.rb
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/ruby/html-parser
+ ${INSTALL_DATA} ${WRKSRC}/README.html ${PREFIX}/share/doc/ruby/html-parser/
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/ruby-html-parser/distinfo b/textproc/ruby-html-parser/distinfo
new file mode 100644
index 000000000000..785f05ea6bdd
--- /dev/null
+++ b/textproc/ruby-html-parser/distinfo
@@ -0,0 +1 @@
+MD5 (html-parser-19990912p1.tar.gz) = f8aaa127c54416ac435c81119adb9fff
diff --git a/textproc/ruby-html-parser/pkg-comment b/textproc/ruby-html-parser/pkg-comment
new file mode 100644
index 000000000000..b6b6be841831
--- /dev/null
+++ b/textproc/ruby-html-parser/pkg-comment
@@ -0,0 +1 @@
+HTML-parser package for Ruby
diff --git a/textproc/ruby-html-parser/pkg-descr b/textproc/ruby-html-parser/pkg-descr
new file mode 100644
index 000000000000..86f3fe102857
--- /dev/null
+++ b/textproc/ruby-html-parser/pkg-descr
@@ -0,0 +1,5 @@
+The html-parser package is a Ruby implementation of the Python's SGML
+parser (sgmllib.py), HTML parser (htmllib.py) and Formatter
+(formatter.py).
+
+WWW: http://www.jin.gr.jp/~nahi/Ruby/html-parser/README.html
diff --git a/textproc/ruby-html-parser/pkg-plist b/textproc/ruby-html-parser/pkg-plist
new file mode 100644
index 000000000000..79190f3860f0
--- /dev/null
+++ b/textproc/ruby-html-parser/pkg-plist
@@ -0,0 +1,5 @@
+lib/ruby/site_ruby/formatter.rb
+lib/ruby/site_ruby/html-parser.rb
+lib/ruby/site_ruby/sgml-parser.rb
+share/doc/ruby/html-parser/README.html
+@dirrm share/doc/ruby/html-parser