aboutsummaryrefslogtreecommitdiff
path: root/ukrainian
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-19 05:31:29 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-19 06:00:49 +0000
commit72664fc2b4d33ca3ae39c8e7ab6f8fa85c08bd63 (patch)
tree5a38291fea0ecf3734c8329b934dc334c8a9feb8 /ukrainian
parent915dbfaa562e20c8402d3873f8bfbf07899f9f8a (diff)
*/*mythes: Avoid using %% in Makefile
Use ${DATAIDR} instead of %%DATADIR%%
Diffstat (limited to 'ukrainian')
-rw-r--r--ukrainian/mythes/Makefile4
-rw-r--r--ukrainian/mythes/Makefile 28
2 files changed, 30 insertions, 2 deletions
diff --git a/ukrainian/mythes/Makefile b/ukrainian/mythes/Makefile
index 41d354055646..8f717bafd6c2 100644
--- a/ukrainian/mythes/Makefile
+++ b/ukrainian/mythes/Makefile
@@ -15,8 +15,8 @@ NO_ARCH= yes
USES= perl5 tar:tgz
USE_PERL5= build
-PLIST_FILES= %%DATADIR%%/th_uk_UA.dat \
- %%DATADIR%%/th_uk_UA.idx
+PLIST_FILES= ${DATADIR}/th_uk_UA.dat \
+ ${DATADIR}/th_uk_UA.idx
do-build:
@${PERL} ${WRKSRC}/bin/th_gen_idx.pl < ${WRKSRC}/src/thesaurus/th_uk_UA.dat > ${WRKSRC}/src/thesaurus/th_uk_UA.idx
diff --git a/ukrainian/mythes/Makefile b/ukrainian/mythes/Makefile
new file mode 100644
index 000000000000..41d354055646
--- /dev/null
+++ b/ukrainian/mythes/Makefile
@@ -0,0 +1,28 @@
+PORTNAME= mythes
+PORTVERSION= 1.8.0
+CATEGORIES= ukrainian textproc
+MASTER_SITES= SF/ispell-uk/spell-uk/${PORTVERSION}
+DISTNAME= spell-uk-${PORTVERSION}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Ukrainian thesaurus
+
+LICENSE= LGPL21 GPLv2
+LICENSE_COMB= dual
+
+NO_ARCH= yes
+USES= perl5 tar:tgz
+USE_PERL5= build
+
+PLIST_FILES= %%DATADIR%%/th_uk_UA.dat \
+ %%DATADIR%%/th_uk_UA.idx
+
+do-build:
+ @${PERL} ${WRKSRC}/bin/th_gen_idx.pl < ${WRKSRC}/src/thesaurus/th_uk_UA.dat > ${WRKSRC}/src/thesaurus/th_uk_UA.idx
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/src/thesaurus/th_uk_UA.dat ${WRKSRC}/src/thesaurus/th_uk_UA.idx ${STAGEDIR}${DATADIR}/
+
+.include <bsd.port.mk>