aboutsummaryrefslogtreecommitdiff
path: root/vietnamese/vn7to8
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2001-02-11 22:15:17 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2001-02-11 22:15:17 +0000
commitdb5b0a31a2841c86e77420e9689c58d84dd64d00 (patch)
treed3fc4231a42b554e54083084091f5567b93cdc64 /vietnamese/vn7to8
parent6fba068a8659e762bfd6e037890d3a1f4d150bfe (diff)
downloadports-db5b0a31a2841c86e77420e9689c58d84dd64d00.tar.gz
ports-db5b0a31a2841c86e77420e9689c58d84dd64d00.zip
Use the new libviet port in building.
Notes
Notes: svn path=/head/; revision=38230
Diffstat (limited to 'vietnamese/vn7to8')
-rw-r--r--vietnamese/vn7to8/Makefile8
-rw-r--r--vietnamese/vn7to8/files/patch-0112
-rw-r--r--vietnamese/vn7to8/files/patch-0211
3 files changed, 15 insertions, 16 deletions
diff --git a/vietnamese/vn7to8/Makefile b/vietnamese/vn7to8/Makefile
index dff369c0e84a..567c486079b0 100644
--- a/vietnamese/vn7to8/Makefile
+++ b/vietnamese/vn7to8/Makefile
@@ -17,9 +17,15 @@ EXTRACT_SUFX= .tar.Z
MAINTAINER= obrien@FreeBSD.org
-CFLAGS+= -I../../include
+BUILD_DEPENDS= ${LOCALBASE}/lib/libviqr.a:${PORTSDIR}/vietnamese/libviet
+
+CFLAGS+= -I${PREFIX}/include/viet
MAN1= vn7to8.1 vn8to7.1 vn80to81.1
+post-extract:
+ @ ${MV} ${WRKDIR}/lib ${WRKDIR}/DONT.lib
+ @ ${MV} ${WRKDIR}/include ${WRKDIR}/DONT.include
+
post-install:
@${INSTALL_MAN} ${FILESDIR}/vn7to8.1 ${PREFIX}/man/man1
@${INSTALL_MAN} ${FILESDIR}/vn80to81.1 ${PREFIX}/man/man1
diff --git a/vietnamese/vn7to8/files/patch-01 b/vietnamese/vn7to8/files/patch-01
index 365e7ec15776..da700624de6c 100644
--- a/vietnamese/vn7to8/files/patch-01
+++ b/vietnamese/vn7to8/files/patch-01
@@ -1,10 +1,14 @@
--- Makefile.orig Mon Sep 14 15:49:45 1992
-+++ Makefile Wed Dec 4 02:54:53 1996
-@@ -6,7 +6,7 @@
++++ Makefile Sun Feb 11 14:13:39 2001
+@@ -4,9 +4,9 @@
+
+ SHELL = /bin/sh
CC = cc
- VNLIBDIR= ../lib
- VNINCDIR= ../include
+-VNLIBDIR= ../lib
+-VNINCDIR= ../include
-BINDIR = /local/usr/bin
++VNLIBDIR= $(PREFIX)/lib
++VNINCDIR= $(PREFIX)/include/viet
+BINDIR = ${PREFIX}/bin
LIBS = $(VNLIBDIR)/libviqr.a $(VNLIBDIR)/libvntype.a
diff --git a/vietnamese/vn7to8/files/patch-02 b/vietnamese/vn7to8/files/patch-02
deleted file mode 100644
index 45efc5aaa195..000000000000
--- a/vietnamese/vn7to8/files/patch-02
+++ /dev/null
@@ -1,11 +0,0 @@
---- ../lib/vntype/Makefile.orig Tue Jan 5 22:18:07 1993
-+++ ../lib/vntype/Makefile Wed Dec 4 03:02:33 1996
-@@ -15,7 +15,7 @@
- #FLAGS = -DNOANSI_C
- CFLAGS = $(FLAGS) $(INC)
- CC = cc
--CPP = /lib/cpp
-+CPP = cpp
-
- .c.o:
- $(CC) $(CFLAGS) -c $*.c