aboutsummaryrefslogtreecommitdiff
path: root/vietnamese/vnpstext
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-09 14:47:53 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-09 16:55:03 +0000
commit874770e983edf276974293e54728d1c64dedf303 (patch)
treeb3ec949a1fce766080ad8cee98606c8e63263345 /vietnamese/vnpstext
parent89f1d74819e1eb5fe6c6a2922f50f2063f991755 (diff)
downloadports-874770e983edf276974293e54728d1c64dedf303.tar.gz
ports-874770e983edf276974293e54728d1c64dedf303.zip
vietnamese/vnpstext: Fix buils with llvm15
- Add LICENSE NONE - Refresh patches
Diffstat (limited to 'vietnamese/vnpstext')
-rw-r--r--vietnamese/vnpstext/Makefile3
-rw-r--r--vietnamese/vnpstext/files/patch-Makefile4
-rw-r--r--vietnamese/vnpstext/files/patch-vnpstext.1V8
-rw-r--r--vietnamese/vnpstext/files/patch-vnpstext.c12
4 files changed, 15 insertions, 12 deletions
diff --git a/vietnamese/vnpstext/Makefile b/vietnamese/vnpstext/Makefile
index 4e9bcf5fdc9a..132a1ce0c5c3 100644
--- a/vietnamese/vnpstext/Makefile
+++ b/vietnamese/vnpstext/Makefile
@@ -1,5 +1,6 @@
PORTNAME= vnpstext
PORTVERSION= 1.1
+PORTREVISION= 1
CATEGORIES= vietnamese print
MASTER_SITES= ftp://ftp.monash.edu.au/pub/vietnam/unix/
DISTNAME= ${PORTNAME}
@@ -8,6 +9,8 @@ EXTRACT_SUFX= .tar.Z
MAINTAINER= ports@FreeBSD.org
COMMENT= Converts 8-bit VISCII Vietnamese text into PostScript
+LICENSE= NONE
+
CFLAGS+= -I../../include
do-install:
diff --git a/vietnamese/vnpstext/files/patch-Makefile b/vietnamese/vnpstext/files/patch-Makefile
index 0795e9e4bc8d..ca0e1404c728 100644
--- a/vietnamese/vnpstext/files/patch-Makefile
+++ b/vietnamese/vnpstext/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Thu May 14 21:59:59 1992
-+++ Makefile Sat Dec 7 23:15:47 1996
+--- Makefile.orig 1992-05-15 04:59:59 UTC
++++ Makefile
@@ -4,7 +4,8 @@
.SUFFIXES: .src .ps .pro
diff --git a/vietnamese/vnpstext/files/patch-vnpstext.1V b/vietnamese/vnpstext/files/patch-vnpstext.1V
index 6ac41ff2d8c0..928f208b5c63 100644
--- a/vietnamese/vnpstext/files/patch-vnpstext.1V
+++ b/vietnamese/vnpstext/files/patch-vnpstext.1V
@@ -1,6 +1,6 @@
---- vnpstext.1V.orig Thu May 14 21:43:57 1992
-+++ vnpstext.1V Sun Dec 8 02:13:22 1996
-@@ -41,7 +41,7 @@
+--- vnpstext.1V.orig 1992-05-15 04:43:57 UTC
++++ vnpstext.1V
+@@ -41,7 +41,7 @@ sizes in normal and bold faces, respectively.
.PP
The location of the prolog file can either be
the current directory, or in
@@ -9,7 +9,7 @@
The latter setting may be overridden by
the environment variable
.I PSLIBDIR.
-@@ -113,7 +113,7 @@
+@@ -113,7 +113,7 @@ The line length is limited to 1024 characters.
Lines are not wrapped. If a line is too long to
fit across a page width, it is truncated (by the printer).
.SH FILES
diff --git a/vietnamese/vnpstext/files/patch-vnpstext.c b/vietnamese/vnpstext/files/patch-vnpstext.c
index 52c6b9fa935a..59050de31ece 100644
--- a/vietnamese/vnpstext/files/patch-vnpstext.c
+++ b/vietnamese/vnpstext/files/patch-vnpstext.c
@@ -1,6 +1,6 @@
---- ./vnpstext.c.orig 1992-09-02 23:01:59.000000000 +0200
-+++ ./vnpstext.c 2013-05-27 16:27:32.390245389 +0200
-@@ -86,7 +86,8 @@
+--- vnpstext.c.orig 1992-09-02 21:01:59 UTC
++++ vnpstext.c
+@@ -86,7 +86,8 @@ main(ac, av)
dofile(input)
FILE *input;
{
@@ -10,7 +10,7 @@
register u_char *s;
register int pageno = 1;
register short col = 0;
-@@ -95,7 +96,8 @@
+@@ -95,7 +96,8 @@ dofile(input)
printf("StartDoc\n");
@@ -20,12 +20,12 @@
if (!*line) printf("B\n");
else {
-@@ -180,7 +182,7 @@
+@@ -180,7 +182,7 @@ doprolog(file)
printf("/S{Lcheck count{gsave show grestore}repeat 0 ld rmoveto}def\n");
printf("/L{Lcheck ld mul 0 exch rmoveto}def\n");
printf("/B{Lcheck 0 ld rmoveto}def\n");
- return;
-+ return NULL;
++ return 0;
}
/* filename specified, use it */