aboutsummaryrefslogtreecommitdiff
path: root/vietnamese/vnroff
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-07-28 09:19:20 +0000
committerJohn Marino <marino@FreeBSD.org>2014-07-28 09:19:20 +0000
commitfcc53d78e7d806a1ddc34060e2ecd6f7f5f1dcc7 (patch)
tree642a8003853d697f1f4330ada53d1fbbe9cb478d /vietnamese/vnroff
parent9cc7f367f39e5a0e8f7237b3a83eabd6d6eecd2f (diff)
downloadports-fcc53d78e7d806a1ddc34060e2ecd6f7f5f1dcc7.tar.gz
ports-fcc53d78e7d806a1ddc34060e2ecd6f7f5f1dcc7.zip
vietnamese/vnroff: integrate pkg-plist and cleanup makefile
The makefile contained DOS CR endings. While removing those, consolidate pkg-plist into the makefile and do some cosmetic clean up. PR: 185986 Submitted by: takefu (airport.fm) Approved by: maintainer timeout (6 months)
Notes
Notes: svn path=/head/; revision=363124
Diffstat (limited to 'vietnamese/vnroff')
-rw-r--r--vietnamese/vnroff/Makefile14
-rw-r--r--vietnamese/vnroff/pkg-plist2
2 files changed, 8 insertions, 8 deletions
diff --git a/vietnamese/vnroff/Makefile b/vietnamese/vnroff/Makefile
index e8107f783d3c..4e1d513f4eda 100644
--- a/vietnamese/vnroff/Makefile
+++ b/vietnamese/vnroff/Makefile
@@ -12,21 +12,23 @@ DISTFILES= vnroff.c.Z vnroff.1.Z
MAINTAINER= obrien@FreeBSD.org
COMMENT= Converts Vietnamese VIQR text into troff format
+PLIST_FILES= bin/vnroff man/man1/vnroff.1.gz
NO_WRKSUBDIR= yes
do-extract:
@${RM} -rf ${WRKDIR}
@${MKDIR} ${WRKDIR}
- @(cd ${WRKDIR} && ${GZCAT} ${DISTDIR}/vnroff.c.Z \
- | ${SED} -e '1,/-cut here-/d' \
+ @(cd ${WRKDIR} && ${GZCAT} ${DISTDIR}/vnroff.c.Z \
+ | ${SED} -e '1,/-cut here-/d' \
> vnroff.c)
- @(cd ${WRKDIR} && ${GZCAT} ${DISTDIR}/vnroff.1.Z \
- | ${SED} -e '1,/Status:/d' -e '//,//d' \
- | ${SED} -e '1,1d' \
+ @(cd ${WRKDIR} && ${GZCAT} ${DISTDIR}/vnroff.1.Z \
+ | ${SED} -e '1,/Status:/d' \
+ | ${SED} -e '1,1d' \
+ | ${TR} -d '\01' \
> vnroff.1)
do-build:
- (cd ${WRKSRC} && ${CC} ${CFLAGS} -o vnroff vnroff.c)
+ cd ${WRKSRC} && ${CC} ${CFLAGS} -o vnroff vnroff.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/vnroff ${STAGEDIR}${PREFIX}/bin
diff --git a/vietnamese/vnroff/pkg-plist b/vietnamese/vnroff/pkg-plist
deleted file mode 100644
index b8989a738845..000000000000
--- a/vietnamese/vnroff/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-bin/vnroff
-man/man1/vnroff.1.gz