aboutsummaryrefslogtreecommitdiff
path: root/www/anyterm
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-10-04 20:45:23 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-10-04 20:45:23 +0000
commitf9f0131edd1ad8103bca26a89e04da109d78ef96 (patch)
tree3b7506c9f28da5e87ffde3b48d1e4915d7f09291 /www/anyterm
parenta4e67553185dba8991ab121b756b4f99d867192a (diff)
downloadports-f9f0131edd1ad8103bca26a89e04da109d78ef96.tar.gz
ports-f9f0131edd1ad8103bca26a89e04da109d78ef96.zip
Notes
Diffstat (limited to 'www/anyterm')
-rw-r--r--www/anyterm/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/www/anyterm/Makefile b/www/anyterm/Makefile
index ff31d7af0b1c..3a69d6b86687 100644
--- a/www/anyterm/Makefile
+++ b/www/anyterm/Makefile
@@ -17,13 +17,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libboost_system.so:devel/boost-libs
-BROKEN_aarch64= does not build: libstdc++.so: undefined reference to __floatunditf@GCC_4.2.0
-BROKEN_armv6= does not build: libstdc++.so: undefined reference to __aeabi_idiv@GCC_3.5
-BROKEN_armv7= does not build: libstdc++.so: undefined reference to __aeabi_idiv@GCC_3.5
-BROKEN_powerpc64= Does not build: ld: cannot find -lboost_system
-
USE_RC_SUBR= anytermd
-USES= gmake iconv localbase tar:tbz2
+USES= compiler:c++11-lang gmake iconv localbase tar:tbz2
USE_GCC= any
ALL_TARGET= default_target
PLIST_FILES= man/man1/anytermd.1.gz \
@@ -41,6 +36,7 @@ post-patch:
-e '/^COMPILE_FLAGS=/s|$$| ${CXXFLAGS}|' \
-e 's|$${OPTIMISE_FLAGS}||' \
-e 's|$$(LINK_FLAGS)|& -L${ICONV_PREFIX}/lib ${ICONV_LIB} |' \
+ -e 's| -L/usr/lib||' \
${WRKSRC}/common.mk
@${REINPLACE_CMD} \
-e '/^COMPILE_FLAGS=/s|$$| ${CXXFLAGS}|' \