aboutsummaryrefslogtreecommitdiff
path: root/www/apache24
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2018-05-02 19:03:18 +0000
committerBernard Spil <brnrd@FreeBSD.org>2018-05-02 19:03:18 +0000
commita443614da050f9f2872182472463f3062ef6e743 (patch)
treee5b684f2f4fb707d1413471d27c09e1e4215934f /www/apache24
parentb9a570764b2f685e4e444dc0868a4777bd647745 (diff)
downloadports-a443614da050f9f2872182472463f3062ef6e743.tar.gz
ports-a443614da050f9f2872182472463f3062ef6e743.zip
www/apache24: Fix runtime failure with LibreSSL 2.7
- Fix LOG_FORENSIC in plist while here PR: 227868 Reported by: Jens K. Loewe <mozilla tuxproject de> Approved by: hat (apache@)
Notes
Notes: svn path=/head/; revision=468867
Diffstat (limited to 'www/apache24')
-rw-r--r--www/apache24/Makefile1
-rw-r--r--www/apache24/files/patch-modules_ssl_mod__ssl.c11
-rw-r--r--www/apache24/files/patch-modules_ssl_ssl__engine__init.c12
-rw-r--r--www/apache24/pkg-plist2
4 files changed, 25 insertions, 1 deletions
diff --git a/www/apache24/Makefile b/www/apache24/Makefile
index a8a119cf298a..6fe43219fee8 100644
--- a/www/apache24/Makefile
+++ b/www/apache24/Makefile
@@ -2,6 +2,7 @@
PORTNAME= apache24
PORTVERSION= 2.4.33
+PORTREVISION= 1
CATEGORIES= www ipv6
MASTER_SITES= APACHE_HTTPD
DISTNAME= httpd-${PORTVERSION}
diff --git a/www/apache24/files/patch-modules_ssl_mod__ssl.c b/www/apache24/files/patch-modules_ssl_mod__ssl.c
new file mode 100644
index 000000000000..42e793e9b5a0
--- /dev/null
+++ b/www/apache24/files/patch-modules_ssl_mod__ssl.c
@@ -0,0 +1,11 @@
+--- modules/ssl/mod_ssl.c.orig 2018-02-13 23:43:36 UTC
++++ modules/ssl/mod_ssl.c
+@@ -398,7 +398,7 @@ static int ssl_hook_pre_config(apr_pool_
+ /* We must register the library in full, to ensure our configuration
+ * code can successfully test the SSL environment.
+ */
+-#if MODSSL_USE_OPENSSL_PRE_1_1_API
++#if MODSSL_USE_OPENSSL_PRE_1_1_API || defined(LIBRESSL_VERSION_NUMBER)
+ (void)CRYPTO_malloc_init();
+ #else
+ OPENSSL_malloc_init();
diff --git a/www/apache24/files/patch-modules_ssl_ssl__engine__init.c b/www/apache24/files/patch-modules_ssl_ssl__engine__init.c
new file mode 100644
index 000000000000..1341e4d5eb7d
--- /dev/null
+++ b/www/apache24/files/patch-modules_ssl_ssl__engine__init.c
@@ -0,0 +1,12 @@
+--- modules/ssl/ssl_engine_init.c.orig 2018-02-13 23:43:36 UTC
++++ modules/ssl/ssl_engine_init.c
+@@ -546,7 +546,7 @@ static apr_status_t ssl_init_ctx_protoco
+ char *cp;
+ int protocol = mctx->protocol;
+ SSLSrvConfigRec *sc = mySrvConfig(s);
+-#if OPENSSL_VERSION_NUMBER >= 0x10100000L
++#if OPENSSL_VERSION_NUMBER >= 0x10100000L && !(defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER < 0x20700000L)
+ int prot;
+ #endif
+
+
diff --git a/www/apache24/pkg-plist b/www/apache24/pkg-plist
index e953535cf1ad..5f3201b4809b 100644
--- a/www/apache24/pkg-plist
+++ b/www/apache24/pkg-plist
@@ -230,7 +230,7 @@ man/man8/rotatelogs.8.gz
man/man8/suexec.8.gz
sbin/apachectl
sbin/apxs
-%%FORENSIC%%sbin/check_forensic
+%%LOG_FORENSIC%%sbin/check_forensic
sbin/checkgid
sbin/dbmmanage
sbin/envvars