aboutsummaryrefslogtreecommitdiff
path: root/www/aws-demos
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-07-04 12:35:35 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-07-04 12:35:35 +0000
commit4934a1218564c2f12decad2d1266e429a87ea89b (patch)
treef78d4a7a2779cc580ef4615e2c585d109158d456 /www/aws-demos
parentcc3063e8db06bfdd8ba29f434b01d37cc561bbd8 (diff)
downloadports-4934a1218564c2f12decad2d1266e429a87ea89b.tar.gz
ports-4934a1218564c2f12decad2d1266e429a87ea89b.zip
www/aws-demos: update to 3.1.0.0
- Update to 3.1.0.0 PR: ports/180251 Submitted by: John Marino <draco@marino.st> (maintainer)
Notes
Notes: svn path=/head/; revision=322271
Diffstat (limited to 'www/aws-demos')
-rw-r--r--www/aws-demos/Makefile13
-rw-r--r--www/aws-demos/distinfo4
-rw-r--r--www/aws-demos/files/patch-demos_test__ldap_test__ldap.gpr11
-rw-r--r--www/aws-demos/pkg-plist7
4 files changed, 24 insertions, 11 deletions
diff --git a/www/aws-demos/Makefile b/www/aws-demos/Makefile
index c83d51884b25..6976b5d286a7 100644
--- a/www/aws-demos/Makefile
+++ b/www/aws-demos/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= aws
-PORTVERSION= 2.10.0
+PORTVERSION= 3.1.0.0
CATEGORIES= www
MASTER_SITES= http://downloads.dragonlace.net/src/
PKGNAMESUFFIX= -demos
@@ -12,11 +12,11 @@ COMMENT= Adacore Ada Web Server demos
BUILD_DEPENDS+= gprbuild>=20120510:${PORTSDIR}/devel/gprbuild \
xmlada>=3.2:${PORTSDIR}/textproc/xmlada \
- aws>=2.10:${PORTSDIR}/www/aws
+ aws>=3.1:${PORTSDIR}/www/aws
USE_BZIP2= yes
USE_GMAKE= yes
-USES+= ada
+USES= ada
CONF_ARGS= PROCESSORS=1
CONF_ARGS+= GCC=ada
@@ -26,8 +26,11 @@ OPTIONS_DEFINE= SSL LDAP
OPTIONS_DEFAULT= SSL
DEMO_DIRS+= auth
+DEMO_DIRS+= autobahn
+DEMO_DIRS+= cert
DEMO_DIRS+= com
DEMO_DIRS+= dispatch
+DEMO_DIRS+= dowload_manager
DEMO_DIRS+= hello_world
DEMO_DIRS+= hotplug
DEMO_DIRS+= jabber_demo
@@ -39,12 +42,14 @@ DEMO_DIRS+= soap_vs
DEMO_DIRS+= split
DEMO_DIRS+= test_mail
DEMO_DIRS+= text_input
+DEMO_DIRS+= upload
DEMO_DIRS+= vh_demo
DEMO_DIRS+= web_block
DEMO_DIRS+= web_block_ajax
DEMO_DIRS+= web_block_ajax_templates
DEMO_DIRS+= web_elements
DEMO_DIRS+= web_mail
+DEMO_DIRS+= websockets
DEMO_DIRS+= wps
DEMO_DIRS+= ws
DEMO_DIRS+= zdemo
@@ -90,7 +95,7 @@ do-build:
.endfor
do-install:
- ${MKDIR} ${PREFIX}/share/examples/aws-demos
+ @${MKDIR} ${PREFIX}/share/examples/aws-demos
.for dd in ${DEMO_DIRS}
${FIND} ${WRKSRC}/demos/${dd} -type f -perm -0001 \
-exec ${INSTALL} {} ${PREFIX}/share/examples/aws-demos/ \;
diff --git a/www/aws-demos/distinfo b/www/aws-demos/distinfo
index b7a68021ea44..4cdc06f0a1fd 100644
--- a/www/aws-demos/distinfo
+++ b/www/aws-demos/distinfo
@@ -1,2 +1,2 @@
-SHA256 (aws-2.10.0.tar.bz2) = 010244129cc736d1ca415162dca79243fb243c3f0b12371a0ffc8a31c8b42f30
-SIZE (aws-2.10.0.tar.bz2) = 1384976
+SHA256 (aws-3.1.0.0.tar.bz2) = bb2896d81ab15f62a6fc8b7ae5c7191bf04ee9875e021ec0639cdbc435f8b8da
+SIZE (aws-3.1.0.0.tar.bz2) = 1529933
diff --git a/www/aws-demos/files/patch-demos_test__ldap_test__ldap.gpr b/www/aws-demos/files/patch-demos_test__ldap_test__ldap.gpr
index cbc1ea411623..f6501c6c36ac 100644
--- a/www/aws-demos/files/patch-demos_test__ldap_test__ldap.gpr
+++ b/www/aws-demos/files/patch-demos_test__ldap_test__ldap.gpr
@@ -1,11 +1,12 @@
---- demos/test_ldap/test_ldap.gpr.orig 2013-04-25 23:03:26.000000000 +0200
-+++ demos/test_ldap/test_ldap.gpr 2013-04-25 23:03:52.000000000 +0200
-@@ -42,7 +42,7 @@
+--- demos/test_ldap/test_ldap.gpr.orig 2013-07-03 01:11:54.000000000 +0000
++++ demos/test_ldap/test_ldap.gpr
+@@ -35,7 +35,8 @@ project Test_LDAP is
when "Windows_NT" =>
for Default_Switches ("Ada") use ("-lwldap32");
when others =>
-- for Default_Switches ("Ada") use ("-lldap");
-+ for Default_Switches ("Ada") use ("-L@PREFIX@/lib", "-lldap");
+- for Default_Switches ("Ada") use ("-lldap", "-llber");
++ for Default_Switches ("Ada") use ("-L@PREFIX@/lib",
++ "-lldap", "-llber");
end case;
end Linker;
diff --git a/www/aws-demos/pkg-plist b/www/aws-demos/pkg-plist
index 5d8efcbd1b39..856bfaa48b3b 100644
--- a/www/aws-demos/pkg-plist
+++ b/www/aws-demos/pkg-plist
@@ -1,8 +1,11 @@
%%OSSL%%%%EXAMPLESDIR%%/agent
%%EXAMPLESDIR%%/auth
+%%EXAMPLESDIR%%/autobahn
+%%EXAMPLESDIR%%/cert
%%EXAMPLESDIR%%/com_1
%%EXAMPLESDIR%%/com_2
%%EXAMPLESDIR%%/dispatch
+%%EXAMPLESDIR%%/download_manager
%%EXAMPLESDIR%%/hello_world
%%EXAMPLESDIR%%/hotplug
@comment broken %%EXAMPLESDIR%%/interoplab_main
@@ -11,6 +14,7 @@
%%EXAMPLESDIR%%/multiple_sessions
%%EXAMPLESDIR%%/res_demo
%%OSSL%%%%EXAMPLESDIR%%/runme
+%%EXAMPLESDIR%%/run.sh
%%EXAMPLESDIR%%/soap_client
%%EXAMPLESDIR%%/soap_cvs
%%EXAMPLESDIR%%/soap_server
@@ -20,15 +24,18 @@
%%LDAP%%%%EXAMPLESDIR%%/test_ldap
%%EXAMPLESDIR%%/test_mail
%%EXAMPLESDIR%%/text_input
+%%EXAMPLESDIR%%/upload
%%EXAMPLESDIR%%/vh_demo
%%EXAMPLESDIR%%/web_block
%%EXAMPLESDIR%%/web_block_ajax
%%EXAMPLESDIR%%/web_block_ajax_templates
%%EXAMPLESDIR%%/web_elements
%%EXAMPLESDIR%%/web_mail
+%%EXAMPLESDIR%%/websock
%%EXAMPLESDIR%%/wps
%%EXAMPLESDIR%%/ws
@comment broken %%EXAMPLESDIR%%/wsdl_demo_client
@comment broken %%EXAMPLESDIR%%/wsdl_demo_server
%%EXAMPLESDIR%%/zdemo
@dirrmtry %%EXAMPLESDIR%%
+@dirrmtry share/examples