aboutsummaryrefslogtreecommitdiff
path: root/www/aws-demos
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-06-23 22:20:35 +0000
committerJohn Marino <marino@FreeBSD.org>2015-06-23 22:20:35 +0000
commitfc445b2e3f2fe16d96e8f4333d11b52df231a9ff (patch)
tree314651731338885ef789fdf94361fb0e78e75437 /www/aws-demos
parentdb109a97b6a1966a6ff296f134ae876b13f79ecf (diff)
downloadports-fc445b2e3f2fe16d96e8f4333d11b52df231a9ff.tar.gz
ports-fc445b2e3f2fe16d96e8f4333d11b52df231a9ff.zip
Ada Framework: Switch to gcc5-aux, upgrade 6 packages at once
The transition from gcc-aux to gcc5-aux in the Ada framework has been blocked by the inability to build gtkada3 and, once resolved, GPS (due to tight locking with compiler). A few days ago, Adacore made their annual release of their main libre products, include GPS. However, some products were tightly coupled with the recent compilers, so in order to upgrade, the compiler had to be switched and dependencies require many ports to be upgraded at once: * lang/asis * devel/gnatcoll * devel/gps * x11-toolkits/gtkada3 * www/aws * www/aws-demos While the version upgrades were modest in most cases (gps, gtkada3), the amount of work put into each port was significant. There are too many improvements to mention here. A few include the removal of dynamic package lists and incorporating gnatcoll into gps to avoid building it twice. A private "exp-run" was done all on all 50+ Ada ports to ensure they still build. Also, a new argument was added to Uses/ada.mk, "run", that pulls in the GNAT compiler as a run depends. This was necessary for GPS that will not launch correctly without the compiler in place.
Notes
Notes: svn path=/head/; revision=390464
Diffstat (limited to 'www/aws-demos')
-rw-r--r--www/aws-demos/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/www/aws-demos/Makefile b/www/aws-demos/Makefile
index b2c82288869c..945de385e9a5 100644
--- a/www/aws-demos/Makefile
+++ b/www/aws-demos/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= aws
-PORTVERSION= 3.2.0.0
-PORTREVISION= 1
+PORTVERSION= 3.3.0.0
CATEGORIES= www
MASTER_SITES= http://downloads.dragonlace.net/src/
PKGNAMESUFFIX= -demos
@@ -78,7 +77,7 @@ DEMO_DIRS+= test_ldap
post-patch:
@${REINPLACE_CMD} -e 's|@PREFIX@|${LOCALBASE}|g' \
${WRKSRC}/demos/test_ldap/test_ldap.gpr
- @${REINPLACE_CMD} -e 's| setup_tp | |' ${WRKSRC}/makefile
+ @${REINPLACE_CMD} -e 's| setup_tp | |' ${WRKSRC}/Makefile
do-configure:
${MKDIR} ${WRKSRC}/.build/native/debug/static/obj